aboutsummaryrefslogtreecommitdiff
path: root/security/libreswan
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-22 01:57:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-22 01:58:00 +0000
commiteb7afecc805bc110e4ee852e4307c38c5f5c45f1 (patch)
treeec15709953eb71f6fd1071323d4c3b5721d9b6ab /security/libreswan
parent673aa41f8e0a40c62fe2a18de776b77a9b719030 (diff)
downloadports-eb7afecc805bc110e4ee852e4307c38c5f5c45f1.tar.gz
ports-eb7afecc805bc110e4ee852e4307c38c5f5c45f1.zip
Diffstat (limited to 'security/libreswan')
-rw-r--r--security/libreswan/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/libreswan/Makefile b/security/libreswan/Makefile
index 5acc76339fa0..0a01f537b014 100644
--- a/security/libreswan/Makefile
+++ b/security/libreswan/Makefile
@@ -23,10 +23,11 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= bison gmake pkgconfig python
CFLAGS+= -I${WRKSRC}/include/unbound
-LDFLAGS+= -lcrypt
MAKE_ARGS= PKG_BASE=${LOCALBASE} \
- NSS_CFLAGS="`pkg-config --cflags nss`" NSPR_LDFLAGS="`pkg-config --libs nss`" \
+ NSS_CFLAGS="`pkg-config --cflags nss`" NSS_LDFLAGS="`pkg-config --libs nss`" \
+ NSPR_LDFLAGS="`pkg-config --libs nspr`" \
+ CRYPT_LDFLAGS=-lcrypt \
USE_PTHREAD_SETSCHEDPRIO=false \
WERROR_CFLAGS="" \
PYTHON_BINARY=${PYTHON_CMD}