aboutsummaryrefslogtreecommitdiff
path: root/security/libsectok
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2005-01-14 13:05:30 +0000
committerBruce M Simpson <bms@FreeBSD.org>2005-01-14 13:05:30 +0000
commit7d447970140cb6af8d05f91b9d2784a0e2cb74e3 (patch)
tree34b5fb614ec37305e505137fd10a03655112ec4c /security/libsectok
parent329803b1d4308e65c1ed6909717dc8c6478d4544 (diff)
downloadports-7d447970140cb6af8d05f91b9d2784a0e2cb74e3.tar.gz
ports-7d447970140cb6af8d05f91b9d2784a0e2cb74e3.zip
Notes
Diffstat (limited to 'security/libsectok')
-rw-r--r--security/libsectok/Makefile13
-rw-r--r--security/libsectok/files/patch-Makefile18
-rw-r--r--security/libsectok/pkg-plist4
3 files changed, 15 insertions, 20 deletions
diff --git a/security/libsectok/Makefile b/security/libsectok/Makefile
index e17ae6802d75..aa38caf8c2d4 100644
--- a/security/libsectok/Makefile
+++ b/security/libsectok/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libsectok
PORTVERSION= 20030619
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
DISTNAME= libsectok-${PORTVERSION}
@@ -20,8 +21,14 @@ USE_OPENSSL= YES
MAN3= sectok.3
-IGNORE= produces a broken package (dangling symlink)
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= "${IGNORE}"
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/sectok.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/libsectok.a ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/libsectok.so.3 ${PREFIX}/lib
+ ${LN} -s ${PREFIX}/lib/libsectok.so.3 ${PREFIX}/lib/libsectok.so
+ ${INSTALL_MAN} ${WRKSRC}/sectok.3 ${PREFIX}/man/man3
+
+PLIST_FILES= include/sectok.h lib/libsectok.a \
+ lib/libsectok.so lib/libsectok.so.3
.include <bsd.port.mk>
diff --git a/security/libsectok/files/patch-Makefile b/security/libsectok/files/patch-Makefile
index 42a45b03cb86..2ebf51522a2c 100644
--- a/security/libsectok/files/patch-Makefile
+++ b/security/libsectok/files/patch-Makefile
@@ -1,7 +1,8 @@
---- Makefile.orig Thu Jan 3 20:26:00 2002
-+++ Makefile Fri Aug 23 13:12:59 2002
+--- Makefile.orig Thu Jun 19 22:02:19 2003
++++ Makefile Fri Jan 14 12:58:03 2005
@@ -1,10 +1,10 @@
- VERSION= 3.1
+-VERSION= 3.1
++VERSION= 3
TARGETS= libsectok.a libsectok.so.$(VERSION)
-PREFIX= /usr/local
+PREFIX?= /usr/local
@@ -12,13 +13,4 @@
+LDFLAGS= -shared -x --whole-archive
# You may have to add getopt.c to SRC if your getopt doesn't have optreset
- SRC= atr.c cmdtab.c cyberflex.c input.c r1r2.c readers.c sc7816.c sectok.c
-@@ -47,6 +47,8 @@
- install :
- $(INSTALL) -m 755 sectok.h $(PREFIX)/include
- $(INSTALL) -m 755 $(TARGETS) $(PREFIX)/lib
-+ ln -s $(PREFIX)/lib/libsectok.so.${VERSION} $(PREFIX)/lib/libsectok.so.3
-+ $(INSTALL) -m 644 sectok.3 $(PREFIX)/man/man3
-
- release :
- rm -rf $(RELEASE)
+ SRC= atr.c cmdtab.c cyberflex.c ifdwrapper.c input.c r1r2.c \
diff --git a/security/libsectok/pkg-plist b/security/libsectok/pkg-plist
deleted file mode 100644
index 145b24ca58d7..000000000000
--- a/security/libsectok/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-include/sectok.h
-lib/libsectok.a
-lib/libsectok.so.3
-lib/libsectok.so.3.1