aboutsummaryrefslogtreecommitdiff
path: root/security/libssh/Makefile
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-07-13 12:57:26 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-07-13 12:57:26 +0000
commitfb892d7018d240ec31772b62462eae46a1f61152 (patch)
tree02a9058fd950a7d0cbf2b984f2c4d599026c400c /security/libssh/Makefile
parentae937334e7a54da0f71e544416f1242eb59f7588 (diff)
downloadports-fb892d7018d240ec31772b62462eae46a1f61152.tar.gz
ports-fb892d7018d240ec31772b62462eae46a1f61152.zip
Notes
Diffstat (limited to 'security/libssh/Makefile')
-rw-r--r--security/libssh/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 5d6aa68aa5a7..822bd8c37543 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= libssh
-PORTVERSION= 0.2
+PORTVERSION= 0.3.0
CATEGORIES= security devel
-MASTER_SITES= http://0xbadc0de.be/libssh/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.libssh.org/files/
MAINTAINER= avl@FreeBSD.org
COMMENT= A library implementing the SSH1 and SSH2 protocol
MAKE_JOBS_SAFE= yes
-GNU_CONFIGURE= yes
+USE_CMAKE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}
+CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
USE_OPENSSL= yes
USE_LDCONFIG= yes
+post-patch:
+ @${MKDIR} ${WRKSRC}/build
+ @${RM} ${WRKSRC}/cmake/Modules/UseDoxygen.cmake
+
.include <bsd.port.mk>