aboutsummaryrefslogtreecommitdiff
path: root/security/libssh2
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2012-02-08 06:58:34 +0000
committerSofian Brabez <sbz@FreeBSD.org>2012-02-08 06:58:34 +0000
commit908d44f3989cd98f465df402f5054312915abf9f (patch)
tree8caa89b0b4062199d7b7f5607d23253d4ac57a35 /security/libssh2
parent6d0e01a6a190cb69e2ca83c6ff384b3bb49e3866 (diff)
downloadports-908d44f3989cd98f465df402f5054312915abf9f.tar.gz
ports-908d44f3989cd98f465df402f5054312915abf9f.zip
Notes
Diffstat (limited to 'security/libssh2')
-rw-r--r--security/libssh2/Makefile1
-rw-r--r--security/libssh2/files/patch-src__libgcrypt.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 69d34309ff74..870808abe572 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libssh2
PORTVERSION= 1.4.0
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/ \
diff --git a/security/libssh2/files/patch-src__libgcrypt.c b/security/libssh2/files/patch-src__libgcrypt.c
new file mode 100644
index 000000000000..825ef1036918
--- /dev/null
+++ b/security/libssh2/files/patch-src__libgcrypt.c
@@ -0,0 +1,11 @@
+--- ./src/libgcrypt.c.orig 2012-02-07 19:05:00.000000000 +0100
++++ ./src/libgcrypt.c 2012-02-07 19:05:11.000000000 +0100
+@@ -581,7 +581,7 @@
+ const char *privatekey,
+ const char *passphrase)
+ {
+- return _libssh_error(session, LIBSSH2_ERROR_FILE,
++ return _libssh2_error(session, LIBSSH2_ERROR_FILE,
+ "Unable to extract public key from private key file: "
+ "Method unimplemented in libgcrypt backend");
+ }