aboutsummaryrefslogtreecommitdiff
path: root/security/libssh
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-07-13 12:57:26 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-07-13 12:57:26 +0000
commitfb892d7018d240ec31772b62462eae46a1f61152 (patch)
tree02a9058fd950a7d0cbf2b984f2c4d599026c400c /security/libssh
parentae937334e7a54da0f71e544416f1242eb59f7588 (diff)
downloadports-fb892d7018d240ec31772b62462eae46a1f61152.tar.gz
ports-fb892d7018d240ec31772b62462eae46a1f61152.zip
Notes
Diffstat (limited to 'security/libssh')
-rw-r--r--security/libssh/Makefile15
-rw-r--r--security/libssh/distinfo6
-rw-r--r--security/libssh/files/patch-Makefile.in11
-rw-r--r--security/libssh/files/patch-cmake_Modules_DefineCompilerFlags.cmake19
-rw-r--r--security/libssh/files/patch-libssh__agent.c13
-rw-r--r--security/libssh/files/patch-libssh__auth.c22
-rw-r--r--security/libssh/files/patch-libssh__buffer.c14
-rw-r--r--security/libssh/files/patch-libssh__channels.c13
-rw-r--r--security/libssh/files/patch-libssh__client.c14
-rw-r--r--security/libssh/files/patch-libssh__crypt.c13
-rw-r--r--security/libssh/files/patch-libssh__dh.c13
-rw-r--r--security/libssh/files/patch-libssh__kex.c13
-rw-r--r--security/libssh/files/patch-libssh__keyfiles.c14
-rw-r--r--security/libssh/files/patch-libssh__messages.c14
-rw-r--r--security/libssh/files/patch-libssh__misc.c10
-rw-r--r--security/libssh/files/patch-libssh__packet.c13
-rw-r--r--security/libssh/files/patch-libssh__sftp.c13
-rw-r--r--security/libssh/files/patch-libssh__sftpserver.c13
-rw-r--r--security/libssh/files/patch-libssh__string.c14
-rw-r--r--security/libssh/files/patch-server.c10
-rw-r--r--security/libssh/pkg-descr2
-rw-r--r--security/libssh/pkg-plist7
22 files changed, 242 insertions, 34 deletions
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 5d6aa68aa5a7..822bd8c37543 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= libssh
-PORTVERSION= 0.2
+PORTVERSION= 0.3.0
CATEGORIES= security devel
-MASTER_SITES= http://0xbadc0de.be/libssh/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.libssh.org/files/
MAINTAINER= avl@FreeBSD.org
COMMENT= A library implementing the SSH1 and SSH2 protocol
MAKE_JOBS_SAFE= yes
-GNU_CONFIGURE= yes
+USE_CMAKE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}
+CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
USE_OPENSSL= yes
USE_LDCONFIG= yes
+post-patch:
+ @${MKDIR} ${WRKSRC}/build
+ @${RM} ${WRKSRC}/cmake/Modules/UseDoxygen.cmake
+
.include <bsd.port.mk>
diff --git a/security/libssh/distinfo b/security/libssh/distinfo
index b56ee442e1ac..a63a568415f7 100644
--- a/security/libssh/distinfo
+++ b/security/libssh/distinfo
@@ -1,3 +1,3 @@
-MD5 (libssh-0.2.tgz) = 8a76c03579a3e27046e6bafe88ffd171
-SHA256 (libssh-0.2.tgz) = 46c3831fd563c54283ebef56e2cb11c27f47b1be9f6cb44f1465897dd7aea5ff
-SIZE (libssh-0.2.tgz) = 329371
+MD5 (libssh-0.3.0.tar.gz) = 2496338686932685c08ed8f6ad185227
+SHA256 (libssh-0.3.0.tar.gz) = d9a7575cd3dfcfcafd3a00c8b9f40baf981b7f2d6edbdd19ea4e6ff07a4a6bf5
+SIZE (libssh-0.3.0.tar.gz) = 234813
diff --git a/security/libssh/files/patch-Makefile.in b/security/libssh/files/patch-Makefile.in
deleted file mode 100644
index 7733ef623ee2..000000000000
--- a/security/libssh/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2009-04-12 20:24:31.000000000 +1000
-+++ Makefile.in 2009-04-12 20:22:37.000000000 +1000
-@@ -28,7 +28,7 @@
- CONFIG = include/libssh/config.h
-
- .PHONY: all
--all: $(CONFIG) SUBDIRS $(OBJECTS) $(APPS)
-+all: $(CONFIG) SUBDIRS
-
- .PHONY: SUBDIRS
- SUBDIRS:
diff --git a/security/libssh/files/patch-cmake_Modules_DefineCompilerFlags.cmake b/security/libssh/files/patch-cmake_Modules_DefineCompilerFlags.cmake
new file mode 100644
index 000000000000..30940dada9f2
--- /dev/null
+++ b/security/libssh/files/patch-cmake_Modules_DefineCompilerFlags.cmake
@@ -0,0 +1,19 @@
+Index: cmake/Modules/DefineCompilerFlags.cmake
+===================================================================
+--- cmake/Modules/DefineCompilerFlags.cmake (revision 772)
++++ cmake/Modules/DefineCompilerFlags.cmake (working copy)
+@@ -29,11 +29,11 @@
+ ERROR_QUIET
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+ )
++ string(REGEX REPLACE "[\r\n]" " " "${_lfs_CFLAGS}" "${${_lfs_CFLAGS}}")
++
++ add_definitions(${_lfs_CFLAGS})
+ endif (CMAKE_SIZEOF_VOID_P MATCHES "8")
+
+- string(REGEX REPLACE "[\r\n]" " " ${_lfs_CFLAGS} "${${_lfs_CFLAGS}}")
+-
+- add_definitions(${_lfs_CFLAGS})
+ add_definitions(-Wall -Wextra -Wmissing-prototypes -Wdeclaration-after-statement -Wunused)
+
+ check_c_compiler_flag("-fstack-protector" WITH_STACK_PROTECTOR)
diff --git a/security/libssh/files/patch-libssh__agent.c b/security/libssh/files/patch-libssh__agent.c
new file mode 100644
index 000000000000..7deaf213a064
--- /dev/null
+++ b/security/libssh/files/patch-libssh__agent.c
@@ -0,0 +1,13 @@
+--- ./libssh/agent.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/agent.c 2009-07-09 08:21:13.000000000 +1000
+@@ -44,6 +44,10 @@
+ #include <poll.h>
+ #include <unistd.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/agent.h"
+ #include "libssh/priv.h"
+
diff --git a/security/libssh/files/patch-libssh__auth.c b/security/libssh/files/patch-libssh__auth.c
new file mode 100644
index 000000000000..32b680a3b0eb
--- /dev/null
+++ b/security/libssh/files/patch-libssh__auth.c
@@ -0,0 +1,22 @@
+--- ./libssh/auth.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/auth.c 2009-07-09 08:21:13.000000000 +1000
+@@ -22,12 +22,17 @@
+ * MA 02111-1307, USA.
+ */
+
+-#include "libssh/priv.h"
+-#include "libssh/ssh2.h"
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
++#include "libssh/priv.h"
++#include "libssh/ssh2.h"
++
+ /** \defgroup ssh_auth SSH Authentication functions
+ * \brief functions to authenticate to servers
+ */
diff --git a/security/libssh/files/patch-libssh__buffer.c b/security/libssh/files/patch-libssh__buffer.c
new file mode 100644
index 000000000000..c800538d3150
--- /dev/null
+++ b/security/libssh/files/patch-libssh__buffer.c
@@ -0,0 +1,14 @@
+--- ./libssh/buffer.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/buffer.c 2009-07-09 08:21:13.000000000 +1000
+@@ -23,6 +23,11 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+
+ /** \defgroup ssh_buffer SSH Buffers
diff --git a/security/libssh/files/patch-libssh__channels.c b/security/libssh/files/patch-libssh__channels.c
new file mode 100644
index 000000000000..5d7279b9d875
--- /dev/null
+++ b/security/libssh/files/patch-libssh__channels.c
@@ -0,0 +1,13 @@
+--- ./libssh/channels.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/channels.c 2009-07-09 08:21:13.000000000 +1000
+@@ -28,6 +28,10 @@
+ #include <stdio.h>
+ #include <errno.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+ #include "libssh/ssh2.h"
+
diff --git a/security/libssh/files/patch-libssh__client.c b/security/libssh/files/patch-libssh__client.c
new file mode 100644
index 000000000000..bb938154a78e
--- /dev/null
+++ b/security/libssh/files/patch-libssh__client.c
@@ -0,0 +1,14 @@
+--- ./libssh/client.c.orig 2009-05-21 18:46:18.000000000 +1000
++++ ./libssh/client.c 2009-07-09 08:21:13.000000000 +1000
+@@ -24,6 +24,11 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+ #include "libssh/ssh2.h"
+
diff --git a/security/libssh/files/patch-libssh__crypt.c b/security/libssh/files/patch-libssh__crypt.c
new file mode 100644
index 000000000000..51d7f8c932a9
--- /dev/null
+++ b/security/libssh/files/patch-libssh__crypt.c
@@ -0,0 +1,13 @@
+--- ./libssh/crypt.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/crypt.c 2009-07-09 08:21:13.000000000 +1000
+@@ -26,6 +26,10 @@
+ #include <stdio.h>
+ #include <string.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #ifdef OPENSSL_CRYPTO
+ #include <openssl/blowfish.h>
+ #include <openssl/evp.h>
diff --git a/security/libssh/files/patch-libssh__dh.c b/security/libssh/files/patch-libssh__dh.c
new file mode 100644
index 000000000000..df73c8be8853
--- /dev/null
+++ b/security/libssh/files/patch-libssh__dh.c
@@ -0,0 +1,13 @@
+--- ./libssh/dh.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/dh.c 2009-07-09 08:21:13.000000000 +1000
+@@ -44,6 +44,10 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+ #include "libssh/crypto.h"
+
diff --git a/security/libssh/files/patch-libssh__kex.c b/security/libssh/files/patch-libssh__kex.c
new file mode 100644
index 000000000000..81899b3f80a8
--- /dev/null
+++ b/security/libssh/files/patch-libssh__kex.c
@@ -0,0 +1,13 @@
+--- ./libssh/kex.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/kex.c 2009-07-09 08:21:13.000000000 +1000
+@@ -25,6 +25,10 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "config.h"
+ #include "libssh/priv.h"
+ #include "libssh/ssh2.h"
diff --git a/security/libssh/files/patch-libssh__keyfiles.c b/security/libssh/files/patch-libssh__keyfiles.c
new file mode 100644
index 000000000000..73ded58d3ef6
--- /dev/null
+++ b/security/libssh/files/patch-libssh__keyfiles.c
@@ -0,0 +1,14 @@
+--- ./libssh/keyfiles.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/keyfiles.c 2009-07-09 08:21:13.000000000 +1000
+@@ -29,6 +29,11 @@
+ #include <stdlib.h>
+ #include <fcntl.h>
+ #include <ctype.h>
++
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+
+ #ifdef HAVE_LIBGCRYPT
diff --git a/security/libssh/files/patch-libssh__messages.c b/security/libssh/files/patch-libssh__messages.c
new file mode 100644
index 000000000000..b7c0f8cd1df5
--- /dev/null
+++ b/security/libssh/files/patch-libssh__messages.c
@@ -0,0 +1,14 @@
+--- ./libssh/messages.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/messages.c 2009-07-09 08:21:13.000000000 +1000
+@@ -34,6 +34,11 @@
+
+ #include <string.h>
+ #include <stdlib.h>
++
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/libssh.h"
+ #include "libssh/priv.h"
+ #include "libssh/server.h"
diff --git a/security/libssh/files/patch-libssh__misc.c b/security/libssh/files/patch-libssh__misc.c
new file mode 100644
index 000000000000..367f306ea090
--- /dev/null
+++ b/security/libssh/files/patch-libssh__misc.c
@@ -0,0 +1,10 @@
+--- ./libssh/misc.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/misc.c 2009-07-09 08:21:13.000000000 +1000
+@@ -37,6 +37,7 @@
+ #include <winsock2.h>
+ #else
+ #include <pwd.h>
++#include <arpa/inet.h>
+ #endif
+
+ #include "libssh/priv.h"
diff --git a/security/libssh/files/patch-libssh__packet.c b/security/libssh/files/patch-libssh__packet.c
new file mode 100644
index 000000000000..429a29c79b0d
--- /dev/null
+++ b/security/libssh/files/patch-libssh__packet.c
@@ -0,0 +1,13 @@
+--- ./libssh/packet.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/packet.c 2009-07-09 08:21:13.000000000 +1000
+@@ -27,6 +27,10 @@
+ #include <string.h>
+ #include <errno.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "config.h"
+ #include "libssh/priv.h"
+ #include "libssh/ssh2.h"
diff --git a/security/libssh/files/patch-libssh__sftp.c b/security/libssh/files/patch-libssh__sftp.c
new file mode 100644
index 000000000000..16bb25cfa7bf
--- /dev/null
+++ b/security/libssh/files/patch-libssh__sftp.c
@@ -0,0 +1,13 @@
+--- ./libssh/sftp.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/sftp.c 2009-07-09 08:21:13.000000000 +1000
+@@ -31,6 +31,10 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+ #include "libssh/ssh2.h"
+ #include "libssh/sftp.h"
diff --git a/security/libssh/files/patch-libssh__sftpserver.c b/security/libssh/files/patch-libssh__sftpserver.c
new file mode 100644
index 000000000000..5251c292186a
--- /dev/null
+++ b/security/libssh/files/patch-libssh__sftpserver.c
@@ -0,0 +1,13 @@
+--- ./libssh/sftpserver.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/sftpserver.c 2009-07-09 08:21:13.000000000 +1000
+@@ -26,6 +26,10 @@
+ #include <string.h>
+ #include <stdio.h>
+
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/libssh.h"
+ #include "libssh/sftp.h"
+ #include "libssh/ssh2.h"
diff --git a/security/libssh/files/patch-libssh__string.c b/security/libssh/files/patch-libssh__string.c
new file mode 100644
index 000000000000..f4887d154405
--- /dev/null
+++ b/security/libssh/files/patch-libssh__string.c
@@ -0,0 +1,14 @@
+--- ./libssh/string.c.orig 2009-05-21 18:46:17.000000000 +1000
++++ ./libssh/string.c 2009-07-09 08:21:13.000000000 +1000
+@@ -24,6 +24,11 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <string.h>
++
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
++
+ #include "libssh/priv.h"
+
+ /** \defgroup ssh_string SSH Strings
diff --git a/security/libssh/files/patch-server.c b/security/libssh/files/patch-server.c
deleted file mode 100644
index 866b3d09177e..000000000000
--- a/security/libssh/files/patch-server.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libssh/server.c.orig 2009-04-12 20:06:06.000000000 +1000
-+++ libssh/server.c 2009-04-12 20:06:16.000000000 +1000
-@@ -27,6 +27,7 @@
- #include <stdio.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in.h>
- #include <netdb.h>
- #include <errno.h>
- #include <string.h>
diff --git a/security/libssh/pkg-descr b/security/libssh/pkg-descr
index fb11d8b0eec3..14e8600c87e9 100644
--- a/security/libssh/pkg-descr
+++ b/security/libssh/pkg-descr
@@ -20,4 +20,4 @@ libssh features:
* Compression support (with zlib)
* Public key (RSA and DSS), password and keyboard-interactive authentication
-WWW: http://0xbadc0de.be/wiki/libssh:libssh
+WWW: http://www.libssh.org/
diff --git a/security/libssh/pkg-plist b/security/libssh/pkg-plist
index 8709851dcfcd..cd01ab3ea1f7 100644
--- a/security/libssh/pkg-plist
+++ b/security/libssh/pkg-plist
@@ -1,12 +1,9 @@
-lib/libssh.a
-lib/libssh.la
lib/libssh.so
-lib/libssh.so.2
+lib/libssh.so.3
+lib/libssh.so.3.0.0
include/libssh/libssh.h
-include/libssh/config.h
include/libssh/sftp.h
include/libssh/crypto.h
include/libssh/server.h
include/libssh/ssh2.h
-include/libssh/ssh1.h
@dirrm include/libssh