aboutsummaryrefslogtreecommitdiff
path: root/security/libssh
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-04-12 17:47:48 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-04-12 17:47:48 +0000
commitb9bf0908c3ec383a5064e01c1a3197363efed49d (patch)
tree819d9e686dce65f055552519afaed1446bc8050e /security/libssh
parentb65ce7077fdba178a22c53ace6b1e00c18091d58 (diff)
downloadports-b9bf0908c3ec383a5064e01c1a3197363efed49d.tar.gz
ports-b9bf0908c3ec383a5064e01c1a3197363efed49d.zip
Notes
Diffstat (limited to 'security/libssh')
-rw-r--r--security/libssh/Makefile22
-rw-r--r--security/libssh/distinfo3
-rw-r--r--security/libssh/files/patch-Makefile.in11
-rw-r--r--security/libssh/files/patch-server.c10
-rw-r--r--security/libssh/pkg-descr23
-rw-r--r--security/libssh/pkg-plist12
6 files changed, 81 insertions, 0 deletions
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
new file mode 100644
index 000000000000..4a70b31ee3b8
--- /dev/null
+++ b/security/libssh/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: libssh
+# Date created: 12 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libssh
+PORTVERSION= 0.2
+CATEGORIES= security devel
+MASTER_SITES= http://0xbadc0de.be/libssh/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A library implementing the SSH1 and SSH2 protocol
+
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/security/libssh/distinfo b/security/libssh/distinfo
new file mode 100644
index 000000000000..b56ee442e1ac
--- /dev/null
+++ b/security/libssh/distinfo
@@ -0,0 +1,3 @@
+MD5 (libssh-0.2.tgz) = 8a76c03579a3e27046e6bafe88ffd171
+SHA256 (libssh-0.2.tgz) = 46c3831fd563c54283ebef56e2cb11c27f47b1be9f6cb44f1465897dd7aea5ff
+SIZE (libssh-0.2.tgz) = 329371
diff --git a/security/libssh/files/patch-Makefile.in b/security/libssh/files/patch-Makefile.in
new file mode 100644
index 000000000000..7733ef623ee2
--- /dev/null
+++ b/security/libssh/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2009-04-12 20:24:31.000000000 +1000
++++ Makefile.in 2009-04-12 20:22:37.000000000 +1000
+@@ -28,7 +28,7 @@
+ CONFIG = include/libssh/config.h
+
+ .PHONY: all
+-all: $(CONFIG) SUBDIRS $(OBJECTS) $(APPS)
++all: $(CONFIG) SUBDIRS
+
+ .PHONY: SUBDIRS
+ SUBDIRS:
diff --git a/security/libssh/files/patch-server.c b/security/libssh/files/patch-server.c
new file mode 100644
index 000000000000..866b3d09177e
--- /dev/null
+++ b/security/libssh/files/patch-server.c
@@ -0,0 +1,10 @@
+--- libssh/server.c.orig 2009-04-12 20:06:06.000000000 +1000
++++ libssh/server.c 2009-04-12 20:06:16.000000000 +1000
+@@ -27,6 +27,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <netdb.h>
+ #include <errno.h>
+ #include <string.h>
diff --git a/security/libssh/pkg-descr b/security/libssh/pkg-descr
new file mode 100644
index 000000000000..fb11d8b0eec3
--- /dev/null
+++ b/security/libssh/pkg-descr
@@ -0,0 +1,23 @@
+The ssh library was designed to be used by programmers needing a working SSH
+implementation by the mean of a library. The complete control of the client is
+made by the programmer. With libssh, you can remotely execute programs, transfer
+files, use a secure and transparent tunnel for your remote programs.
+With its Secure FTP implementation, you can play with remote files easily,
+without third-party programs others than libcrypto (from openssl).
+
+libssh features:
+
+ * Full C library functions for manipulating a client-side SSH connection
+ * SSH2 and SSH1 protocol compliant
+ * Fully configurable sessions
+ * Server support
+ * Support for AES-128,AES-192,AES-256,blowfish,3des in cbc mode
+ * Use multiple SSH connections in a same process, at same time
+ * Use multiple channels in the same connection
+ * Thread safety when using different sessions at same time
+ * Basic but correct SFTP implementation (secure file transfer)
+ * RSA and DSS server public key supported
+ * Compression support (with zlib)
+ * Public key (RSA and DSS), password and keyboard-interactive authentication
+
+WWW: http://0xbadc0de.be/wiki/libssh:libssh
diff --git a/security/libssh/pkg-plist b/security/libssh/pkg-plist
new file mode 100644
index 000000000000..8709851dcfcd
--- /dev/null
+++ b/security/libssh/pkg-plist
@@ -0,0 +1,12 @@
+lib/libssh.a
+lib/libssh.la
+lib/libssh.so
+lib/libssh.so.2
+include/libssh/libssh.h
+include/libssh/config.h
+include/libssh/sftp.h
+include/libssh/crypto.h
+include/libssh/server.h
+include/libssh/ssh2.h
+include/libssh/ssh1.h
+@dirrm include/libssh