aboutsummaryrefslogtreecommitdiff
path: root/security/libssh
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2010-03-26 08:31:47 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2010-03-26 08:31:47 +0000
commit9b16656e242c1b686b684f0fa7ec314c56eff371 (patch)
treed8b942db1c19f431ac97cc229a2e30999201a88d /security/libssh
parent5ced21fdb6619b04188d1514f262daf236f335b8 (diff)
downloadports-9b16656e242c1b686b684f0fa7ec314c56eff371.tar.gz
ports-9b16656e242c1b686b684f0fa7ec314c56eff371.zip
Notes
Diffstat (limited to 'security/libssh')
-rw-r--r--security/libssh/Makefile13
-rw-r--r--security/libssh/distinfo6
-rw-r--r--security/libssh/files/patch-libssh_auth.c11
-rw-r--r--security/libssh/files/patch-libssh_channels1.c12
-rw-r--r--security/libssh/pkg-plist3
5 files changed, 39 insertions, 6 deletions
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index e2dc96e3756a..6f9a1b80e75c 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libssh
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh.org/files/ \
LOCAL/avl
@@ -14,7 +14,8 @@ MASTER_SITES= http://www.libssh.org/files/ \
MAINTAINER= avl@FreeBSD.org
COMMENT= A library implementing the SSH1 and SSH2 protocol
-OPTIONS= GCRYPT "Build with libgcrypt" off
+OPTIONS= GCRYPT "Build with libgcrypt" off \
+ SSH1 "Build with SSH1 support" off
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
@@ -33,6 +34,14 @@ CMAKE_ARGS+= -DWITH_GCRYPT:BOOL=ON
USE_OPENSSL= yes
.endif
+.if defined(WITH_SSH1)
+CMAKE_ARGS+= -DWITH_SSH1:BOOL=ON
+PLIST_SUB+= SSH1=""
+.else
+CMAKE_ARGS+= -DWITH_SSH1:BOOL=OFF
+PLIST_SUB+= SSH1="@comment "
+.endif
+
post-patch:
@${MKDIR} ${BUILD_WRKSRC}
@${RM} ${PATCH_WRKSRC}/cmake/Modules/UseDoxygen.cmake
diff --git a/security/libssh/distinfo b/security/libssh/distinfo
index ba3ef1c2b3c0..f48caee76c3f 100644
--- a/security/libssh/distinfo
+++ b/security/libssh/distinfo
@@ -1,3 +1,3 @@
-MD5 (libssh-0.4.1.tar.gz) = 258402bf1fabf664daeba4e5fc7a8d09
-SHA256 (libssh-0.4.1.tar.gz) = a6d2ae8212182cb366230de3cc3977779b5010c85f9a157ca9850bc6bf8f2238
-SIZE (libssh-0.4.1.tar.gz) = 252598
+MD5 (libssh-0.4.2.tar.gz) = 249fd41dff094f6b236d69a9d1bbb971
+SHA256 (libssh-0.4.2.tar.gz) = ef0abcb5e3a0f647248b3d128905649b77a78161fe0888e88c4efffef739873d
+SIZE (libssh-0.4.2.tar.gz) = 254508
diff --git a/security/libssh/files/patch-libssh_auth.c b/security/libssh/files/patch-libssh_auth.c
new file mode 100644
index 000000000000..985d3fabb029
--- /dev/null
+++ b/security/libssh/files/patch-libssh_auth.c
@@ -0,0 +1,11 @@
+--- libssh/auth.c.orig 2010-03-16 02:34:17.000000000 +0800
++++ libssh/auth.c 2010-03-26 15:41:36.000000000 +0800
+@@ -866,6 +866,8 @@
+ char *privkey_file = NULL;
+ int privkey_open = 0;
+
++ privkey = NULL;
++
+ privkey_file = dir_expand_dup(session, it->data, 1);
+ if (privkey_file == NULL) {
+ continue;
diff --git a/security/libssh/files/patch-libssh_channels1.c b/security/libssh/files/patch-libssh_channels1.c
new file mode 100644
index 000000000000..07f10673bd82
--- /dev/null
+++ b/security/libssh/files/patch-libssh_channels1.c
@@ -0,0 +1,12 @@
+--- libssh/channels1.c.orig 2010-03-19 22:34:30.000000000 +0800
++++ libssh/channels1.c 2010-03-19 22:35:51.000000000 +0800
+@@ -26,6 +26,9 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#ifndef _WIN32
++#include <arpa/inet.h>
++#endif
+ #include "libssh/priv.h"
+ #include "libssh/ssh1.h"
+ #include "libssh/buffer.h"
diff --git a/security/libssh/pkg-plist b/security/libssh/pkg-plist
index c764773a5352..ca73423db449 100644
--- a/security/libssh/pkg-plist
+++ b/security/libssh/pkg-plist
@@ -2,8 +2,9 @@ include/libssh/callbacks.h
include/libssh/libssh.h
include/libssh/server.h
include/libssh/sftp.h
+%%SSH1%%include/libssh/ssh1.h
include/libssh/ssh2.h
lib/libssh.so
lib/libssh.so.4
-lib/libssh.so.4.0.1
+lib/libssh.so.4.0.2
@dirrm include/libssh