aboutsummaryrefslogtreecommitdiff
path: root/security/libtasn1/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-01-28 22:19:12 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-01-28 22:19:12 +0000
commit3c4b5af5ca9f54a03cd68b539436215e82892c9e (patch)
treebd613ad8b3b260f0e5caa2651ad030c573abbe0d /security/libtasn1/Makefile
parenteb4cdb39e7a7e9ec358860ddcd6c4f25a9a21a21 (diff)
Notes
Diffstat (limited to 'security/libtasn1/Makefile')
-rw-r--r--security/libtasn1/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/security/libtasn1/Makefile b/security/libtasn1/Makefile
index 0c8f9e80aab2..207b213b5186 100644
--- a/security/libtasn1/Makefile
+++ b/security/libtasn1/Makefile
@@ -9,24 +9,32 @@ PORTNAME= libtasn1
PORTVERSION= 0.1.2
CATEGORIES= security
MASTER_SITES= http://gd.tuwien.ac.at/privacy/gnupg/alpha/gnutls/libtasn1/ \
- ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
- ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/libtasn1/ \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
- ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/libtasn1/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
+ ftp://ftp.gnutls.org/pub/gnutls/libtasn1/
MAINTAINER= sergei@kolobov.com
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
DOCS= AUTHORS NEWS README THANKS
DOCS2= asn1.ps asn1.tex fdl.tex
+post-patch:
+.for file in asn1Coding.c asn1Decoding.c asn1Parser.c
+ ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${file}
+.endfor
+
post-install:
+ ${RM} -f ${PREFIX}/lib/libtasn1.la
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${DOCS}