aboutsummaryrefslogtreecommitdiff
path: root/security/libtasn1
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-02-27 20:09:41 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-02-27 20:09:41 +0000
commitce4b1510c1acc083904b674d0898474249f4471c (patch)
tree0ae17156dc47f74a7b8fabc865f76ce78c1020db /security/libtasn1
parentc19d348710a5e393f809e62da1b0bad862c1c257 (diff)
downloadports-ce4b1510c1acc083904b674d0898474249f4471c.tar.gz
ports-ce4b1510c1acc083904b674d0898474249f4471c.zip
Notes
Diffstat (limited to 'security/libtasn1')
-rw-r--r--security/libtasn1/Makefile17
-rw-r--r--security/libtasn1/distinfo2
-rw-r--r--security/libtasn1/files/patch-configure13
-rw-r--r--security/libtasn1/pkg-plist19
4 files changed, 31 insertions, 20 deletions
diff --git a/security/libtasn1/Makefile b/security/libtasn1/Makefile
index 9a6c07e10739..12356412cf81 100644
--- a/security/libtasn1/Makefile
+++ b/security/libtasn1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtasn1
-PORTVERSION= 0.1.2
+PORTVERSION= 0.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
@@ -17,33 +17,30 @@ MASTER_SITE_SUBDIR= alpha/gnutls/libtasn1
MAINTAINER= sergei@kolobov.com
COMMENT= ASN.1 structure parser library
+.if !exists(/usr/include/getopt.h)
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
+.endif
USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-DOCS= AUTHORS NEWS README THANKS
-DOCS2= asn1.ps asn1.tex fdl.tex
+DOCS= AUTHORS NEWS README THANKS doc/asn1.ps doc/asn1.tex doc/fdl.tex
post-patch:
.for file in asn1Coding.c asn1Decoding.c asn1Parser.c
${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${file}
.endfor
-post-install:
- ${RM} -f ${PREFIX}/lib/libtasn1.la
.if !defined(NOPORTDOCS)
+post-install:
@${MKDIR} ${DOCSDIR}
.for file in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
-.for file in ${DOCS2}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
-.endfor
.endif
.include <bsd.port.mk>
diff --git a/security/libtasn1/distinfo b/security/libtasn1/distinfo
index bf49d272e206..430c6b193ac9 100644
--- a/security/libtasn1/distinfo
+++ b/security/libtasn1/distinfo
@@ -1 +1 @@
-MD5 (libtasn1-0.1.2.tar.gz) = 6c8c376e5582f6845371a939869166dd
+MD5 (libtasn1-0.2.1.tar.gz) = 738810df8f97b9b457a5dc6aa5ad2065
diff --git a/security/libtasn1/files/patch-configure b/security/libtasn1/files/patch-configure
new file mode 100644
index 000000000000..7dac841eecb9
--- /dev/null
+++ b/security/libtasn1/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure.orig Thu Feb 27 21:02:03 2003
++++ configure Thu Feb 27 21:02:16 2003
+@@ -8617,6 +8617,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/security/libtasn1/pkg-plist b/security/libtasn1/pkg-plist
index 1a3bc94b231f..70eaae134b61 100644
--- a/security/libtasn1/pkg-plist
+++ b/security/libtasn1/pkg-plist
@@ -1,12 +1,13 @@
+@comment $FreeBSD$
include/libtasn1.h
-lib/libtasn1.so.0
+lib/libtasn1.so.1
lib/libtasn1.so
lib/libtasn1.a
-%%PORTDOCS%%share/doc/libtasn1/AUTHORS
-%%PORTDOCS%%share/doc/libtasn1/NEWS
-%%PORTDOCS%%share/doc/libtasn1/README
-%%PORTDOCS%%share/doc/libtasn1/THANKS
-%%PORTDOCS%%share/doc/libtasn1/asn1.ps
-%%PORTDOCS%%share/doc/libtasn1/asn1.tex
-%%PORTDOCS%%share/doc/libtasn1/fdl.tex
-%%PORTDOCS%%@dirrm share/doc/libtasn1
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/asn1.ps
+%%PORTDOCS%%%%DOCSDIR%%/asn1.tex
+%%PORTDOCS%%%%DOCSDIR%%/fdl.tex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%