aboutsummaryrefslogtreecommitdiff
path: root/security/libtomcrypt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-08-29 14:58:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-08-29 14:58:21 +0000
commit9e9dcc48e9960a0b09d745f77dc7e1e8998db865 (patch)
tree4f209ba5961a520b56613f0cceb297cc64fbd533 /security/libtomcrypt
parentbc6e6582e11c72d0f0a6c604046a0b5e8fb20022 (diff)
Notes
Diffstat (limited to 'security/libtomcrypt')
-rw-r--r--security/libtomcrypt/Makefile38
-rw-r--r--security/libtomcrypt/distinfo6
-rw-r--r--security/libtomcrypt/files/patch-makefile52
-rw-r--r--security/libtomcrypt/pkg-plist4
4 files changed, 84 insertions, 16 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 5c9b04849321..d6222e9c361d 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -6,25 +6,48 @@
#
PORTNAME= libtomcrypt
-PORTVERSION= 1.02
+PORTVERSION= 1.06
CATEGORIES= security
MASTER_SITES= http://libtomcrypt.org/files/
DISTNAME= crypt-${PORTVERSION}
-MAINTAINER= onatan@gmail.com
+PATCH_SITES= http://www.libtomcrypt.org/files/patch-1.06/
+PATCHFILES= makefile.diff
+
+MAINTAINER= wxs@csh.rit.edu
COMMENT= Comprehensive, modular and portable cryptographic toolkit
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
+MAKE_ARGS= DESTDIR="${PREFIX}" LIBPATH="/lib" INCPATH="/include" \
+ DATAPATH="${DOCSDIR}/pdf"
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
ALL_TARGET= library
-OPTIONS= DOCS "build documentation (depends on teTeX)" off
+CFLAGS+= -I${PREFIX}/include
+
+OPTIONS= DOCS "build documentation (depends on teTeX)" off \
+ LIBTOMMATH "Use LibTomMath" on \
+ TOMSFASTMATH "Use TomsFastMath" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_LIBTOMMATH) && defined(WITHOUT_TOMSFASTMATH)
+IGNORE= You must choose either LibTomMath or TomsFastMath (or both)
+.endif
+
+.if !defined(WITHOUT_LIBTOMMATH)
+BUILD_DEPENDS+= ${LOCALBASE}/include/tommath.h:${PORTSDIR}/math/libtommath
+CFLAGS+= -DLTM_DESC
+.endif
+
+.if defined(WITH_TOMSFASTMATH)
+BUILD_DEPENDS+= ${LOCALBASE}/include/tfm.h:${PORTSDIR}/math/tomsfastmath
+CFLAGS+= -DTFM_DESC
+.endif
+
.if defined(WITH_DOCS)
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
.else
@@ -32,16 +55,9 @@ NOPORTDOCS= yes
INSTALL_TARGET= install_lib
.endif
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr|${PREFIX}|; s|dvipdf|dvipdft|; \
- s|-O3||; s|-funroll-loops||; s|-fomit-frame-pointer||; \
- s|-Wno-unused-parameter||' \
- ${WRKSRC}/makefile
-
.if defined(MAINTAINER_MODE)
test: build
- (cd ${WRKSRC}/demos/test && ${MAKE} test ${MAKE_ARGS} && ${WRKSRC}/demos/test/test)
+ (cd ${WRKSRC} && ${GMAKE} test && ${WRKSRC}/test)
.endif
.include <bsd.port.post.mk>
diff --git a/security/libtomcrypt/distinfo b/security/libtomcrypt/distinfo
index 2b1e5572348b..3571f3dd934f 100644
--- a/security/libtomcrypt/distinfo
+++ b/security/libtomcrypt/distinfo
@@ -1,2 +1,4 @@
-MD5 (crypt-1.02.tar.bz2) = f571fb2f984ec59d229a7f691c35b4d1
-SIZE (crypt-1.02.tar.bz2) = 1025539
+MD5 (crypt-1.06.tar.bz2) = f7b5fd2a5d4b2917576da7885f27e4a0
+SIZE (crypt-1.06.tar.bz2) = 1160330
+MD5 (makefile.diff) = 76b18782400494589c35e12e6cdd081d
+SIZE (makefile.diff) = 1372
diff --git a/security/libtomcrypt/files/patch-makefile b/security/libtomcrypt/files/patch-makefile
new file mode 100644
index 000000000000..de4f9b53d746
--- /dev/null
+++ b/security/libtomcrypt/files/patch-makefile
@@ -0,0 +1,52 @@
+--- makefile.orig Thu Aug 18 13:07:13 2005
++++ makefile Thu Aug 18 13:10:14 2005
+@@ -15,7 +15,7 @@
+ #ARFLAGS=r
+
+ # Compilation flags. Note the += does not write over the user's CFLAGS!
+-CFLAGS += -c -I./testprof/ -I./src/headers/ -Wall -Wsign-compare -W -Wshadow -Wno-unused-parameter -DLTC_SOURCE
++CFLAGS += -c -I./testprof/ -I./src/headers/ -Wall -Wsign-compare -W -Wshadow -DLTC_SOURCE
+
+ # additional warnings (newer GCC 3.4 and higher)
+ #CFLAGS += -Wsystem-headers -Wdeclaration-after-statement -Wbad-function-cast -Wcast-align -Wstrict-prototypes -Wmissing-prototypes \
+@@ -24,10 +24,10 @@
+ ifndef IGNORE_SPEED
+
+ # optimize for SPEED
+-CFLAGS += -O3 -funroll-loops
++#CFLAGS += -O3 -funroll-loops
+
+ # add -fomit-frame-pointer. hinders debugging!
+-CFLAGS += -fomit-frame-pointer
++#CFLAGS += -fomit-frame-pointer
+
+ # optimize for SIZE
+ #CFLAGS += -Os -DLTC_SMALL_CODE
+@@ -249,10 +249,16 @@
+ install: library docs
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(DATAPATH)
++ install -d -g $(GROUP) -o $(USER) $(DATAPATH)
++ install -g $(GROUP) -o $(USER) $(LIBNAME) $(DESTDIR)$(LIBPATH)
++ install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
++ install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DATAPATH)
++
++install_lib: library
++ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
++ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+ install -g $(GROUP) -o $(USER) $(LIBNAME) $(DESTDIR)$(LIBPATH)
+ install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+- install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DESTDIR)$(DATAPATH)
+
+ install_test: testprof/$(LIBTEST)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
+@@ -305,7 +311,7 @@
+ latex crypt > /dev/null
+ makeindex crypt.idx > /dev/null
+ latex crypt > /dev/null
+- dvipdf crypt
++ dvipdft crypt
+ mv -ivf crypt.pdf doc/crypt.pdf
+ rm -f $(LEFTOVERS)
+
diff --git a/security/libtomcrypt/pkg-plist b/security/libtomcrypt/pkg-plist
index ea0c4303af7d..c2c016feb8df 100644
--- a/security/libtomcrypt/pkg-plist
+++ b/security/libtomcrypt/pkg-plist
@@ -1,4 +1,3 @@
-include/ltc_tommath.h
include/tomcrypt.h
include/tomcrypt_argchk.h
include/tomcrypt_cfg.h
@@ -7,13 +6,12 @@ include/tomcrypt_custom.h
include/tomcrypt_hash.h
include/tomcrypt_mac.h
include/tomcrypt_macros.h
+include/tomcrypt_math.h
include/tomcrypt_misc.h
include/tomcrypt_pk.h
include/tomcrypt_pkcs.h
include/tomcrypt_prng.h
include/tomcrypt_test.h
-include/tommath_class.h
-include/tommath_superclass.h
lib/libtomcrypt.a
%%PORTDOCS%%%%DOCSDIR%%/pdf/crypt.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf