aboutsummaryrefslogtreecommitdiff
path: root/security/libtomcrypt
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-05-31 18:06:35 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-05-31 18:06:35 +0000
commitc48fc1ace26ca312622c1f30fd0354ea436e181f (patch)
tree678e2afff9f47532198cbc6b54645fb373a12d1a /security/libtomcrypt
parent060d89d7fb2405637bf92bfaaaeb561c1c1b4c15 (diff)
downloadports-c48fc1ace26ca312622c1f30fd0354ea436e181f.tar.gz
ports-c48fc1ace26ca312622c1f30fd0354ea436e181f.zip
Notes
Diffstat (limited to 'security/libtomcrypt')
-rw-r--r--security/libtomcrypt/Makefile22
-rw-r--r--security/libtomcrypt/distinfo6
2 files changed, 21 insertions, 7 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index a6596483b3b2..711a190502b5 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtomcrypt
-PORTVERSION= 1.10
+PORTVERSION= 1.12
CATEGORIES= security
MASTER_SITES= http://libtomcrypt.com/files/
DISTNAME= crypt-${PORTVERSION}
@@ -26,12 +26,13 @@ CFLAGS+= -I${PREFIX}/include
OPTIONS= DOCS "build documentation (depends on teTeX)" off \
LIBTOMMATH "Use LibTomMath" on \
- TOMSFASTMATH "Use TomsFastMath" off
+ TOMSFASTMATH "Use TomsFastMath" off \
+ GMP "Use GMP" off
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_LIBTOMMATH) && defined(WITHOUT_TOMSFASTMATH)
-IGNORE= you must choose either LibTomMath or TomsFastMath (or both)
+.if defined(WITHOUT_LIBTOMMATH) && !defined(WITH_TOMSFASTMATH) && !defined(WITH_GMP)
+IGNORE= you must choose at least LibTomMath, TomsFastMath, or GMP (or all three)
.endif
.if !defined(WITHOUT_LIBTOMMATH)
@@ -44,6 +45,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/tfm.h:${PORTSDIR}/math/tomsfastmath
CFLAGS+= -DTFM_DESC
.endif
+.if defined(WITH_GMP)
+BUILD_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
+CFLAGS+= -DGMP_DESC
+.endif
+
.if defined(WITH_DOCS)
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
.else
@@ -62,5 +68,13 @@ test: build
@${ECHO_MSG} "Testing with -DUSE_LTM..."
(cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_LTM" EXTRALIBS="-L${PREFIX}/lib -ltommath" ${GMAKE} test && ${WRKSRC}/test)
+
+ @${ECHO_MSG} "Cleaning up test binary..."
+ @${RM} ${WRKSRC}/test
+ @${RM} ${WRKSRC}/demos/test.o
+
+ @${ECHO_MSG} "Testing with -DUSE_GMP..."
+ (cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_GMP" EXTRALIBS="-L${PREFIX}/lib -lgmp" ${GMAKE} test && ${WRKSRC}/test)
.endif
+
.include <bsd.port.post.mk>
diff --git a/security/libtomcrypt/distinfo b/security/libtomcrypt/distinfo
index d749ac92a3a7..8de998b39e9e 100644
--- a/security/libtomcrypt/distinfo
+++ b/security/libtomcrypt/distinfo
@@ -1,3 +1,3 @@
-MD5 (crypt-1.10.tar.bz2) = 8da42847a5ac43e82965121c9e26e525
-SHA256 (crypt-1.10.tar.bz2) = 3115f8d91956ae8e05a19d74e6d2d2321e5e466a6daf69a4c43c2aa48334308d
-SIZE (crypt-1.10.tar.bz2) = 1324351
+MD5 (crypt-1.12.tar.bz2) = 0a018c0a84deea104bbc21d566f142fc
+SHA256 (crypt-1.12.tar.bz2) = 3001f79f26d3e70ae52e3f752c506aec1159c5efdcc43ca970cbfc7904c50907
+SIZE (crypt-1.12.tar.bz2) = 1393191