aboutsummaryrefslogtreecommitdiff
path: root/security/libtomcrypt
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2018-09-28 14:48:17 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2018-09-28 14:48:17 +0000
commit45ca47802c3eb0aa37b47999732c7f8aeee2b72b (patch)
tree72a5a48b5f80ffab4768abd0741733ffb2271d6d /security/libtomcrypt
parent4b32ecc401f3977b28e175fbc3a6c5ebd794ddf4 (diff)
downloadports-45ca47802c3eb0aa37b47999732c7f8aeee2b72b.tar.gz
ports-45ca47802c3eb0aa37b47999732c7f8aeee2b72b.zip
Notes
Diffstat (limited to 'security/libtomcrypt')
-rw-r--r--security/libtomcrypt/Makefile9
-rw-r--r--security/libtomcrypt/distinfo6
-rw-r--r--security/libtomcrypt/files/patch-makefile__include.mk11
3 files changed, 17 insertions, 9 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 39621f7446b0..119c75584130 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= libtomcrypt
-PORTVERSION= 1.18.1
-PORTREVISION= 1
+PORTVERSION= 1.18.2
+PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= https://github.com/libtom/${PORTNAME}/releases/download/v${PORTVERSION}/
DISTNAME= crypt-${PORTVERSION}
@@ -14,9 +14,7 @@ COMMENT= Comprehensive, modular, and portable cryptographic toolkit
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_mips= fails to compile: unrecognized command line option "-Wno-type-limits"
-BROKEN_mips64= fails to compile: unrecognized command line option "-Wno-type-limits"
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-type-limits"
+USES= gmake libtool:build tar:xz
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -26,7 +24,6 @@ MAKEFILE= makefile.shared
ALL_TARGET= library
MAKE_ARGS= INCPATH="${PREFIX}/include" LIBPATH="${PREFIX}/lib" \
EXTRALIBS="${EXTRALIBS}"
-USES= gmake libtool:build tar:xz
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
diff --git a/security/libtomcrypt/distinfo b/security/libtomcrypt/distinfo
index f726c17b9436..9eba52169404 100644
--- a/security/libtomcrypt/distinfo
+++ b/security/libtomcrypt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516696801
-SHA256 (crypt-1.18.1.tar.xz) = 57c13a34fbfd45696189d19e47864e48f4e5c11590c29b444accb8edbf047f14
-SIZE (crypt-1.18.1.tar.xz) = 2614492
+TIMESTAMP = 1538144834
+SHA256 (crypt-1.18.2.tar.xz) = 96ad4c3b8336050993c5bc2cf6c057484f2b0f9f763448151567fbab5e767b84
+SIZE (crypt-1.18.2.tar.xz) = 2638064
diff --git a/security/libtomcrypt/files/patch-makefile__include.mk b/security/libtomcrypt/files/patch-makefile__include.mk
new file mode 100644
index 000000000000..bb99faa5f75c
--- /dev/null
+++ b/security/libtomcrypt/files/patch-makefile__include.mk
@@ -0,0 +1,11 @@
+--- makefile_include.mk.orig 2018-09-28 13:43:18 UTC
++++ makefile_include.mk
+@@ -73,8 +73,6 @@ LTC_CFLAGS += -Wdeclaration-after-statement
+ LTC_CFLAGS += -Wwrite-strings
+ endif
+
+-LTC_CFLAGS += -Wno-type-limits
+-
+ ifdef LTC_DEBUG
+ $(info Debug build)
+ # compile for DEBUGGING (required for ccmalloc checking!!!)