aboutsummaryrefslogtreecommitdiff
path: root/security/libtomcrypt
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-22 16:43:56 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-22 16:43:56 +0000
commit20e0d563111ea7fdfb91585035c6fdac86ecb080 (patch)
treef2da291e70ca2502e29cb16330f5d20b1b3a2868 /security/libtomcrypt
parent99e76bb9fcf3a9485b2b6ca7dbf8d82d4f08c3a6 (diff)
downloadports-20e0d563111ea7fdfb91585035c6fdac86ecb080.tar.gz
ports-20e0d563111ea7fdfb91585035c6fdac86ecb080.zip
Notes
Diffstat (limited to 'security/libtomcrypt')
-rw-r--r--security/libtomcrypt/Makefile33
-rw-r--r--security/libtomcrypt/distinfo6
-rw-r--r--security/libtomcrypt/files/patch-demos-test-makefile11
-rw-r--r--security/libtomcrypt/files/patch-makefile29
-rw-r--r--security/libtomcrypt/pkg-plist16
5 files changed, 26 insertions, 69 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 681352bf44df..5c9b04849321 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -6,45 +6,42 @@
#
PORTNAME= libtomcrypt
-PORTVERSION= 1.00
-PORTREVISION= 1
+PORTVERSION= 1.02
CATEGORIES= security
-MASTER_SITES= http://libtomcrypt.org/files/:source \
- http://libtomcrypt.org/files/patch-1.00/:patch
-DISTFILES= crypt-${PORTVERSION}.tar.bz2:source \
- ltc-1.00-001.tar.bz2:patch
+MASTER_SITES= http://libtomcrypt.org/files/
+DISTNAME= crypt-${PORTVERSION}
MAINTAINER= onatan@gmail.com
COMMENT= Comprehensive, modular and portable cryptographic toolkit
-EXTRA_PATCHES= ${WRKDIR}/src/pk/pkcs1/pkcs_1_oaep_encode.c.patch \
- ${WRKDIR}/src/pk/pkcs1/pkcs_1_oaep_decode.c.patch \
- ${WRKDIR}/src/misc/base64/base64_decode.c.patch \
- ${WRKDIR}/src/headers/tomcrypt.h.patch \
- ${WRKDIR}/makefile.shared.patch \
- ${WRKDIR}/makefile.patch \
- ${WRKDIR}/changes.patch \
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
-MAKE_ARGS+= PREFIX=${PREFIX}
-MAKE_ENV= PREFIX=${PREFIX} DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR}
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
ALL_TARGET= library
+OPTIONS= DOCS "build documentation (depends on teTeX)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_DOCS)
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
-RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
.else
NOPORTDOCS= yes
INSTALL_TARGET= install_lib
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr|${PREFIX}|; s|dvipdf|dvipdft|; \
+ s|-O3||; s|-funroll-loops||; s|-fomit-frame-pointer||; \
+ s|-Wno-unused-parameter||' \
+ ${WRKSRC}/makefile
+
.if defined(MAINTAINER_MODE)
test: build
(cd ${WRKSRC}/demos/test && ${MAKE} test ${MAKE_ARGS} && ${WRKSRC}/demos/test/test)
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/libtomcrypt/distinfo b/security/libtomcrypt/distinfo
index b4671fe0320b..2b1e5572348b 100644
--- a/security/libtomcrypt/distinfo
+++ b/security/libtomcrypt/distinfo
@@ -1,4 +1,2 @@
-MD5 (crypt-1.00.tar.bz2) = 73a896e5e8f636dd14c1517f572ddaa1
-SIZE (crypt-1.00.tar.bz2) = 940439
-MD5 (ltc-1.00-001.tar.bz2) = fa7a398e554754098259a1a3a5997672
-SIZE (ltc-1.00-001.tar.bz2) = 1868
+MD5 (crypt-1.02.tar.bz2) = f571fb2f984ec59d229a7f691c35b4d1
+SIZE (crypt-1.02.tar.bz2) = 1025539
diff --git a/security/libtomcrypt/files/patch-demos-test-makefile b/security/libtomcrypt/files/patch-demos-test-makefile
deleted file mode 100644
index a2585b74d9c3..000000000000
--- a/security/libtomcrypt/files/patch-demos-test-makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- demos/test/makefile.orig Mon Jan 10 16:35:45 2005
-+++ demos/test/makefile Mon Jan 10 16:35:58 2005
-@@ -19,7 +19,7 @@
- #CCMALLOC = -lccmalloc -ldl
-
- test: $(OBJECTS)
-- $(CC) $(CFLAGS) $(OBJECTS) /usr/lib/libtomcrypt.a $(CCMALLOC) -o test
-+ $(CC) $(CFLAGS) $(OBJECTS) $(PREFIX)/lib/libtomcrypt.a $(CCMALLOC) -o test
-
- clean:
- rm -rf test *.o *.obj *.exe *~ .libs
diff --git a/security/libtomcrypt/files/patch-makefile b/security/libtomcrypt/files/patch-makefile
deleted file mode 100644
index a582545b8fb2..000000000000
--- a/security/libtomcrypt/files/patch-makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- makefile.orig Thu Dec 30 19:55:17 2004
-+++ makefile Tue Jan 11 12:10:05 2005
-@@ -50,13 +50,13 @@
- #INCPATH-The directory to install the header files for libtomcrypt.
- #DATAPATH-The directory to install the pdf docs.
- DESTDIR=
--LIBPATH=/usr/lib
--INCPATH=/usr/include
--DATAPATH=/usr/share/doc/libtomcrypt/pdf
-+LIBPATH=$(PREFIX)/lib
-+INCPATH=$(PREFIX)/include
-+DATAPATH=$(PREFIX)/share/doc/libtomcrypt/pdf
-
- #Who do we install as?
- USER=root
--GROUP=root
-+GROUP=wheel
-
- #List of objects to compile.
-
-@@ -251,7 +251,7 @@
- latex crypt > /dev/null
- makeindex crypt.idx > /dev/null
- latex crypt > /dev/null
-- dvipdf crypt
-+ dvipdft crypt
- mv -ivf crypt.pdf doc/crypt.pdf
- rm -f $(LEFTOVERS)
-
diff --git a/security/libtomcrypt/pkg-plist b/security/libtomcrypt/pkg-plist
index 0d924ba0c98e..ea0c4303af7d 100644
--- a/security/libtomcrypt/pkg-plist
+++ b/security/libtomcrypt/pkg-plist
@@ -1,18 +1,20 @@
-lib/libtomcrypt.a
include/ltc_tommath.h
+include/tomcrypt.h
+include/tomcrypt_argchk.h
include/tomcrypt_cfg.h
-include/tomcrypt_misc.h
-include/tomcrypt_prng.h
include/tomcrypt_cipher.h
+include/tomcrypt_custom.h
include/tomcrypt_hash.h
+include/tomcrypt_mac.h
include/tomcrypt_macros.h
+include/tomcrypt_misc.h
include/tomcrypt_pk.h
-include/tomcrypt.h
-include/tomcrypt_argchk.h
-include/tomcrypt_custom.h
include/tomcrypt_pkcs.h
+include/tomcrypt_prng.h
+include/tomcrypt_test.h
include/tommath_class.h
include/tommath_superclass.h
+lib/libtomcrypt.a
%%PORTDOCS%%%%DOCSDIR%%/pdf/crypt.pdf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf/
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%