aboutsummaryrefslogtreecommitdiff
path: root/security/libwhisker
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2014-05-22 17:12:40 +0000
committerStefan Eßer <se@FreeBSD.org>2014-05-22 17:12:40 +0000
commitabea5cd3cee0cedbe6e90fef0af01a5e174b5354 (patch)
tree5d1c1716b6263fbee4a0e4bbe21c29c10cc3f059 /security/libwhisker
parentfe7e51337636ce550e5c85bbdc2f6253f237705d (diff)
downloadports-abea5cd3cee0cedbe6e90fef0af01a5e174b5354.tar.gz
ports-abea5cd3cee0cedbe6e90fef0af01a5e174b5354.zip
Notes
Diffstat (limited to 'security/libwhisker')
-rw-r--r--security/libwhisker/Makefile41
-rw-r--r--security/libwhisker/files/patch-Makefile.pl11
-rw-r--r--security/libwhisker/pkg-descr2
3 files changed, 29 insertions, 25 deletions
diff --git a/security/libwhisker/Makefile b/security/libwhisker/Makefile
index 4472332b562e..28dfc1dec7a2 100644
--- a/security/libwhisker/Makefile
+++ b/security/libwhisker/Makefile
@@ -4,41 +4,34 @@
PORTNAME= libwhisker
PORTVERSION= 2.5
CATEGORIES= security perl5
-MASTER_SITES= http://www.wiretrip.net/rfp/${PORTNAME}/
+MASTER_SITES= SF/whisker/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}2-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= se@FreeBSD.org
COMMENT= Perl module to create HTTP test scripts
-WRKSRC= ${WRKDIR}/${PORTNAME}2-${PORTVERSION}
+LICENSE= BSD2CLAUSE
NO_BUILD= yes
USES= perl5
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
+PLIST_FILES= ${SITE_PERL_REL}/LW2.pm \
+ %%PERL5_MAN3%%/LW2.3pm.gz
-PLIST_FILES= ${SITE_PERL_REL}/LW2.pm
+OPTIONS_DEFINE= DOCS
-MAN3= LW2.3pm
-MANPREFIX= ${LOCALBASE}/lib/perl5/${PERL_VER}/perl/
-
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
-
-NO_STAGE= yes
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.pl lib
do-install:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.pl ${INSTALL_TARGET}
- @${INSTALL_DATA} ${WRKSRC}/LW2.pm ${SITE_PERL}
- @${CHMOD} 444 ${SITE_PERL}/LW2.pm
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/docs ${DOCSDIR}/scripts
- cd ${WRKSRC} && ${INSTALL_DATA} README CHANGES KNOWNBUGS ${DOCSDIR}
- cd ${WRKSRC}/docs/ && ${INSTALL_DATA} * ${DOCSDIR}/docs
- cd ${WRKSRC}/scripts/ && ${INSTALL_SCRIPT} * ${DOCSDIR}/scripts
-.endif
+ @${MKDIR} ${STAGEDIR}${SITE_PERL}
+ @${MKDIR} ${STAGEDIR}${MAN3PREFIX}/man/man3
+ cd ${WRKSRC} && ${SETENV} DESTDIR=${STAGEDIR} ${PERL5} Makefile.pl install
+ @${CHMOD} 444 ${STAGEDIR}${SITE_PERL}/LW2.pm
+ @${CHMOD} 444 ${STAGEDIR}${MAN3PREFIX}/man/man3/LW2.3pm
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/docs
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/scripts
+ cd ${WRKSRC} && ${INSTALL_DATA} README CHANGES KNOWNBUGS ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs/ && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}/docs
+ cd ${WRKSRC}/scripts/ && ${INSTALL_SCRIPT} * ${STAGEDIR}${DOCSDIR}/scripts
.include <bsd.port.mk>
diff --git a/security/libwhisker/files/patch-Makefile.pl b/security/libwhisker/files/patch-Makefile.pl
new file mode 100644
index 000000000000..05526ee9f0d0
--- /dev/null
+++ b/security/libwhisker/files/patch-Makefile.pl
@@ -0,0 +1,11 @@
+--- ./Makefile.pl.orig 2010-01-24 04:35:26.000000000 +0000
++++ ./Makefile.pl 2014-05-21 16:29:01.000000000 +0000
+@@ -171,7 +171,7 @@
+ command_build() if(!-e $TARGET);
+ die("Can not install without Config.pm") if($MODULES{Config}==0);
+ $CWD=&cwd if($MODULES{Cwd}>0);
+- my $where=$DESTDIR . $Config{'man3direxp'};
++ my $where=$DESTDIR . $Config{'siteman3direxp'};
+ my $t = $TARGET;
+ if($LIBRARY){
+ $t="$PACKAGE.3pm";
diff --git a/security/libwhisker/pkg-descr b/security/libwhisker/pkg-descr
index 29ed1ec3c50d..4004289af101 100644
--- a/security/libwhisker/pkg-descr
+++ b/security/libwhisker/pkg-descr
@@ -8,4 +8,4 @@ Libwhisker has a few design principles:
- Contained: designed to not require external modules when possible
- Localized: does not require installation to use
-WWW: http://www.wiretrip.net/rfp/lw.asp
+WWW: http://sourceforge.net/projects/whisker/