aboutsummaryrefslogtreecommitdiff
path: root/security/lsh/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-02 02:56:29 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-02 02:56:29 +0000
commit28824c0b83fedcb931002eeb5a5c6939c0415778 (patch)
tree42c37a3af1050d1535ee3d8a45bd751c2f0f514c /security/lsh/Makefile
parent8908492156bdfdab3a8cfe87b33b56853b93d3b8 (diff)
downloadports-28824c0b83fedcb931002eeb5a5c6939c0415778.tar.gz
ports-28824c0b83fedcb931002eeb5a5c6939c0415778.zip
Notes
Diffstat (limited to 'security/lsh/Makefile')
-rw-r--r--security/lsh/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
new file mode 100644
index 000000000000..f4e692e5947e
--- /dev/null
+++ b/security/lsh/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: lsh secure shell
+# Date created: 29 MAY 2000
+# Whom: Eric Schwertfeger <eric@cybernut.com>
+#
+# $FreeBSD$
+
+PORTNAME= lsh
+PORTVERSION= 0.9.10
+CATEGORIES= security ipv6
+MASTER_SITES= ftp://ftp.lysator.liu.se/pub/security/lsh/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= eric@cybernut.com
+
+RESTRICTED= "Crypto; export-controlled"
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400014
+CONFIGURE_ARGS+=--without-ipv6
+.endif
+
+post-install:
+.for BIN in lsh lsh_keygen lsh_writekey sexp_conv srp-gen
+ strip ${PREFIX}/bin/${BIN}
+.endfor
+.for SBIN in lshd lsh_proxy
+ strip ${PREFIX}/sbin/${SBIN}
+.endfor
+.if !defined(NOPORTDOCS)
+ install-info --section="Miscellaneous" \
+ --entry="* LSH: (lsh). lsh secure remote shell documentation." \
+ ${PREFIX}/info/lsh.info ${PREFIX}/info/dir
+.endif
+
+.include <bsd.port.post.mk>