aboutsummaryrefslogtreecommitdiff
path: root/security/lsh/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-14 15:39:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-14 15:39:49 +0000
commit732e51da4aaee9a2eea428105f3de79c59586ba1 (patch)
tree2c2f7ebb2fb4fcb71a3d04e0deae7c40de1397df /security/lsh/Makefile
parent30fc4a094115d904bb309ef723bfd6582213e595 (diff)
downloadports-732e51da4aaee9a2eea428105f3de79c59586ba1.tar.gz
ports-732e51da4aaee9a2eea428105f3de79c59586ba1.zip
Notes
Diffstat (limited to 'security/lsh/Makefile')
-rw-r--r--security/lsh/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index ac5027a56277..da7a8cca1537 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -5,13 +5,14 @@
# $FreeBSD$
PORTNAME= lsh
-PORTVERSION= 1.5.3
-PORTREVISION= 3
+PORTVERSION= 2.0.1
CATEGORIES= security ipv6
MASTER_SITES= ${MASTER_SITE_GNUPG} \
ftp://ftp.lysator.liu.se/pub/security/%SUBDIR%/
MASTER_SITE_SUBDIR= lsh lsh/old
DISTNAME= ${PORTNAME}-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A secure (encrypted) remote shell compatible with ssh 2.0
@@ -26,6 +27,7 @@ INSTALL_TARGET= install
CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+USE_GPG?= yes
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
PLIST_SUB+= KRB=""
.else
@@ -35,6 +37,13 @@ PLIST_SUB+= KRB="@comment "
LDFLAGS+= ${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
.endif
+MAN1= lsftp.1 ssh-conv.1 lshg.1 lsh.1 lsh-writekey.1 lsh-upgrade.1 \
+ lsh-upgrade-key.1 lsh-make-seed.1 lsh-keygen.1 \
+ lsh-export-key.1 lsh-decrypt-key.1 lsh-decode-key.1 \
+ lsh-authorize.1
+MAN5= secsh.5 SPKI.5 SHA.5 DSA.5
+MAN8= sftp-server.8 lshd.8
+INFO= lsh nettle
.include <bsd.port.pre.mk>