aboutsummaryrefslogtreecommitdiff
path: root/security/lsh
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-14 15:39:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-14 15:39:49 +0000
commit732e51da4aaee9a2eea428105f3de79c59586ba1 (patch)
tree2c2f7ebb2fb4fcb71a3d04e0deae7c40de1397df /security/lsh
parent30fc4a094115d904bb309ef723bfd6582213e595 (diff)
downloadports-732e51da4aaee9a2eea428105f3de79c59586ba1.tar.gz
ports-732e51da4aaee9a2eea428105f3de79c59586ba1.zip
Notes
Diffstat (limited to 'security/lsh')
-rw-r--r--security/lsh/Makefile13
-rw-r--r--security/lsh/distinfo6
-rw-r--r--security/lsh/pkg-plist15
3 files changed, 22 insertions, 12 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index ac5027a56277..da7a8cca1537 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -5,13 +5,14 @@
# $FreeBSD$
PORTNAME= lsh
-PORTVERSION= 1.5.3
-PORTREVISION= 3
+PORTVERSION= 2.0.1
CATEGORIES= security ipv6
MASTER_SITES= ${MASTER_SITE_GNUPG} \
ftp://ftp.lysator.liu.se/pub/security/%SUBDIR%/
MASTER_SITE_SUBDIR= lsh lsh/old
DISTNAME= ${PORTNAME}-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A secure (encrypted) remote shell compatible with ssh 2.0
@@ -26,6 +27,7 @@ INSTALL_TARGET= install
CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+USE_GPG?= yes
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
PLIST_SUB+= KRB=""
.else
@@ -35,6 +37,13 @@ PLIST_SUB+= KRB="@comment "
LDFLAGS+= ${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
.endif
+MAN1= lsftp.1 ssh-conv.1 lshg.1 lsh.1 lsh-writekey.1 lsh-upgrade.1 \
+ lsh-upgrade-key.1 lsh-make-seed.1 lsh-keygen.1 \
+ lsh-export-key.1 lsh-decrypt-key.1 lsh-decode-key.1 \
+ lsh-authorize.1
+MAN5= secsh.5 SPKI.5 SHA.5 DSA.5
+MAN8= sftp-server.8 lshd.8
+INFO= lsh nettle
.include <bsd.port.pre.mk>
diff --git a/security/lsh/distinfo b/security/lsh/distinfo
index 3c58c0b9915c..574da64df4c7 100644
--- a/security/lsh/distinfo
+++ b/security/lsh/distinfo
@@ -1,2 +1,4 @@
-MD5 (lsh-1.5.3.tar.gz) = 7fa504d4ee7b39c27cc35c372056d17b
-SIZE (lsh-1.5.3.tar.gz) = 1682922
+MD5 (lsh-2.0.1.tar.gz) = 25ca0b4385779de3d58d2d5757f495c3
+SIZE (lsh-2.0.1.tar.gz) = 1866063
+MD5 (lsh-2.0.1.tar.gz.asc) = 0982d7b8c6439b79771823882bcd36d4
+SIZE (lsh-2.0.1.tar.gz.asc) = 189
diff --git a/security/lsh/pkg-plist b/security/lsh/pkg-plist
index 247e4196e1c6..8432609b8186 100644
--- a/security/lsh/pkg-plist
+++ b/security/lsh/pkg-plist
@@ -1,3 +1,4 @@
+bin/lcp
bin/lsftp
bin/lsh
bin/lsh-authorize
@@ -16,8 +17,10 @@ bin/srp-gen
bin/ssh-conv
include/nettle/aes.h
include/nettle/arcfour.h
+include/nettle/arctwo.h
include/nettle/base16.h
include/nettle/base64.h
+include/nettle/bignum.h
include/nettle/blowfish.h
include/nettle/buffer.h
include/nettle/cast128.h
@@ -32,24 +35,20 @@ include/nettle/md2.h
include/nettle/md4.h
include/nettle/md5-compat.h
include/nettle/md5.h
+include/nettle/memxor.h
include/nettle/nettle-meta.h
+include/nettle/nettle-types.h
include/nettle/pgp.h
+include/nettle/pkcs1.h
include/nettle/realloc.h
include/nettle/rsa.h
+include/nettle/rsa-compat.h
include/nettle/serpent.h
include/nettle/sexp.h
include/nettle/sha.h
include/nettle/twofish.h
include/nettle/yarrow.h
@dirrm include/nettle
-@unexec install-info --delete %D/info/lsh.info %D/info/dir
-@unexec install-info --delete %D/info/nettle.info %D/info/dir
-info/lsh.info
-info/nettle.info
-info/nettle.info-1
-info/nettle.info-2
-@exec install-info %D/info/lsh.info %D/info/dir
-@exec install-info %D/info/nettle.info %D/info/dir
lib/libnettle.a
sbin/lsh-execuv
%%KRB%%sbin/lsh-krb-checkpw