aboutsummaryrefslogtreecommitdiff
path: root/security/makepasswd
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
commit4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/makepasswd
parentb3b7323d8ef412f19e96f476f048c4f46aa36bab (diff)
downloadports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.tar.gz
ports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.zip
Notes
Diffstat (limited to 'security/makepasswd')
-rw-r--r--security/makepasswd/Makefile25
-rw-r--r--security/makepasswd/pkg-plist4
2 files changed, 11 insertions, 18 deletions
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
index e505ffb57724..46e3c08cc8d7 100644
--- a/security/makepasswd/Makefile
+++ b/security/makepasswd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= makepasswd
PORTVERSION= 1.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@@ -22,28 +22,25 @@ NO_BUILD= yes
USES= perl5
USE_PERL5= run
+PORT_OPTIONS= DOCS
+
RUN_DEPENDS+= p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAN1= makepasswd.1
-DOCS= CHANGES README
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PORTDOCS= CHANGES README
post-patch:
${REINPLACE_CMD} -e "s/use bytes;/#use bytes;/" ${WRKSRC}/makepasswd
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/makepasswd ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/makepasswd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/makepasswd/pkg-plist b/security/makepasswd/pkg-plist
deleted file mode 100644
index 4f66536b1d9f..000000000000
--- a/security/makepasswd/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/makepasswd
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%