aboutsummaryrefslogtreecommitdiff
path: root/security/makepasswd
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-01 08:04:10 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-01 08:04:10 +0000
commit5c6be7bf37f43c9caffb44ca7803f36023121dc9 (patch)
tree2456ff88f1e374f41cb5c55b573b38c98b5dab8a /security/makepasswd
parent4ac806ccc67cf9745ad76a224f26d259acb5ed85 (diff)
downloadports-5c6be7bf37f43c9caffb44ca7803f36023121dc9.tar.gz
ports-5c6be7bf37f43c9caffb44ca7803f36023121dc9.zip
Notes
Diffstat (limited to 'security/makepasswd')
-rw-r--r--security/makepasswd/Makefile35
-rw-r--r--security/makepasswd/distinfo1
-rw-r--r--security/makepasswd/pkg-descr7
-rw-r--r--security/makepasswd/pkg-plist4
4 files changed, 47 insertions, 0 deletions
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
new file mode 100644
index 000000000000..2e69dd8962f0
--- /dev/null
+++ b/security/makepasswd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: makepasswd
+# Date created: 7 March 2003
+# Whom: Toni Viemerö <toni.viemero@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= makepasswd
+PORTVERSION= 1.10
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= dists/potato/main/source/admin/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Random password generator
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= makepasswd.1
+DOCS= CHANGES README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/makepasswd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/makepasswd/distinfo b/security/makepasswd/distinfo
new file mode 100644
index 000000000000..cb34811b8248
--- /dev/null
+++ b/security/makepasswd/distinfo
@@ -0,0 +1 @@
+MD5 (makepasswd_1.10.orig.tar.gz) = 55842bb4c064ebcdedffb4afd5f0945a
diff --git a/security/makepasswd/pkg-descr b/security/makepasswd/pkg-descr
new file mode 100644
index 000000000000..054ce00c1341
--- /dev/null
+++ b/security/makepasswd/pkg-descr
@@ -0,0 +1,7 @@
+Generates true random passwords by using the /dev/random feature of
+Linux,
+with the emphasis on security over pronounceability. It can also
+encrypt
+plaintext passwords given on the command line.
+
+WWW: http://packages.debian.org/stable/admin/makepasswd.html
diff --git a/security/makepasswd/pkg-plist b/security/makepasswd/pkg-plist
new file mode 100644
index 000000000000..f4087be20385
--- /dev/null
+++ b/security/makepasswd/pkg-plist
@@ -0,0 +1,4 @@
+bin/makepasswd
+share/doc/makepasswd/CHANGES
+share/doc/makepasswd/README
+@dirrm share/doc/makepasswd