aboutsummaryrefslogtreecommitdiff
path: root/security/masscan
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-11-16 12:11:27 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-11-16 12:11:27 +0000
commit8e8505aa7261684a4eac0f9d0acfc81c8dc19e6b (patch)
treedbf5a8140d1a0f6e2c7b7ace86f20b8c274d488e /security/masscan
parent5a943a50615ff9ed9ce365f162e129b49ab20f62 (diff)
downloadports-8e8505aa7261684a4eac0f9d0acfc81c8dc19e6b.tar.gz
ports-8e8505aa7261684a4eac0f9d0acfc81c8dc19e6b.zip
Notes
Diffstat (limited to 'security/masscan')
-rw-r--r--security/masscan/Makefile28
-rw-r--r--security/masscan/distinfo2
-rw-r--r--security/masscan/pkg-descr7
3 files changed, 37 insertions, 0 deletions
diff --git a/security/masscan/Makefile b/security/masscan/Makefile
new file mode 100644
index 000000000000..a8b97af5c834
--- /dev/null
+++ b/security/masscan/Makefile
@@ -0,0 +1,28 @@
+# Created by: Chie Taguchi <taguchi.ch@gmail.com>
+# $FreeBSD$
+
+PORTNAME= masscan
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://github.com/robertdavidgraham/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
+
+MAINTAINER= taguchi.ch@gmail.com
+COMMENT= Very fast port scanner
+
+LICENSE= GPLv3
+
+FETCH_ARGS= -Fpr
+USES= gmake
+CFLAGS+= -I. -Wno-format
+MAKE_ARGS= SYS=freebsd CC=${CC} CFLAGS="${CFLAGS}" LIBS="-lpcap -lm ${PTHREAD_LIBS}"
+
+PLIST_FILES= bin/masscan man/man8/masscan.8.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/masscan ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/masscan.8 ${STAGEDIR}${MANPREFIX}/man/man8
+
+regression-test: build
+ ${WRKSRC}/bin/masscan --selftest
+
+.include <bsd.port.mk>
diff --git a/security/masscan/distinfo b/security/masscan/distinfo
new file mode 100644
index 000000000000..e1e39e9c469c
--- /dev/null
+++ b/security/masscan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (masscan-1.0.tar.gz) = 703f5b61246dd70f71c4145e254a0b9306ffd302b466a2b615ea9aae1db34d43
+SIZE (masscan-1.0.tar.gz) = 241907
diff --git a/security/masscan/pkg-descr b/security/masscan/pkg-descr
new file mode 100644
index 000000000000..c1b0fbb4cd78
--- /dev/null
+++ b/security/masscan/pkg-descr
@@ -0,0 +1,7 @@
+masscan is a very fast port scanner.
+
+Using masscan, you can get results similar to nmap.
+And masscan is not only faster than other scanners,
+also more flexible setting for address and port ranges.
+
+WWW: https://github.com/robertdavidgraham/masscan