aboutsummaryrefslogtreecommitdiff
path: root/security/mate-keyring
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /security/mate-keyring
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'security/mate-keyring')
-rw-r--r--security/mate-keyring/Makefile41
-rw-r--r--security/mate-keyring/distinfo2
-rw-r--r--security/mate-keyring/files/patch-configure.ac11
-rw-r--r--security/mate-keyring/files/patch-daemon_control_gkd-control-client.c11
-rw-r--r--security/mate-keyring/files/patch-egg_egg-unix-credentials.c44
-rw-r--r--security/mate-keyring/files/patch-pam_gkr-pam-client.c18
-rw-r--r--security/mate-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c11
-rw-r--r--security/mate-keyring/pkg-descr17
-rw-r--r--security/mate-keyring/pkg-plist246
9 files changed, 401 insertions, 0 deletions
diff --git a/security/mate-keyring/Makefile b/security/mate-keyring/Makefile
new file mode 100644
index 000000000000..5cb03c7ed988
--- /dev/null
+++ b/security/mate-keyring/Makefile
@@ -0,0 +1,41 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-keyring
+PORTVERSION= 1.6.0
+CATEGORIES= security mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program that keeps passwords and other secrets
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libtasn1.so:${PORTSDIR}/security/libtasn1
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= autogen common:build intlhack libmatekeyring ltverhack
+USE_GNOME= gnomehier glib20 gtk20
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib" \
+ --with-root-certs="${LOCALBASE}/share/certs" \
+ --with-gtk=2.0 \
+ --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.*
+
+GLIB_SCHEMAS= org.mate.crypto.cache.gschema.xml \
+ org.mate.crypto.pgp.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/security/mate-keyring/distinfo b/security/mate-keyring/distinfo
new file mode 100644
index 000000000000..85a897b48b5a
--- /dev/null
+++ b/security/mate-keyring/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-keyring-1.6.0.tar.xz) = f77c48c59a9611baa9721d0a30e78f148629d1754066844bea053cb80141652b
+SIZE (mate/mate-keyring-1.6.0.tar.xz) = 1339564
diff --git a/security/mate-keyring/files/patch-configure.ac b/security/mate-keyring/files/patch-configure.ac
new file mode 100644
index 000000000000..fcd5bab38705
--- /dev/null
+++ b/security/mate-keyring/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2013-03-24 01:28:30.000000000 -0500
++++ configure.ac 2013-03-24 01:29:26.000000000 -0500
+@@ -284,7 +284,7 @@
+
+ pam_status="no"
+ if test "$enable_pam" != "no"; then
+- AC_CHECK_HEADERS(security/pam_modules.h pam/pam_modules.h, [have_pam=yes; break], have_pam=no)
++ AC_CHECK_HEADERS(security/pam_modules.h, [have_pam=yes; break], have_pam=no)
+ if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
+ AC_MSG_ERROR(The PAM headers are missing)
+ elif test "$have_pam" = "yes"; then
diff --git a/security/mate-keyring/files/patch-daemon_control_gkd-control-client.c b/security/mate-keyring/files/patch-daemon_control_gkd-control-client.c
new file mode 100644
index 000000000000..6cdb0ca6a213
--- /dev/null
+++ b/security/mate-keyring/files/patch-daemon_control_gkd-control-client.c
@@ -0,0 +1,11 @@
+--- daemon/control/gkd-control-client.c.orig 2009-12-21 18:43:16.000000000 -0500
++++ daemon/control/gkd-control-client.c 2009-12-21 18:44:17.000000000 -0500
+@@ -31,6 +31,8 @@
+ #include <errno.h>
+ #include <fcntl.h>
+
++#include <string.h>
++#include <sys/stat.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/un.h>
diff --git a/security/mate-keyring/files/patch-egg_egg-unix-credentials.c b/security/mate-keyring/files/patch-egg_egg-unix-credentials.c
new file mode 100644
index 000000000000..5ae53f8b02cc
--- /dev/null
+++ b/security/mate-keyring/files/patch-egg_egg-unix-credentials.c
@@ -0,0 +1,44 @@
+--- egg/egg-unix-credentials.c.orig 2010-01-13 00:21:23.000000000 -0500
++++ egg/egg-unix-credentials.c 2010-01-13 00:25:46.000000000 -0500
+@@ -27,6 +27,7 @@
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <sys/param.h>
+ #include <sys/uio.h>
+ #include <sys/un.h>
+ #include <errno.h>
+@@ -37,6 +38,33 @@
+ #include <ucred.h>
+ #endif
+
++#if __FreeBSD_version < 701101
++static char *
++strndup (const char *s, size_t n)
++{
++ size_t nAvail;
++ char *p;
++
++ if (s == NULL)
++ return NULL;
++
++ if (memchr (s, '\0', n) != NULL) {
++ nAvail = strlen(s);
++ if (nAvail > n)
++ nAvail = n;
++ } else{
++ nAvail = n;
++ }
++ p = malloc (nAvail + 1);
++ if (p == NULL)
++ return NULL;
++ memcpy (p, s, nAvail);
++ p[nAvail] = '\0';
++
++ return p;
++}
++#endif
++
+ int
+ egg_unix_credentials_read (int sock, pid_t *pid, uid_t *uid)
+ {
diff --git a/security/mate-keyring/files/patch-pam_gkr-pam-client.c b/security/mate-keyring/files/patch-pam_gkr-pam-client.c
new file mode 100644
index 000000000000..c4c0ad88e944
--- /dev/null
+++ b/security/mate-keyring/files/patch-pam_gkr-pam-client.c
@@ -0,0 +1,18 @@
+--- pam/gkr-pam-client.c.orig 2008-10-07 12:25:23.000000000 -0400
++++ pam/gkr-pam-client.c 2008-10-07 12:38:36.000000000 -0400
+@@ -96,12 +96,12 @@ check_peer_same_uid (int sock)
+ struct xucred xuc;
+ socklen_t xuc_len = sizeof (xuc);
+
+- if (getsockopt (sock, SOL_SOCKET, LOCAL_PEERCRED, &xuc, &xuc_len) == 0 &&
+- xuc_len == sizeof (xuc)) {
++ if (getsockopt (sock, 0, LOCAL_PEERCRED, &xuc, &xuc_len) == 0 &&
++ xuc.cr_version == XUCRED_VERSION) {
+ uid = xuc.cr_uid;
+ } else {
+ syslog (GKR_LOG_ERR, "could not get mate-keyring-daemon socket credentials, "
+- "(returned len %d/%d)\n", xuc_len, (int)sizeof (xuc));
++ "(returned version %d/%d)\n", xuc.cr_version, XUCRED_VERSION);
+ return -1;
+ }
+
diff --git a/security/mate-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c b/security/mate-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c
new file mode 100644
index 000000000000..146d8b69da05
--- /dev/null
+++ b/security/mate-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c
@@ -0,0 +1,11 @@
+--- pkcs11/rpc-layer/gkm-rpc-dispatch.c.orig 2010-09-04 12:06:44.000000000 +0200
++++ pkcs11/rpc-layer/gkm-rpc-dispatch.c 2010-09-04 12:07:12.000000000 +0200
+@@ -784,7 +784,7 @@ rpc_C_Finalize (CallState *cs)
+ {
+ CK_SLOT_ID_PTR slots;
+ CK_ULONG n_slots, i;
+- CK_RV ret;
++ CK_RV ret = CKR_OK;
+
+ debug (("C_Finalize: enter"));
+
diff --git a/security/mate-keyring/pkg-descr b/security/mate-keyring/pkg-descr
new file mode 100644
index 000000000000..66f0d73bdefa
--- /dev/null
+++ b/security/mate-keyring/pkg-descr
@@ -0,0 +1,17 @@
+Mate-keyring is a program that keep password and other secrets for
+users. It is run as a damon in the session, similar to ssh-agent, and
+other applications can locate it by an environment variable.
+
+The program can manage several keyrings, each with its own master
+password, and there is also a session keyring which is never stored to
+disk, but forgotten when the session ends.
+
+The library libmatekeyring is used by applications to integrate with
+the MATE keyring system. However, at this point the library hasn't been
+tested and used enought to consider the API to be publically
+exposed. Therefore use of libmatekeyring is at the moment limited to
+internal use in the MATE desktop. However, we hope that the
+mate-keyring API will turn out useful and good, so that later it
+can be made public for any application to use.
+
+WWW: http://mate-desktop.org/
diff --git a/security/mate-keyring/pkg-plist b/security/mate-keyring/pkg-plist
new file mode 100644
index 000000000000..bd6defa4dfef
--- /dev/null
+++ b/security/mate-keyring/pkg-plist
@@ -0,0 +1,246 @@
+bin/mate-keyring
+bin/mate-keyring-daemon
+etc/xdg/autostart/mate-keyring-gpg.desktop
+etc/xdg/autostart/mate-keyring-pkcs11.desktop
+etc/xdg/autostart/mate-keyring-secrets.desktop
+etc/xdg/autostart/mate-keyring-ssh.desktop
+include/gck/pkcs11.h
+include/gck/pkcs11n.h
+include/gck/pkcs11x.h
+include/mate-gck/gck.h
+include/mategcr/gcr/gcr-certificate-basics-widget.h
+include/mategcr/gcr/gcr-certificate-chain.h
+include/mategcr/gcr/gcr-certificate-details-widget.h
+include/mategcr/gcr/gcr-certificate-renderer.h
+include/mategcr/gcr/gcr-certificate-widget.h
+include/mategcr/gcr/gcr-certificate.h
+include/mategcr/gcr/gcr-importer.h
+include/mategcr/gcr/gcr-key-renderer.h
+include/mategcr/gcr/gcr-key-widget.h
+include/mategcr/gcr/gcr-library.h
+include/mategcr/gcr/gcr-parser.h
+include/mategcr/gcr/gcr-pkcs11-certificate.h
+include/mategcr/gcr/gcr-renderer.h
+include/mategcr/gcr/gcr-simple-certificate.h
+include/mategcr/gcr/gcr-trust.h
+include/mategcr/gcr/gcr-types.h
+include/mategcr/gcr/gcr-unlock-options-widget.h
+include/mategcr/gcr/gcr-unlock-options.h
+include/mategcr/gcr/gcr-viewer.h
+include/mategcr/gcr/gcr.h
+lib/libmategck.a
+lib/libmategck.la
+lib/libmategck.so
+lib/libmategck.so.0
+lib/libmategcr.a
+lib/libmategcr.la
+lib/libmategcr.so
+lib/libmategcr.so.0
+lib/mate-keyring/devel/gkm-mate2-store-standalone.a
+lib/mate-keyring/devel/gkm-mate2-store-standalone.la
+lib/mate-keyring/devel/gkm-mate2-store-standalone.so
+lib/mate-keyring/devel/gkm-roots-store-standalone.a
+lib/mate-keyring/devel/gkm-roots-store-standalone.la
+lib/mate-keyring/devel/gkm-roots-store-standalone.so
+lib/mate-keyring/devel/gkm-ssh-store-standalone.a
+lib/mate-keyring/devel/gkm-ssh-store-standalone.la
+lib/mate-keyring/devel/gkm-ssh-store-standalone.so
+lib/mate-keyring/devel/gkm-xdg-store-standalone.a
+lib/mate-keyring/devel/gkm-xdg-store-standalone.la
+lib/mate-keyring/devel/gkm-xdg-store-standalone.so
+lib/mate-keyring/standalone/gkm-secret-store-standalone.a
+lib/mate-keyring/standalone/gkm-secret-store-standalone.la
+lib/mate-keyring/standalone/gkm-secret-store-standalone.so
+lib/pam_mate_keyring.a
+lib/pam_mate_keyring.la
+lib/pam_mate_keyring.so
+lib/pkcs11/mate-keyring-pkcs11.a
+lib/pkcs11/mate-keyring-pkcs11.la
+lib/pkcs11/mate-keyring-pkcs11.so
+libdata/pkgconfig/mate-gck-0.pc
+libdata/pkgconfig/mate-gcr-0.pc
+libexec/mate-keyring-prompt
+share/MateConf/gsettings/org.mate.crypto.cache.convert
+share/MateConf/gsettings/org.mate.crypto.pgp.convert
+share/dbus-1/services/org.mate-freedesktop.secrets.service
+share/dbus-1/services/org.mate.keyring.service
+share/doc/mate-gck/GckModule.html
+share/doc/mate-gck/GckObject.html
+share/doc/mate-gck/GckSession.html
+share/doc/mate-gck/GckSlot.html
+share/doc/mate-gck/ch01.html
+share/doc/mate-gck/gck-Errors.html
+share/doc/mate-gck/gck-GckAttribute.html
+share/doc/mate-gck/gck-GckAttributes.html
+share/doc/mate-gck/gck-Miscellaneous-Functions.html
+share/doc/mate-gck/gck-PKCS11-URIs.html
+share/doc/mate-gck/gck.devhelp
+share/doc/mate-gck/gck.devhelp2
+share/doc/mate-gck/home.png
+share/doc/mate-gck/index.html
+share/doc/mate-gck/index.sgml
+share/doc/mate-gck/left.png
+share/doc/mate-gck/right.png
+share/doc/mate-gck/style.css
+share/doc/mate-gck/up.png
+share/doc/mate-gcr-0/GcrCertificateChain.html
+share/doc/mate-gcr-0/GcrPkcs11Certificate.html
+share/doc/mate-gcr-0/GcrSimpleCertificate.html
+share/doc/mate-gcr-0/certificates.html
+share/doc/mate-gcr-0/gcr-GcrCertificate.html
+share/doc/mate-gcr-0/gcr-Library-Settings.html
+share/doc/mate-gcr-0/gcr-Trust-Storage-and-Lookups.html
+share/doc/mate-gcr-0/gcr-gcr-importer.html
+share/doc/mate-gcr-0/gcr-gcr-initializer.html
+share/doc/mate-gcr-0/gcr-gcr-parser.html
+share/doc/mate-gcr-0/gcr.devhelp
+share/doc/mate-gcr-0/gcr.devhelp2
+share/doc/mate-gcr-0/home.png
+share/doc/mate-gcr-0/index.html
+share/doc/mate-gcr-0/index.sgml
+share/doc/mate-gcr-0/left.png
+share/doc/mate-gcr-0/misc.html
+share/doc/mate-gcr-0/right.png
+share/doc/mate-gcr-0/storage.html
+share/doc/mate-gcr-0/style.css
+share/doc/mate-gcr-0/up.png
+share/locale/af/LC_MESSAGES/mate-keyring.mo
+share/locale/am/LC_MESSAGES/mate-keyring.mo
+share/locale/ar/LC_MESSAGES/mate-keyring.mo
+share/locale/as/LC_MESSAGES/mate-keyring.mo
+share/locale/ast/LC_MESSAGES/mate-keyring.mo
+share/locale/az/LC_MESSAGES/mate-keyring.mo
+share/locale/be/LC_MESSAGES/mate-keyring.mo
+share/locale/be@latin/LC_MESSAGES/mate-keyring.mo
+share/locale/bg/LC_MESSAGES/mate-keyring.mo
+share/locale/bn/LC_MESSAGES/mate-keyring.mo
+share/locale/bn_IN/LC_MESSAGES/mate-keyring.mo
+share/locale/bs/LC_MESSAGES/mate-keyring.mo
+share/locale/ca/LC_MESSAGES/mate-keyring.mo
+share/locale/ca@valencia/LC_MESSAGES/mate-keyring.mo
+share/locale/cs/LC_MESSAGES/mate-keyring.mo
+share/locale/cy/LC_MESSAGES/mate-keyring.mo
+share/locale/da/LC_MESSAGES/mate-keyring.mo
+share/locale/de/LC_MESSAGES/mate-keyring.mo
+share/locale/dz/LC_MESSAGES/mate-keyring.mo
+share/locale/el/LC_MESSAGES/mate-keyring.mo
+share/locale/en@shaw/LC_MESSAGES/mate-keyring.mo
+share/locale/en_AU/LC_MESSAGES/mate-keyring.mo
+share/locale/en_CA/LC_MESSAGES/mate-keyring.mo
+share/locale/en_GB/LC_MESSAGES/mate-keyring.mo
+share/locale/es/LC_MESSAGES/mate-keyring.mo
+share/locale/et/LC_MESSAGES/mate-keyring.mo
+share/locale/eu/LC_MESSAGES/mate-keyring.mo
+share/locale/fa/LC_MESSAGES/mate-keyring.mo
+share/locale/fi/LC_MESSAGES/mate-keyring.mo
+share/locale/fr/LC_MESSAGES/mate-keyring.mo
+share/locale/ga/LC_MESSAGES/mate-keyring.mo
+share/locale/gl/LC_MESSAGES/mate-keyring.mo
+share/locale/gu/LC_MESSAGES/mate-keyring.mo
+share/locale/he/LC_MESSAGES/mate-keyring.mo
+share/locale/hi/LC_MESSAGES/mate-keyring.mo
+share/locale/hr/LC_MESSAGES/mate-keyring.mo
+share/locale/hu/LC_MESSAGES/mate-keyring.mo
+share/locale/id/LC_MESSAGES/mate-keyring.mo
+share/locale/is/LC_MESSAGES/mate-keyring.mo
+share/locale/it/LC_MESSAGES/mate-keyring.mo
+share/locale/ja/LC_MESSAGES/mate-keyring.mo
+share/locale/ka/LC_MESSAGES/mate-keyring.mo
+share/locale/kn/LC_MESSAGES/mate-keyring.mo
+share/locale/ko/LC_MESSAGES/mate-keyring.mo
+share/locale/ky/LC_MESSAGES/mate-keyring.mo
+share/locale/lt/LC_MESSAGES/mate-keyring.mo
+share/locale/lv/LC_MESSAGES/mate-keyring.mo
+share/locale/mai/LC_MESSAGES/mate-keyring.mo
+share/locale/mg/LC_MESSAGES/mate-keyring.mo
+share/locale/mk/LC_MESSAGES/mate-keyring.mo
+share/locale/ml/LC_MESSAGES/mate-keyring.mo
+share/locale/mn/LC_MESSAGES/mate-keyring.mo
+share/locale/mr/LC_MESSAGES/mate-keyring.mo
+share/locale/ms/LC_MESSAGES/mate-keyring.mo
+share/locale/nb/LC_MESSAGES/mate-keyring.mo
+share/locale/ne/LC_MESSAGES/mate-keyring.mo
+share/locale/nl/LC_MESSAGES/mate-keyring.mo
+share/locale/nn/LC_MESSAGES/mate-keyring.mo
+share/locale/oc/LC_MESSAGES/mate-keyring.mo
+share/locale/or/LC_MESSAGES/mate-keyring.mo
+share/locale/pa/LC_MESSAGES/mate-keyring.mo
+share/locale/pl/LC_MESSAGES/mate-keyring.mo
+share/locale/pt/LC_MESSAGES/mate-keyring.mo
+share/locale/pt_BR/LC_MESSAGES/mate-keyring.mo
+share/locale/ro/LC_MESSAGES/mate-keyring.mo
+share/locale/ru/LC_MESSAGES/mate-keyring.mo
+share/locale/rw/LC_MESSAGES/mate-keyring.mo
+share/locale/si/LC_MESSAGES/mate-keyring.mo
+share/locale/sk/LC_MESSAGES/mate-keyring.mo
+share/locale/sl/LC_MESSAGES/mate-keyring.mo
+share/locale/sq/LC_MESSAGES/mate-keyring.mo
+share/locale/sr/LC_MESSAGES/mate-keyring.mo
+share/locale/sr@latin/LC_MESSAGES/mate-keyring.mo
+share/locale/sv/LC_MESSAGES/mate-keyring.mo
+share/locale/ta/LC_MESSAGES/mate-keyring.mo
+share/locale/te/LC_MESSAGES/mate-keyring.mo
+share/locale/th/LC_MESSAGES/mate-keyring.mo
+share/locale/tr/LC_MESSAGES/mate-keyring.mo
+share/locale/ug/LC_MESSAGES/mate-keyring.mo
+share/locale/uk/LC_MESSAGES/mate-keyring.mo
+share/locale/vi/LC_MESSAGES/mate-keyring.mo
+share/locale/xh/LC_MESSAGES/mate-keyring.mo
+share/locale/zh_CN/LC_MESSAGES/mate-keyring.mo
+share/locale/zh_HK/LC_MESSAGES/mate-keyring.mo
+share/locale/zh_TW/LC_MESSAGES/mate-keyring.mo
+%%DATADIR%%/ui/gku-prompt.ui
+share/mategcr/ui/gcr-import-dialog.ui
+share/mategcr/ui/gcr-unlock-options-widget.ui
+@dirrm share/mategcr/ui
+@dirrm share/mategcr
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+@dirrm share/doc/mate-gcr-0
+@dirrm share/doc/mate-gck
+@dirrmtry lib/pkcs11
+@dirrm lib/mate-keyring/standalone
+@dirrm lib/mate-keyring/devel
+@dirrm lib/mate-keyring
+@dirrm include/mategcr/gcr
+@dirrm include/mategcr
+@dirrm include/mate-gck
+@dirrm include/gck