aboutsummaryrefslogtreecommitdiff
path: root/security/matrixssl
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2006-03-17 15:54:09 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2006-03-17 15:54:09 +0000
commitb5dc8972d2b67e0bee6d88799a2e4132fd259c86 (patch)
tree3116f67a707e430f763430be61f88f1f7effe370 /security/matrixssl
parent456bbaed3b423d15772f5625346630a69ec9064b (diff)
downloadports-b5dc8972d2b67e0bee6d88799a2e4132fd259c86.tar.gz
ports-b5dc8972d2b67e0bee6d88799a2e4132fd259c86.zip
Add matrixssl, a small GPL'd SSL implementation.
Notes
Notes: svn path=/head/; revision=157498
Diffstat (limited to 'security/matrixssl')
-rw-r--r--security/matrixssl/Makefile32
-rw-r--r--security/matrixssl/distinfo3
-rw-r--r--security/matrixssl/files/patch-Makefile21
-rw-r--r--security/matrixssl/files/patch-examples-sslSocket.h10
-rw-r--r--security/matrixssl/files/patch-os-linux-linux.c41
-rw-r--r--security/matrixssl/files/patch-os-osLayer.h11
-rw-r--r--security/matrixssl/pkg-descr6
-rw-r--r--security/matrixssl/pkg-plist21
8 files changed, 145 insertions, 0 deletions
diff --git a/security/matrixssl/Makefile b/security/matrixssl/Makefile
new file mode 100644
index 000000000000..74acf24a2417
--- /dev/null
+++ b/security/matrixssl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection Makefile for: matrixssl
+# Date created: 2006-03-17
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= matrixssl
+PORTVERSION= 1.7.3
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+DISTNAME= ${PORTNAME}-${PORTVERSION:S,.,-,g}-open
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Small alternative SSL implementation
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/matrixssl/src
+INSTALLS_SHLIB= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libmatrixssl* ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/../*.h ${PREFIX}/include
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/../doc/* ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/../examples/* ${EXAMPLESDIR}
+ cd ${EXAMPLESDIR}; ${RM} *.vcproj *.sln *.orig
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/matrixssl/distinfo b/security/matrixssl/distinfo
new file mode 100644
index 000000000000..e4a0bc54ec25
--- /dev/null
+++ b/security/matrixssl/distinfo
@@ -0,0 +1,3 @@
+MD5 (matrixssl-1-7-3-open.tar.gz) = b80faff3e389000b9a161dda4812112d
+SHA256 (matrixssl-1-7-3-open.tar.gz) = 66b60065eb1cc3fc6d98cb161b50ceef4eb48bdccdc919b6773d9bf5b6e44b28
+SIZE (matrixssl-1-7-3-open.tar.gz) = 346585
diff --git a/security/matrixssl/files/patch-Makefile b/security/matrixssl/files/patch-Makefile
new file mode 100644
index 000000000000..13742dae3fd5
--- /dev/null
+++ b/security/matrixssl/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Fri Mar 17 16:30:14 2006
++++ Makefile Fri Mar 17 16:31:40 2006
+@@ -5,7 +5,6 @@
+ # Copyright (c) PeerSec Networks, 2002-2005. All Rights Reserved.
+ #
+
+-CC = gcc
+ STRIP = strip
+ AR = ar
+ RANLIB = ranlib
+@@ -69,8 +68,8 @@
+ # Compile options
+ #
+ SHARED = -shared
+-CFLAGS = $(DFLAGS) -DLINUX -I./
+-LDFLAGS = -lc -lpthread
++CFLAGS += -DLINUX -I./ ${PTHREAD_CFLAGS}
++LDFLAGS += ${PTHREAD_LIBS}
+
+ #
+ # Override variables for compilation on Mac OS X (Darwin)
diff --git a/security/matrixssl/files/patch-examples-sslSocket.h b/security/matrixssl/files/patch-examples-sslSocket.h
new file mode 100644
index 000000000000..80c8f1c04e62
--- /dev/null
+++ b/security/matrixssl/files/patch-examples-sslSocket.h
@@ -0,0 +1,10 @@
+--- ../examples/sslSocket.h.orig Fri Mar 17 16:32:41 2006
++++ ../examples/sslSocket.h Fri Mar 17 16:32:59 2006
+@@ -50,6 +50,7 @@
+ #define getSocketError() WSAGetLastError()
+ #elif LINUX
+ #include <sys/socket.h>
++ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+ #include <arpa/inet.h>
diff --git a/security/matrixssl/files/patch-os-linux-linux.c b/security/matrixssl/files/patch-os-linux-linux.c
new file mode 100644
index 000000000000..827684028973
--- /dev/null
+++ b/security/matrixssl/files/patch-os-linux-linux.c
@@ -0,0 +1,41 @@
+--- os/linux/linux.c.orig Fri Mar 17 16:03:55 2006
++++ os/linux/linux.c Fri Mar 17 16:04:27 2006
+@@ -39,7 +39,7 @@
+
+ #include "../osLayer.h"
+
+-#if defined(__i386__) || defined(RDTSC)
++#if (defined(__i386__) || defined(RDTSC))&& !defined(__FreeBSD__)
+ #include <asm/timex.h>
+ /*
+ As defined in asm/timex.h for x386:
+@@ -86,7 +86,7 @@
+ /*
+ Initialize times
+ */
+-#if defined(__i386__) || defined(RDTSC)
++#if (defined(__i386__) || defined(RDTSC)) && !defined(__FreeBSD__)
+ if ((cpuInfo = fopen ("/proc/cpuinfo","r")) == NULL) {
+ matrixStrDebugMsg("Error opening /proc/cpuinfo\n", NULL);
+ return -2;
+@@ -122,7 +122,11 @@
+ #ifdef USE_MULTITHREADING
+ pthread_mutexattr_init(&attr);
+ #ifndef OSX
++#ifndef PTHREAD_MUTEX_RECURSIVE_NP
++ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);
++#else
+ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE_NP);
++#endif /* PTHREAD_MUTEX_RECURSIVE_NP */
+ #endif /* !OSX */
+ #endif /* USE_MULTITHREADING */
+ return psOpenMalloc(MAX_MEMORY_USAGE);
+@@ -252,7 +256,7 @@
+ /*
+ Use a platform specific high resolution timer
+ */
+-#if defined(__i386__) || defined(RDTSC)
++#if (defined(__i386__) || defined(RDTSC)) && !defined(__FreeBSD__)
+
+ int32 sslInitMsecs(sslTime_t *t)
+ {
diff --git a/security/matrixssl/files/patch-os-osLayer.h b/security/matrixssl/files/patch-os-osLayer.h
new file mode 100644
index 000000000000..4cdcb0423b5f
--- /dev/null
+++ b/security/matrixssl/files/patch-os-osLayer.h
@@ -0,0 +1,11 @@
+--- os/osLayer.h.orig Fri Mar 17 16:06:31 2006
++++ os/osLayer.h Fri Mar 17 16:06:34 2006
+@@ -119,7 +119,7 @@
+ long sec;
+ long usec;
+ } sslTime_t;
+-#elif (defined(__i386__) || defined(RDTSC))
++#elif (defined(__i386__) || defined(RDTSC)) && !defined(__FreeBSD__)
+ typedef unsigned long long LARGE_INTEGER;
+ typedef LARGE_INTEGER sslTime_t;
+ #elif WINCE
diff --git a/security/matrixssl/pkg-descr b/security/matrixssl/pkg-descr
new file mode 100644
index 000000000000..80d35e8de262
--- /dev/null
+++ b/security/matrixssl/pkg-descr
@@ -0,0 +1,6 @@
+PeerSec Networks MatrixSSL? is an embedded SSL implementation designed for
+small footprint applications and devices. PeerSec Networks offers a fully
+supported, commercial version as well as an open source version that is
+available for download.
+
+WWW: http://www.matrixssl.org/
diff --git a/security/matrixssl/pkg-plist b/security/matrixssl/pkg-plist
new file mode 100644
index 000000000000..986cc9889f80
--- /dev/null
+++ b/security/matrixssl/pkg-plist
@@ -0,0 +1,21 @@
+include/matrixCommon.h
+include/matrixSsl.h
+lib/libmatrixssl.so
+lib/libmatrixsslstatic.a
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLApi.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLDeveloperGuide.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLKeyGeneration.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLPortingGuide.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLQuickStart.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLSocketApi.pdf
+%%PORTDOCS%%%%EXAMPLESDIR%%/CAcertSrv.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/certSrv.p12
+%%PORTDOCS%%%%EXAMPLESDIR%%/certSrv.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/httpsClient.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/httpsReflector.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/privkeySrv.pem
+%%PORTDOCS%%%%EXAMPLESDIR%%/sslSocket.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/sslSocket.h
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%