aboutsummaryrefslogtreecommitdiff
path: root/security/matrixssl
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-11-30 23:50:42 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-11-30 23:50:42 +0000
commit1dcc6b441b877c5996554ac2e14879ea03890294 (patch)
tree04afd9583c1794633b4e48beb0298f3abd55c1ef /security/matrixssl
parent129a867c3cc3efd4a5924d0cdeddf29b7ba3516c (diff)
Notes
Diffstat (limited to 'security/matrixssl')
-rw-r--r--security/matrixssl/Makefile64
-rw-r--r--security/matrixssl/distinfo4
-rw-r--r--security/matrixssl/files/patch-examples-sslSocket.h10
-rw-r--r--security/matrixssl/pkg-plist71
4 files changed, 97 insertions, 52 deletions
diff --git a/security/matrixssl/Makefile b/security/matrixssl/Makefile
index b3baaf39a1b1..fa0ec0a583b1 100644
--- a/security/matrixssl/Makefile
+++ b/security/matrixssl/Makefile
@@ -5,34 +5,66 @@
# $FreeBSD$
PORTNAME= matrixssl
-PORTVERSION= 1.8.8
+PORTVERSION= 3.3
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
-MASTER_SITE_SUBDIR= distfiles
-DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CDRAKE
+DISTNAME= Crypt-MatrixSSL3-3.3.0.1
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Small alternative SSL implementation
+LICENSE= GPLv2 # (or later)
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}-${PORTVERSION:S/./-/g}-open
+
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/matrixssl-1-8-8-open/src
+MAKE_ARGS= CC="${CC}" DFLAGS="${CFLAGS}" STRIP="${TEST}"
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
+CFLAGS+= -DPSTM_64BIT
+.endif
post-extract:
- cd ${WRKDIR} && ${TAR} -xvf matrixssl-1-8-8-open.tgz
+ @cd ${WRKDIR}/${DISTNAME} \
+ && ${TAR} -xf ${PORTNAME}-${PORTVERSION:S/./-/g}-open.tgz
+
+pre-patch:
+ @cd ${WRKDIR}/${DISTNAME} \
+ && ${CAT} ${PORTNAME}-${PORTVERSION:S/./-/g}-open.patch | \
+ ${PATCH} -d ${WRKSRC} -p1 --quiet
post-patch:
- ${REINPLACE_CMD} -e "s,^CC,#CC,;s,-O3,${CFLAGS}," ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|^LDFLAGS|#LDFLAGS|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_DATA} ${WRKSRC}/libmatrixssl* ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/../*.h ${PREFIX}/include
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${CP} ${WRKSRC}/../doc/* ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} ${WRKSRC}/../examples/* ${EXAMPLESDIR}
- -cd ${EXAMPLESDIR}; ${RM} *.vcproj *.sln *.orig
+ ${INSTALL_DATA} ${WRKSRC}/libmatrixssl.* ${PREFIX}/lib
+ @${MKDIR} ${PREFIX}/include/matrixssl
+ ${INSTALL_DATA} ${WRKSRC}/matrixssl/*.h ${PREFIX}/include/matrixssl
+ @${MKDIR} ${PREFIX}/include/matrixssl/core
+ ${INSTALL_DATA} ${WRKSRC}/core/*.h ${PREFIX}/include/matrixssl/core
+ @${MKDIR} ${PREFIX}/include/matrixssl/crypto
+ ${INSTALL_DATA} ${WRKSRC}/crypto/*.h ${PREFIX}/include/matrixssl/crypto
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}/apps
+ ${INSTALL_DATA} ${WRKSRC}/apps/Makefile ${EXAMPLESDIR}/apps
+ ${INSTALL_DATA} ${WRKSRC}/apps/*.c ${EXAMPLESDIR}/apps
+ ${INSTALL_DATA} ${WRKSRC}/apps/*.h ${EXAMPLESDIR}/apps
+ @${MKDIR} ${EXAMPLESDIR}/sampleCerts
+ ${INSTALL_DATA} ${WRKSRC}/sampleCerts/*.h ${EXAMPLESDIR}/sampleCerts
+ ${INSTALL_DATA} ${WRKSRC}/sampleCerts/*.pem ${EXAMPLESDIR}/sampleCerts
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/matrixssl/distinfo b/security/matrixssl/distinfo
index 3d59f664ccdc..f495081032c6 100644
--- a/security/matrixssl/distinfo
+++ b/security/matrixssl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (matrixssl_1.8.8.orig.tar.gz) = 6c40581406b7732030d8bdf2fb40628448b826b36b0f81745d43479f028537b6
-SIZE (matrixssl_1.8.8.orig.tar.gz) = 735470
+SHA256 (Crypt-MatrixSSL3-3.3.0.1.tgz) = 4693155e64041c8c81cf53f084b502d0238d539676001856d05b6a19855769ff
+SIZE (Crypt-MatrixSSL3-3.3.0.1.tgz) = 4142631
diff --git a/security/matrixssl/files/patch-examples-sslSocket.h b/security/matrixssl/files/patch-examples-sslSocket.h
deleted file mode 100644
index 5eb96d398843..000000000000
--- a/security/matrixssl/files/patch-examples-sslSocket.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../examples/sslSocket.h.orig 2010-02-01 00:06:47.000000000 +0100
-+++ ../examples/sslSocket.h 2010-02-01 00:06:59.000000000 +0100
-@@ -50,6 +50,7 @@
- #define getSocketError() WSAGetLastError()
- #elif LINUX
- #include <sys/socket.h>
-+ #include <sys/types.h>
- #include <netinet/in.h>
- #include <netinet/tcp.h>
- #include <arpa/inet.h>
diff --git a/security/matrixssl/pkg-plist b/security/matrixssl/pkg-plist
index 5ae67f3fa07b..a65b2ee2dab1 100644
--- a/security/matrixssl/pkg-plist
+++ b/security/matrixssl/pkg-plist
@@ -1,26 +1,49 @@
-include/matrixCommon.h
-include/matrixSsl.h
+include/matrixssl/core/coreApi.h
+include/matrixssl/core/coreConfig.h
+include/matrixssl/core/list.h
+include/matrixssl/core/osdep.h
+include/matrixssl/core/psmalloc.h
+include/matrixssl/crypto/cryptoApi.h
+include/matrixssl/crypto/cryptoConfig.h
+include/matrixssl/crypto/cryptolib.h
+include/matrixssl/matrixsslApi.h
+include/matrixssl/matrixsslConfig.h
+include/matrixssl/matrixssllib.h
+include/matrixssl/version.h
+lib/libmatrixssl.a
lib/libmatrixssl.so
-lib/libmatrixsslstatic.a
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLReadme.pdf
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLApi.pdf
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLDeveloperGuide.pdf
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLKeyGeneration.pdf
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLPortingGuide.pdf
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSLSocketApi.pdf
-%%PORTDOCS%%%%DOCSDIR%%/MatrixSSL-1.8.8-SecurityNotes.pdf
-%%PORTDOCS%%%%DOCSDIR%%/Renegotiating_TLS.pdf
-%%PORTDOCS%%%%EXAMPLESDIR%%/CAcertSrv.pem
-%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/certSrv.p12
-%%PORTDOCS%%%%EXAMPLESDIR%%/certSrv.pem
-%%PORTDOCS%%%%EXAMPLESDIR%%/httpsClient.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/httpsReflector.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/privkeySrv.pem
-%%PORTDOCS%%%%EXAMPLESDIR%%/sslSocket.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/sslSocket.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/CAcertSrv.der
-%%PORTDOCS%%%%EXAMPLESDIR%%/privkeySrv.der
-%%PORTDOCS%%%%EXAMPLESDIR%%/certSrv.der
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSL_3-3-OpenReleaseNotes.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSL_API.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSL_DevelopersGuide.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSL_GettingStarted.pdf
+%%PORTDOCS%%%%DOCSDIR%%/MatrixSSL_PortingGuide.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/apps/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/apps/app.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/apps/client.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/apps/http.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/apps/server.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/CAcertSrv.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/CAcertSrv.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/CAcertSrv2048.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/CAcertSrv2048.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/CAcertSrv512.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/CAcertSrv512.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/certSrv.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/certSrv.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/certSrv2048.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/certSrv2048.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/certSrv512.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/certSrv512.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/privkeySrv.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/privkeySrv.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/privkeySrv2048.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/privkeySrv2048.pem
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/privkeySrv512.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleCerts/privkeySrv512.pem
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sampleCerts
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/apps
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm include/matrixssl/crypto
+@dirrm include/matrixssl/core
+@dirrm include/matrixssl