aboutsummaryrefslogtreecommitdiff
path: root/security/mbedtls/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-07-16 08:42:37 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-07-16 08:42:37 +0000
commit9dda8dd58fec29091de0a30f016b9a820f43342a (patch)
tree82ea0489806d212e694528b8d50a044670d83f76 /security/mbedtls/Makefile
parenta70ecc3140165d19ed2290e0748150c9c3ec0b90 (diff)
Notes
Diffstat (limited to 'security/mbedtls/Makefile')
-rw-r--r--security/mbedtls/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/mbedtls/Makefile b/security/mbedtls/Makefile
new file mode 100644
index 000000000000..3f373ba00e20
--- /dev/null
+++ b/security/mbedtls/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= mbedtls
+PORTVERSION= 2.0.0
+DISTVERSIONSUFFIX= -gpl
+CATEGORIES= security devel
+MASTER_SITES= https://tls.mbed.org/download/
+
+MAINTAINER= tijl@FreeBSD.org
+COMMENT= SSL/TLS and cryptography library
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ALL_TARGET= no_test
+MAKE_ENV= SHARED=1
+USES= gmake tar:tgz
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/mbedtls-${PORTVERSION}
+
+CONFLICTS_INSTALL= polarssl13-[0-9]*
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/PREFIX/NAMEPREFIX/' \
+ -e 's/$$(DESTDIR)/&$$(PREFIX)/' \
+ -e '/^install:/s/[[:<:]]all//' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${FIND} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/lib -type f | \
+ ${XARGS} ${STRIP_CMD}
+
+.include <bsd.port.mk>