aboutsummaryrefslogtreecommitdiff
path: root/security/mdcrack
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-26 16:00:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-26 16:00:41 +0000
commit4cae4c46b10a14b194633125110bf22c77823d29 (patch)
treef61a24c206e130641af0465914db6d1fcaea7db6 /security/mdcrack
parent246d2efa62dab845aa9ed8d1b9159b49bf365b87 (diff)
downloadports-4cae4c46b10a14b194633125110bf22c77823d29.tar.gz
ports-4cae4c46b10a14b194633125110bf22c77823d29.zip
Notes
Diffstat (limited to 'security/mdcrack')
-rw-r--r--security/mdcrack/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/security/mdcrack/Makefile b/security/mdcrack/Makefile
index a7f286d1de47..646e0989bee4 100644
--- a/security/mdcrack/Makefile
+++ b/security/mdcrack/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mdcrack
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://membres.lycos.fr/mdcrack/download/
@@ -13,4 +13,16 @@ COMMENT= Bruteforce password MD5 hashes
ALL_TARGET= little
PLIST_FILES= bin/mdcrack
-.include <bsd.port.mk>
+USES= compiler:features
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 36
+post-patch:
+ @${REINPLACE_CMD} -e 's|-fforce-addr||' ${WRKSRC}/Makefile
+.endif
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.post.mk>