aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-11-07 10:32:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-11-07 10:32:38 +0000
commite4ef9f7b66f030fd2b592bb1b587d2f9a2647833 (patch)
tree4d55209f1e08f2128035a69eb067b701fb2a0ca9 /security/metasploit/Makefile
parentd446204edd25023918135eecee450f6fa901ae68 (diff)
Notes
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 9347f3a7ace7..36b44e78918a 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= metasploit
-PORTVERSION= 2.4
-PORTREVISION= 1
+PORTVERSION= 2.5
CATEGORIES= security
MASTER_SITES= http://www.metasploit.org/tools/
DISTNAME= framework-${PORTVERSION}
@@ -21,6 +20,11 @@ RUN_DEPENDS= ${SITE_PERL}/mach/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLin
NO_BUILD= yes
USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ''
+
+SCRIPTS= msfcli msfconsole msfelfscan msfencode msflogdump msfpayload msfpescan \
+ msfupdate msfweb
.include <bsd.port.pre.mk>
@@ -28,11 +32,16 @@ USE_PERL5_RUN= yes
IGNORE= This port requires perl version 5.6.0 or higher.
.endif
+post-patch:
+.for f in ${SCRIPTS}
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/${f}
+.endfor
+
do-install:
${MKDIR} ${DATADIR}
${CP} -Rp ${WRKSRC}/ ${DATADIR}
-. for i in msfcli msfconsole msfelfscan msfencode msflogdump msfpayload msfpescan msfupdate msfweb
- ${LN} -s ${DATADIR}/$i ${PREFIX}/bin
-. endfor
+.for f in ${SCRIPTS}
+ ${LN} -s ${DATADIR}/${f} ${PREFIX}/bin
+.endfor
.include <bsd.port.post.mk>