aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-14 18:25:24 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-14 18:25:24 +0000
commite0cb3d43191f76975ea1473c7545fafde20769fb (patch)
tree131680d6e7eba5fedf6d5b9fc9f4b2a7476a5a29 /security/metasploit
parentb07029fa4351fd1e43ee89fbd1c6598b631d4c44 (diff)
downloadports-e0cb3d43191f76975ea1473c7545fafde20769fb.tar.gz
ports-e0cb3d43191f76975ea1473c7545fafde20769fb.zip
Notes
Diffstat (limited to 'security/metasploit')
-rw-r--r--security/metasploit/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index c2fd40ccb632..04e662c80420 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= metasploit
DISTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://downloads.metasploit.com/data/releases/
DISTNAME= framework-${DISTVERSION}
@@ -21,11 +22,11 @@ WRKSRC= ${WRKDIR}/msf3
SCRIPTS= msfcli msfconsole msfd msfelfscan msfencode msfmachscan \
msfopcode msfpayload msfpescan msfweb
-OPTIONS= SVN "Use subversion" off \
- SVN_FBSD "Use subversion-freebsd" off
+OPTIONS= SVN "Use subversion" off
NO_BUILD= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= iconv
USE_BZIP2= yes
USE_NCURSES= yes
WITH_NCURSES_PORT= yes
@@ -38,17 +39,12 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gem:${PORTSDIR}/devel/ruby-gems
RUN_DEPENDS+= rubygem-actionpack>0:${PORTSDIR}/www/rubygem-actionpack \
rubygem-sqlite3>0:${PORTSDIR}/databases/rubygem-sqlite3 \
rubygem-activerecord>0:${PORTSDIR}/databases/rubygem-activerecord \
- rubygem-activesupport>0:${PORTSDIR}/devel/rubygem-activesupport \
- ${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
+ rubygem-activesupport>0:${PORTSDIR}/devel/rubygem-activesupport
.endif
-.if defined(WITH_SVN) || defined(WITH_SVN_FBSD)
-.if defined(WITH_SVN_FBSD)
-RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion-freebsd
-.else
+.if defined(WITH_SVN)
RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
.endif
-.endif
do-install:
${MKDIR} ${DATADIR}