aboutsummaryrefslogtreecommitdiff
path: root/security/mhash
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-02-20 11:03:42 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-02-20 11:03:42 +0000
commitba5574060ff1898d1f4b31a4b8709b4fb56a7d0c (patch)
tree88e96aa6bb22f02e575e78477e82b1d36befa037 /security/mhash
parent6f53c11721e388176a8ada20986284a5364a477f (diff)
downloadports-ba5574060ff1898d1f4b31a4b8709b4fb56a7d0c.tar.gz
ports-ba5574060ff1898d1f4b31a4b8709b4fb56a7d0c.zip
Update to 0.9.13.
In the process, fix an autoconf-2.52 bug in using $target_alias as a program prefix even if it is exactly the same as $host_alias. Also, remove the installation of the library .la file. Based on a patch by: ijliao
Notes
Notes: svn path=/head/; revision=54970
Diffstat (limited to 'security/mhash')
-rw-r--r--security/mhash/Makefile5
-rw-r--r--security/mhash/distinfo2
-rw-r--r--security/mhash/files/patch-configure10
-rw-r--r--security/mhash/files/patch-libtool16
4 files changed, 31 insertions, 2 deletions
diff --git a/security/mhash/Makefile b/security/mhash/Makefile
index 629342750f07..8d6efdf033f6 100644
--- a/security/mhash/Makefile
+++ b/security/mhash/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mhash
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.13
CATEGORIES= security
MASTER_SITES= http://mhash.sourceforge.net/dl/
@@ -18,4 +18,7 @@ CONFIGURE_ARGS+= --with-LDFLAGS="${PTHREAD_LIBS}"
MAN3= mhash.3
+post-extract:
+ ${CP} ${LOCALBASE}/bin/libtool ${WRKSRC}
+
.include <bsd.port.mk>
diff --git a/security/mhash/distinfo b/security/mhash/distinfo
index 31712904282a..1b71f0ea4274 100644
--- a/security/mhash/distinfo
+++ b/security/mhash/distinfo
@@ -1 +1 @@
-MD5 (mhash-0.8.9.tar.gz) = 9e1f965298fb769f11f3507b3676edc1
+MD5 (mhash-0.8.13.tar.gz) = 824ccfb22399ec69e5c292ad3da0339a
diff --git a/security/mhash/files/patch-configure b/security/mhash/files/patch-configure
new file mode 100644
index 000000000000..60318fb7fc26
--- /dev/null
+++ b/security/mhash/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Feb 20 12:39:08 2002
++++ configure Wed Feb 20 12:39:39 2002
+@@ -1240,6 +1240,7 @@
+ # The aliases save the names the user supplied, while $host etc.
+ # will get canonicalized.
+ test -n "$target_alias" &&
++ test "$target_alias" != "$host_alias" &&
+ test "$program_prefix$program_suffix$program_transform_name" = \
+ NONENONEs,x,x, &&
+ program_prefix=${target_alias}-
diff --git a/security/mhash/files/patch-libtool b/security/mhash/files/patch-libtool
new file mode 100644
index 000000000000..094e674c9f12
--- /dev/null
+++ b/security/mhash/files/patch-libtool
@@ -0,0 +1,16 @@
+--- libtool.orig Wed Feb 20 12:43:25 2002
++++ libtool Wed Feb 20 12:43:37 2002
+@@ -3723,11 +3723,13 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ if test "$install_ltlibs" = yes; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+ fi
+
+ # Maybe install the static library, too.