aboutsummaryrefslogtreecommitdiff
path: root/security/mhash
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-09-20 16:33:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-09-20 16:33:24 +0000
commita8530dd5743a4e74e67d539c16700a3f6e0bac5a (patch)
tree8de9fcc5108589aa61e6c71338ba76841d992bbc /security/mhash
parent7d8cb38f49ca29f6fac79256b961e4bf41b6e18b (diff)
downloadports-a8530dd5743a4e74e67d539c16700a3f6e0bac5a.tar.gz
ports-a8530dd5743a4e74e67d539c16700a3f6e0bac5a.zip
Notes
Diffstat (limited to 'security/mhash')
-rw-r--r--security/mhash/Makefile17
-rw-r--r--security/mhash/distinfo6
-rw-r--r--security/mhash/pkg-plist11
3 files changed, 18 insertions, 16 deletions
diff --git a/security/mhash/Makefile b/security/mhash/Makefile
index e3870fd85c79..973ad1c511da 100644
--- a/security/mhash/Makefile
+++ b/security/mhash/Makefile
@@ -6,29 +6,28 @@
#
PORTNAME= mhash
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.7.1
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= roam@FreeBSD.org
COMMENT= An easy-to-use library for strong hashes such as MD5 and SHA1
-INSTALLS_SHLIB= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-LDFLAGS="${PTHREAD_LIBS}" --enable-static \
--with-gnu-ld
MAN3= mhash.3
-DOCFILES= example.c md5-rfc1321.txt skid2-authentication
+PORTDOCS= example.c md5-rfc1321.txt skid2-authentication
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/security/mhash/distinfo b/security/mhash/distinfo
index 29ccb6921606..729e9d97f6e5 100644
--- a/security/mhash/distinfo
+++ b/security/mhash/distinfo
@@ -1,3 +1,3 @@
-MD5 (mhash-0.9.2.tar.gz) = bf31627548376891e4f42ace54db4c2d
-SHA256 (mhash-0.9.2.tar.gz) = 50a471c543407e44947ad74496ab78843d53db66ae06ec0f9f3cd393ca9f1917
-SIZE (mhash-0.9.2.tar.gz) = 853662
+MD5 (mhash-0.9.7.1.tar.bz2) = e2a7f6594d468c5d0edbfa788dbdca0f
+SHA256 (mhash-0.9.7.1.tar.bz2) = e9ac257ba9fd62e54011ed1282c7c1bf5fbd72bf84484ad6a293ece43f8d641c
+SIZE (mhash-0.9.7.1.tar.bz2) = 727397
diff --git a/security/mhash/pkg-plist b/security/mhash/pkg-plist
index f4908f660448..1b99733b0c53 100644
--- a/security/mhash/pkg-plist
+++ b/security/mhash/pkg-plist
@@ -1,8 +1,11 @@
include/mhash.h
+include/mutils/mglobal.h
+include/mutils/mhash.h
+include/mutils/mhash_config.h
+include/mutils/mincludes.h
+include/mutils/mtypes.h
+include/mutils/mutils.h
lib/libmhash.a
lib/libmhash.so
lib/libmhash.so.2
-%%PORTDOCS%%%%DOCSDIR%%/example.c
-%%PORTDOCS%%%%DOCSDIR%%/md5-rfc1321.txt
-%%PORTDOCS%%%%DOCSDIR%%/skid2-authentication
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/mutils