aboutsummaryrefslogtreecommitdiff
path: root/security/munge
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-15 17:55:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-15 17:55:34 +0000
commit6ecb70f552146ae393a7534eb9ef6c04a9e696fd (patch)
treec3861ef6a5dfce2da0932f6b64359be83e9ee8b8 /security/munge
parentdf0499802aa8c55c8a3d6c536a74dd5d8132cc28 (diff)
downloadports-6ecb70f552146ae393a7534eb9ef6c04a9e696fd.tar.gz
ports-6ecb70f552146ae393a7534eb9ef6c04a9e696fd.zip
Notes
Diffstat (limited to 'security/munge')
-rw-r--r--security/munge/Makefile28
-rw-r--r--security/munge/distinfo4
-rw-r--r--security/munge/files/patch-src-Makefile.in10
-rw-r--r--security/munge/files/patch-src-etc-Makefile.in28
-rw-r--r--security/munge/files/patch-src-munged-xgetgrent.c11
-rw-r--r--security/munge/pkg-descr2
-rw-r--r--security/munge/pkg-plist27
7 files changed, 40 insertions, 70 deletions
diff --git a/security/munge/Makefile b/security/munge/Makefile
index ce96b25668cf..c86718d72c82 100644
--- a/security/munge/Makefile
+++ b/security/munge/Makefile
@@ -2,40 +2,20 @@
# $FreeBSD$
PORTNAME= munge
-PORTVERSION= 0.5.10
-PORTREVISION= 1
+PORTVERSION= 0.5.11
CATEGORIES= security
MASTER_SITES= GOOGLE_CODE
MAINTAINER= 5u623l20@gmail.com
COMMENT= Authentication service for creating and validating credentials
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= perl5
USE_LDCONFIG= yes
USE_RC_SUBR= munged
-MAN1= unmunge.1 \
- munge.1 \
- remunge.1
-MAN3= munge.3 \
- munge_ctx_copy.3 \
- munge_ctx_get.3 \
- munge_ctx.3 \
- munge_enum_int_to_str.3 \
- munge_enum_is_valid.3 \
- munge_enum_str_to_int.3 \
- munge_enum.3
-MAN7= munge.7
-MAN8= munged.8
-MLINKS= munge.3 munge_strerror.3 \
- munge.3 munge_encode.3 \
- munge.3 munge_decode.3 \
- munge_ctx.3 munge_ctx_create.3 \
- munge_ctx.3 munge_ctx_destroy.3 \
- munge_ctx.3 munge_ctx_set.3 \
- munge_ctx.3 munge_ctx_strerror.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/munge/distinfo b/security/munge/distinfo
index 1bf23891b683..ad8a656a5403 100644
--- a/security/munge/distinfo
+++ b/security/munge/distinfo
@@ -1,2 +1,2 @@
-SHA256 (munge-0.5.10.tar.bz2) = 00e0125c2895877b555872647b0a98d13838a54acda78614bb6c6e70daadabc6
-SIZE (munge-0.5.10.tar.bz2) = 424285
+SHA256 (munge-0.5.11.tar.bz2) = 8e075614f81cb0a6df21a0aafdc825498611a04429d0876f074fc828739351a5
+SIZE (munge-0.5.11.tar.bz2) = 423232
diff --git a/security/munge/files/patch-src-Makefile.in b/security/munge/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..7d5cd280dcdd
--- /dev/null
+++ b/security/munge/files/patch-src-Makefile.in
@@ -0,0 +1,10 @@
+--- src/Makefile.in.orig 2013-11-15 02:53:07.000000000 +0600
++++ src/Makefile.in 2013-11-15 02:53:15.000000000 +0600
+@@ -284,7 +284,6 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = \
+- etc \
+ libcommon \
+ libmissing \
+ libmunge \
diff --git a/security/munge/files/patch-src-etc-Makefile.in b/security/munge/files/patch-src-etc-Makefile.in
deleted file mode 100644
index 007259942f9f..000000000000
--- a/security/munge/files/patch-src-etc-Makefile.in
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/etc/Makefile.in.orig 2012-03-24 23:11:13.000000000 +0600
-+++ src/etc/Makefile.in 2012-03-24 23:14:23.000000000 +0600
-@@ -431,24 +431,7 @@
- -rm -f *~ \#* .\#* cscope*.out core core.* tags TAGS
-
- install-data-local:
-- expr "`id`" : 'uid=0(' >/dev/null && OWNER="-o daemon" || OWNER=""; \
-- $(INSTALL) -m 0755 -d "$(DESTDIR)$(sysconfdir)/init.d"; \
-- new=""; test ! -f "$(DESTDIR)$(sysconfdir)/init.d/munge" \
-- || cmp "$(builddir)/munge.init" \
-- "$(DESTDIR)$(sysconfdir)/init.d/munge" \
-- 1>/dev/null 2>&1 || new=".new"; \
-- $(INSTALL) -m 0755 "$(builddir)/munge.init" \
-- "$(DESTDIR)$(sysconfdir)/init.d/munge$${new}"; \
-- test -d "/etc/sysconfig" && d="sysconfig" || d="default"; \
-- new=""; test ! -f "$(DESTDIR)$(sysconfdir)/$${d}/munge" \
-- || cmp "$(srcdir)/munge.sysconfig" \
-- "$(DESTDIR)$(sysconfdir)/$${d}/munge" \
-- 1>/dev/null 2>&1 || new=".new"; \
-- $(INSTALL) -m 0755 -d "$(DESTDIR)$(sysconfdir)/$${d}"; \
-- $(INSTALL) -m 0644 "$(srcdir)/munge.sysconfig" \
-- "$(DESTDIR)$(sysconfdir)/$${d}/munge$${new}"; \
-- $(INSTALL) $${OWNER} -m 0700 -d \
-- "$(DESTDIR)$(sysconfdir)/munge"; \
-+ expr "`id`" : 'uid=0(' >/dev/null && OWNER="-o root" || OWNER=""; \
- $(INSTALL) -m 0711 -d "$(DESTDIR)$(localstatedir)/lib"; \
- $(INSTALL) $${OWNER} -m 0711 -d \
- "$(DESTDIR)$(localstatedir)/lib/munge"; \
diff --git a/security/munge/files/patch-src-munged-xgetgrent.c b/security/munge/files/patch-src-munged-xgetgrent.c
deleted file mode 100644
index f0c10632a828..000000000000
--- a/security/munge/files/patch-src-munged-xgetgrent.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/munged/xgetgrent.c.orig 2012-10-18 16:42:46.000000000 +0200
-+++ src/munged/xgetgrent.c 2012-10-18 16:43:17.000000000 +0200
-@@ -194,7 +194,7 @@
-
- #if HAVE_GETGRENT_R_GNU
- rv = getgrent_r (gr, buf, buflen, &gr_ptr);
-- if (rv == ENOENT) {
-+ if (((rv == ENOENT) || (rv == 0)) && (gr_ptr == NULL)) {
- got_eof = 1;
- }
- else if (rv != 0) {
diff --git a/security/munge/pkg-descr b/security/munge/pkg-descr
index 49f414001165..4e6b50413b01 100644
--- a/security/munge/pkg-descr
+++ b/security/munge/pkg-descr
@@ -7,4 +7,4 @@ cryptographic key. Clients within this security realm can create and validate
credentials without the use of root privileges, reserved ports, or
platform-specific methods.
-WWW: http://code.google.com/p/munge/
+WWW: http://code.google.com/p/munge/
diff --git a/security/munge/pkg-plist b/security/munge/pkg-plist
index babf9470da74..e0ddab9d7c9f 100644
--- a/security/munge/pkg-plist
+++ b/security/munge/pkg-plist
@@ -8,7 +8,26 @@ lib/libmunge.so.2
lib/libmunge.a
lib/libmunge.so
sbin/munged
-@cwd /
-@exec rm /var/run/${PORTNAME}
-@exec rm /var/log/${PORTNAME}
-@exec rm /var/lib/${PORTNAME}
+man/man1/munge.1.gz
+man/man1/remunge.1.gz
+man/man1/unmunge.1.gz
+man/man3/munge.3.gz
+man/man3/munge_ctx.3.gz
+man/man3/munge_ctx_copy.3.gz
+man/man3/munge_ctx_create.3.gz
+man/man3/munge_ctx_destroy.3.gz
+man/man3/munge_ctx_get.3.gz
+man/man3/munge_ctx_set.3.gz
+man/man3/munge_ctx_strerror.3.gz
+man/man3/munge_decode.3.gz
+man/man3/munge_encode.3.gz
+man/man3/munge_enum.3.gz
+man/man3/munge_enum_int_to_str.3.gz
+man/man3/munge_enum_is_valid.3.gz
+man/man3/munge_enum_str_to_int.3.gz
+man/man3/munge_strerror.3.gz
+man/man7/munge.7.gz
+man/man8/munged.8.gz
+@unexec rm %D/var/run/munge 2>&1 >/dev/null || true
+@unexec rm %D/var/log/munge 2>&1 >/dev/null || true
+@unexec rm %D/var/lib/munge 2>&1 >/dev/null || true