aboutsummaryrefslogtreecommitdiff
path: root/security/nacl
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2011-10-04 02:36:58 +0000
committerDavid Thiel <lx@FreeBSD.org>2011-10-04 02:36:58 +0000
commit5e7030c41d21d402149913cb4bfd5e3718e46058 (patch)
tree696d8be9844e1eb883ef7c9603b359d4b6fc146c /security/nacl
parent0a27148e1a94552a7d16637bf6a3a820d876b563 (diff)
downloadports-5e7030c41d21d402149913cb4bfd5e3718e46058.tar.gz
ports-5e7030c41d21d402149913cb4bfd5e3718e46058.zip
Notes
Diffstat (limited to 'security/nacl')
-rw-r--r--security/nacl/Makefile37
-rw-r--r--security/nacl/distinfo2
-rw-r--r--security/nacl/pkg-descr10
-rw-r--r--security/nacl/pkg-plist46
4 files changed, 95 insertions, 0 deletions
diff --git a/security/nacl/Makefile b/security/nacl/Makefile
new file mode 100644
index 000000000000..7b244996ef52
--- /dev/null
+++ b/security/nacl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: nacl
+# Date created: 2011-10-03
+# Whom: David Thiel <lx@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nacl
+PORTVERSION= 20110221
+CATEGORIES= security
+MASTER_SITES= http://hyperelliptic.org/nacl/
+
+MAINTAINER= lx@FreeBSD.org
+COMMENT= High speed cryptography library
+
+ALL_TARGET= do
+USE_BZIP2= YES
+MAKE_JOBS_UNSAFE= YES
+
+.include <bsd.port.pre.mk>
+
+HOSTNAME_CMD?= /bin/hostname
+
+do-build:
+ cd ${WRKSRC} && ./do
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/build/`${HOSTNAME_CMD} -s`/bin/nacl-sha256 \
+ ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/build/`${HOSTNAME_CMD} -s`/bin/nacl-sha512 \
+ ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/build/`${HOSTNAME_CMD} -s`/lib/${ARCH}/* \
+ ${PREFIX}/lib
+ @${INSTALL_DATA} ${WRKSRC}/build/`${HOSTNAME_CMD} -s`/include/${ARCH}/* \
+ ${PREFIX}/include
+
+.include <bsd.port.post.mk>
diff --git a/security/nacl/distinfo b/security/nacl/distinfo
new file mode 100644
index 000000000000..49154ad59ba8
--- /dev/null
+++ b/security/nacl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nacl-20110221.tar.bz2) = 4f277f89735c8b0b8a6bbd043b3efb3fa1cc68a9a5da6a076507d067fc3b3bf8
+SIZE (nacl-20110221.tar.bz2) = 163415
diff --git a/security/nacl/pkg-descr b/security/nacl/pkg-descr
new file mode 100644
index 000000000000..00bf94b2643d
--- /dev/null
+++ b/security/nacl/pkg-descr
@@ -0,0 +1,10 @@
+NaCl (pronounced "salt") is a new easy-to-use high-speed software
+library for network communication, encryption, decryption, signatures,
+etc. NaCl's goal is to provide all of the core operations needed to
+build higher-level cryptographic tools.
+
+Of course, other libraries already exist for these core operations.
+NaCl advances the state of the art by improving security, by improving
+usability, and by improving speed.
+
+WWW: http://nacl.cace-project.eu/
diff --git a/security/nacl/pkg-plist b/security/nacl/pkg-plist
new file mode 100644
index 000000000000..65bf7d204afe
--- /dev/null
+++ b/security/nacl/pkg-plist
@@ -0,0 +1,46 @@
+@comment $FreeBSD$
+bin/nacl-sha256
+bin/nacl-sha512
+include/cpucycles.h
+include/crypto_auth.h
+include/crypto_auth_hmacsha256.h
+include/crypto_auth_hmacsha512256.h
+include/crypto_box.h
+include/crypto_box_curve25519xsalsa20poly1305.h
+include/crypto_core_hsalsa20.h
+include/crypto_core_salsa20.h
+include/crypto_core_salsa2012.h
+include/crypto_core_salsa208.h
+include/crypto_hash.h
+include/crypto_hash_sha256.h
+include/crypto_hash_sha512.h
+include/crypto_hashblocks.h
+include/crypto_hashblocks_sha256.h
+include/crypto_hashblocks_sha512.h
+include/crypto_int16.h
+include/crypto_int32.h
+include/crypto_int64.h
+include/crypto_int8.h
+include/crypto_onetimeauth.h
+include/crypto_onetimeauth_poly1305.h
+include/crypto_scalarmult_curve25519.h
+include/crypto_secretbox.h
+include/crypto_secretbox_xsalsa20poly1305.h
+include/crypto_sign.h
+include/crypto_sign_edwards25519sha512batch.h
+include/crypto_stream.h
+include/crypto_stream_aes128ctr.h
+include/crypto_stream_salsa20.h
+include/crypto_stream_salsa2012.h
+include/crypto_stream_salsa208.h
+include/crypto_stream_xsalsa20.h
+include/crypto_uint16.h
+include/crypto_uint32.h
+include/crypto_uint64.h
+include/crypto_uint8.h
+include/crypto_verify_16.h
+include/crypto_verify_32.h
+include/randombytes.h
+lib/cpucycles.o
+lib/libnacl.a
+lib/randombytes.o