aboutsummaryrefslogtreecommitdiff
path: root/security/ncrypt/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-06 12:49:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-06 12:49:38 +0000
commitf9f47c70793b95fd5d636924afeb29ddfcc14db8 (patch)
treed86ed051e60063bb104576ae3bfa7e67295c3e47 /security/ncrypt/Makefile
parent7ac08aaf0e1c81759c48150b3b005f9ac91ee8cb (diff)
downloadports-f9f47c70793b95fd5d636924afeb29ddfcc14db8.tar.gz
ports-f9f47c70793b95fd5d636924afeb29ddfcc14db8.zip
Notes
Diffstat (limited to 'security/ncrypt/Makefile')
-rw-r--r--security/ncrypt/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/security/ncrypt/Makefile b/security/ncrypt/Makefile
new file mode 100644
index 000000000000..2d7d0a8ff59c
--- /dev/null
+++ b/security/ncrypt/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: ncrypt
+# Date created: 30 Aug 2005
+# Whom: Frank Laszlo <laszlof@vonostingroup.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncrypt
+PORTVERSION= 0.7.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= laszlof@vonostingroup.com
+COMMENT= Advanced AES file encryption tool
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_AUTOMAKE_VER= 19
+USE_ACLOCAL_VER= 19
+USE_AUTOCONF_VER= 259
+
+PLIST_FILES= bin/ncrypt bin/nrm
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ @${REINPLACE_CMD} -E 's,^(CC|CFLAGS) =,\1 \?=,g' \
+ ${WRKSRC}/Makefile
+.if (${OSVERSION} < 500000)
+ @${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,g' \
+ ${WRKSRC}/standard.h
+ @${REINPLACE_CMD} -e 's,O_SYNC,O_FSYNC,g' \
+ ${WRKSRC}/wipe_file.c
+.endif
+.if (${OSVERSION} < 501000)
+ @${REINPLACE_CMD} -e 's,ifndef WIN32,if (!defined(__FreeBSD__)),g' \
+ ${WRKSRC}/ncrypt.c
+.endif
+
+.include <bsd.port.post.mk>