aboutsummaryrefslogtreecommitdiff
path: root/security/ncrypt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-21 17:14:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-21 17:14:49 +0000
commitc8ec1e96354c78a25fc90f3c2d10d00a466892ed (patch)
treee6926ca46444863d802d99a35ff610dadcf6b9ec /security/ncrypt
parente9baa3931b7676cf14a0982ec224c34aeb651c78 (diff)
downloadports-c8ec1e96354c78a25fc90f3c2d10d00a466892ed.tar.gz
ports-c8ec1e96354c78a25fc90f3c2d10d00a466892ed.zip
Notes
Diffstat (limited to 'security/ncrypt')
-rw-r--r--security/ncrypt/Makefile16
-rw-r--r--security/ncrypt/distinfo4
-rw-r--r--security/ncrypt/files/patch-getopt.c10
-rw-r--r--security/ncrypt/files/patch-ncrypt.c4
-rw-r--r--security/ncrypt/pkg-descr21
5 files changed, 26 insertions, 29 deletions
diff --git a/security/ncrypt/Makefile b/security/ncrypt/Makefile
index 0f774c495add..e3a3dba31a9d 100644
--- a/security/ncrypt/Makefile
+++ b/security/ncrypt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ncrypt
-PORTVERSION= 0.7.0
-PORTREVISION= 3
+PORTVERSION= 0.8.0
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION}
@@ -11,14 +10,21 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Advanced AES file encryption tool
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+USES= autoreconf tar:tgz
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= tar:tgz
PLIST_FILES= bin/ncrypt bin/nrm
+pre-patch:
+ @${RM} ${WRKSRC}/*.m4
+
post-patch:
- @${REINPLACE_CMD} -E 's,^(CC|CFLAGS) =,\1 \?=,g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's| getopt.c getopt1.c||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e \
+ 's|-O0|| ; \
+ s|"\($$CCOPTS\)"|"\1 $$CFLAGS"|' ${WRKSRC}/configure.ac
.include <bsd.port.mk>
diff --git a/security/ncrypt/distinfo b/security/ncrypt/distinfo
index 72cafe3d8d18..0171650f5fac 100644
--- a/security/ncrypt/distinfo
+++ b/security/ncrypt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ncrypt-0.7.0.tgz) = 3b6182775bc82a889140b4847b5d30e561093c6ab772440323e4856b157ccc87
-SIZE (ncrypt-0.7.0.tgz) = 172283
+SHA256 (ncrypt-0.8.0.tgz) = 771267940226bb570dea2a5b2300e542a78285fa38c45d6f74903931c15633ab
+SIZE (ncrypt-0.8.0.tgz) = 785474
diff --git a/security/ncrypt/files/patch-getopt.c b/security/ncrypt/files/patch-getopt.c
deleted file mode 100644
index 493e986a5444..000000000000
--- a/security/ncrypt/files/patch-getopt.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- getopt.c.orig Tue Aug 30 11:15:09 2005
-+++ getopt.c Tue Aug 30 11:15:23 2005
-@@ -46,6 +46,7 @@
- #endif
-
- #include <stdio.h>
-+#include <string.h>
-
- /* Comment out all this code if we are using the GNU C Library, and are not
- actually compiling the library itself. This code is part of the GNU C
diff --git a/security/ncrypt/files/patch-ncrypt.c b/security/ncrypt/files/patch-ncrypt.c
index 77ac32bcc166..cafe1e442698 100644
--- a/security/ncrypt/files/patch-ncrypt.c
+++ b/security/ncrypt/files/patch-ncrypt.c
@@ -1,5 +1,5 @@
---- ncrypt.c.orig Tue Aug 30 10:57:04 2005
-+++ ncrypt.c Tue Aug 30 10:57:30 2005
+--- ncrypt.c.orig 2015-05-11 20:36:52 UTC
++++ ncrypt.c
@@ -17,6 +17,7 @@
#include <sys/stat.h>
#include <sys/mman.h>
diff --git a/security/ncrypt/pkg-descr b/security/ncrypt/pkg-descr
index 3061f06e2710..3c086e4f8c5a 100644
--- a/security/ncrypt/pkg-descr
+++ b/security/ncrypt/pkg-descr
@@ -1,12 +1,13 @@
-NCrypt is intended to give you security in an insecure environment. If you are
-wanting to encrypt files (particularly on a multi-user system where you don't
-have root), wishing to hide your activites from prying eyes, and want to "cover
-your tracks", then NCrypt is for you. It is a symmetrical file
-encryptor/decryptor that gives you the choice of the top three candidates for
-AES as the encryption algorithm (Rijndael, Serpent, Twofish), tries to minimize
-exposure of the plaintext password in memory, and can safely erase the plaintext
-version from the hard drive. It compiles without any extra crypto libraries,
-making it ideal for systems where you just have a compiler and basic libraries
-(such as an ISP's shell server).
+NCrypt is intended to give you security in an insecure environment.
+If you are wanting to encrypt files (particularly on a multi-user
+system where you don't have root), wishing to hide your activites
+from prying eyes, and want to "cover your tracks", then NCrypt is
+for you. It is a symmetrical file encryptor/decryptor that gives
+you the choice of the top three candidates for AES as the encryption
+algorithm (Rijndael, Serpent, Twofish), tries to minimize exposure
+of the plaintext password in memory, and can safely erase the
+plaintext version from the hard drive. It compiles without any extra
+crypto libraries, making it ideal for systems where you just have
+a compiler and basic libraries (such as an ISP's shell server).
WWW: http://ncrypt.sourceforge.net/