aboutsummaryrefslogtreecommitdiff
path: root/security/ncrypt
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-06 12:49:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-06 12:49:38 +0000
commitf9f47c70793b95fd5d636924afeb29ddfcc14db8 (patch)
treed86ed051e60063bb104576ae3bfa7e67295c3e47 /security/ncrypt
parent7ac08aaf0e1c81759c48150b3b005f9ac91ee8cb (diff)
downloadports-f9f47c70793b95fd5d636924afeb29ddfcc14db8.tar.gz
ports-f9f47c70793b95fd5d636924afeb29ddfcc14db8.zip
Notes
Diffstat (limited to 'security/ncrypt')
-rw-r--r--security/ncrypt/Makefile42
-rw-r--r--security/ncrypt/distinfo2
-rw-r--r--security/ncrypt/files/patch-getopt.c10
-rw-r--r--security/ncrypt/files/patch-ncrypt.c10
-rw-r--r--security/ncrypt/pkg-descr7
5 files changed, 71 insertions, 0 deletions
diff --git a/security/ncrypt/Makefile b/security/ncrypt/Makefile
new file mode 100644
index 000000000000..2d7d0a8ff59c
--- /dev/null
+++ b/security/ncrypt/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: ncrypt
+# Date created: 30 Aug 2005
+# Whom: Frank Laszlo <laszlof@vonostingroup.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncrypt
+PORTVERSION= 0.7.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= laszlof@vonostingroup.com
+COMMENT= Advanced AES file encryption tool
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_AUTOMAKE_VER= 19
+USE_ACLOCAL_VER= 19
+USE_AUTOCONF_VER= 259
+
+PLIST_FILES= bin/ncrypt bin/nrm
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ @${REINPLACE_CMD} -E 's,^(CC|CFLAGS) =,\1 \?=,g' \
+ ${WRKSRC}/Makefile
+.if (${OSVERSION} < 500000)
+ @${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,g' \
+ ${WRKSRC}/standard.h
+ @${REINPLACE_CMD} -e 's,O_SYNC,O_FSYNC,g' \
+ ${WRKSRC}/wipe_file.c
+.endif
+.if (${OSVERSION} < 501000)
+ @${REINPLACE_CMD} -e 's,ifndef WIN32,if (!defined(__FreeBSD__)),g' \
+ ${WRKSRC}/ncrypt.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/ncrypt/distinfo b/security/ncrypt/distinfo
new file mode 100644
index 000000000000..3afee4e47432
--- /dev/null
+++ b/security/ncrypt/distinfo
@@ -0,0 +1,2 @@
+MD5 (ncrypt-0.7.0.tgz) = 423d6d0fb607d63dce788f11f74cb59f
+SIZE (ncrypt-0.7.0.tgz) = 172283
diff --git a/security/ncrypt/files/patch-getopt.c b/security/ncrypt/files/patch-getopt.c
new file mode 100644
index 000000000000..493e986a5444
--- /dev/null
+++ b/security/ncrypt/files/patch-getopt.c
@@ -0,0 +1,10 @@
+--- getopt.c.orig Tue Aug 30 11:15:09 2005
++++ getopt.c Tue Aug 30 11:15:23 2005
+@@ -46,6 +46,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C
diff --git a/security/ncrypt/files/patch-ncrypt.c b/security/ncrypt/files/patch-ncrypt.c
new file mode 100644
index 000000000000..77ac32bcc166
--- /dev/null
+++ b/security/ncrypt/files/patch-ncrypt.c
@@ -0,0 +1,10 @@
+--- ncrypt.c.orig Tue Aug 30 10:57:04 2005
++++ ncrypt.c Tue Aug 30 10:57:30 2005
+@@ -17,6 +17,7 @@
+ #include <sys/stat.h>
+ #include <sys/mman.h>
+ #include <unistd.h>
++#include <getopt.h>
+ #include "ncrypt.h"
+ #include "config.h"
+ #include "encrypt_file.h"
diff --git a/security/ncrypt/pkg-descr b/security/ncrypt/pkg-descr
new file mode 100644
index 000000000000..319fdc0935be
--- /dev/null
+++ b/security/ncrypt/pkg-descr
@@ -0,0 +1,7 @@
+NCrypt is intended to give you security in an insecure environment.
+If you are wanting to encrypt files (particularly on a multi-user
+system where you don't have root), wishing to hide your activites
+from prying eyes, and want to "cover your tracks", then NCrypt is
+for you.
+
+WWW: http://ncrypt.sourceforge.net/