aboutsummaryrefslogtreecommitdiff
path: root/security/nessus-libnasl
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-10-25 12:00:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-10-25 12:00:27 +0000
commit2cf11697f1f887898d44af4fba3eb18ad9ec8802 (patch)
treeb990e95f0242f7a196eaa0959680fcd9ece5183b /security/nessus-libnasl
parent263a93f75fb030554e850ef4c14e3e5bc38c95c1 (diff)
downloadports-2cf11697f1f887898d44af4fba3eb18ad9ec8802.tar.gz
ports-2cf11697f1f887898d44af4fba3eb18ad9ec8802.zip
Notes
Diffstat (limited to 'security/nessus-libnasl')
-rw-r--r--security/nessus-libnasl/Makefile5
-rw-r--r--security/nessus-libnasl/files/patch-libtool8
-rw-r--r--security/nessus-libnasl/files/patch-nomd262
-rw-r--r--security/nessus-libnasl/pkg-plist2
4 files changed, 72 insertions, 5 deletions
diff --git a/security/nessus-libnasl/Makefile b/security/nessus-libnasl/Makefile
index dd2ec2af7f4e..ccab3da32772 100644
--- a/security/nessus-libnasl/Makefile
+++ b/security/nessus-libnasl/Makefile
@@ -15,9 +15,9 @@ DISTNAME= libnasl-${PORTVERSION}
MAINTAINER= udo.schweigert@siemens.com
COMMENT= Nessus Attack Scripting Language
-BROKEN= Does not build
+LICENSE= GPLv2
-LIB_DEPENDS= nessus.4:${PORTSDIR}/security/nessus-libraries
+LIB_DEPENDS= libnessus.so:${PORTSDIR}/security/nessus-libraries
DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/libnasl
@@ -29,5 +29,4 @@ USE_LDCONFIG= YES
MAN1= nasl.1 nasl-config.1
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/nessus-libnasl/files/patch-libtool b/security/nessus-libnasl/files/patch-libtool
index 1e190cc05a32..bf833f83d89c 100644
--- a/security/nessus-libnasl/files/patch-libtool
+++ b/security/nessus-libnasl/files/patch-libtool
@@ -1,6 +1,6 @@
--- nasl/Makefile.orig 2005-02-10 17:03:51.000000000 +0100
+++ nasl/Makefile 2012-01-29 10:29:13.000000000 +0100
-@@ -88,7 +88,8 @@
+@@ -88,10 +88,11 @@
nasl_server.c \
nasl_debug.c
@@ -9,7 +9,11 @@
+LINK = $(LIBTOOL) --mode link $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
all : cflags libnasl.la nasl
- .c.o:
+-.c.o:
++.c.o: cflags
+ $(COMPILE) -c $<
+ cflags :
+ @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
@@ -101,7 +102,7 @@
$(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
diff --git a/security/nessus-libnasl/files/patch-nomd2 b/security/nessus-libnasl/files/patch-nomd2
new file mode 100644
index 000000000000..7897538a5f1f
--- /dev/null
+++ b/security/nessus-libnasl/files/patch-nomd2
@@ -0,0 +1,62 @@
+--- nasl/nasl_crypto.c.orig 2005-07-07 08:14:26.000000000 +0800
++++ nasl/nasl_crypto.c 2013-05-21 18:09:58.000000000 +0800
+@@ -22,7 +22,9 @@
+ */
+ #include <includes.h>
+ #ifdef HAVE_SSL
++#ifdef HAVE_OPENSSL_MD2_H
+ #include <openssl/md2.h>
++#endif
+ #include <openssl/md4.h>
+ #include <openssl/md5.h>
+ #include <openssl/ripemd.h>
+@@ -45,6 +47,7 @@
+
+
+ /*-------------------[ Std. HASH ]-------------------------------------*/
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_md2(lex_ctxt * lexic)
+ {
+ char * data = get_str_var_by_num(lexic, 0);
+@@ -63,6 +66,7 @@
+ retc->size = MD2_DIGEST_LENGTH;
+ return retc;
+ }
++#endif
+
+ tree_cell * nasl_md4(lex_ctxt * lexic)
+ {
+@@ -192,11 +196,12 @@
+ return retc;
+ }
+
+-
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_hmac_md2(lex_ctxt * lexic)
+ {
+ return nasl_hmac(lexic, EVP_md2());
+ }
++#endif
+
+
+ tree_cell * nasl_hmac_md5(lex_ctxt * lexic)
+--- nasl/nasl_crypto.h.orig 2005-02-11 00:03:52.000000000 +0800
++++ nasl/nasl_crypto.h 2013-05-21 18:11:23.000000000 +0800
+@@ -2,13 +2,17 @@
+ #define NASL_CRYPTO_H
+
+ #ifdef HAVE_SSL
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_md2(lex_ctxt *);
++#endif
+ tree_cell * nasl_md4(lex_ctxt *);
+ tree_cell * nasl_md5(lex_ctxt *);
+ tree_cell * nasl_sha(lex_ctxt *);
+ tree_cell * nasl_sha1(lex_ctxt *);
+ tree_cell * nasl_ripemd160(lex_ctxt *);
++#ifdef HAVE_OPENSSL_MD2_H
+ tree_cell * nasl_hmac_md2(lex_ctxt * );
++#endif
+ tree_cell * nasl_hmac_md5(lex_ctxt * );
+ tree_cell * nasl_hmac_sha(lex_ctxt *);
+ tree_cell * nasl_hmac_sha1(lex_ctxt * );
diff --git a/security/nessus-libnasl/pkg-plist b/security/nessus-libnasl/pkg-plist
index 10ccab19c3c0..d2bbb33a170d 100644
--- a/security/nessus-libnasl/pkg-plist
+++ b/security/nessus-libnasl/pkg-plist
@@ -5,6 +5,8 @@ lib/libnasl.a
lib/libnasl.la
lib/libnasl.so
lib/libnasl.so.4
+man/man1/nasl.1.gz
+man/man1/nasl-config.1.gz
var/nessus/nessus_org.pem
@dirrmtry var/nessus
@dirrmtry var