aboutsummaryrefslogtreecommitdiff
path: root/security/netpgp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-15 21:46:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-15 21:46:41 +0000
commitca2be65696241dec10910f527334d26eb7744c29 (patch)
treed02b8e244dbad7086b685ca5eed02e8bdfc380a1 /security/netpgp/Makefile
parent0a3a673ee794b18568c2999d11ac41e930a1fe2a (diff)
downloadports-ca2be65696241dec10910f527334d26eb7744c29.tar.gz
ports-ca2be65696241dec10910f527334d26eb7744c29.zip
Notes
Diffstat (limited to 'security/netpgp/Makefile')
-rw-r--r--security/netpgp/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/netpgp/Makefile b/security/netpgp/Makefile
new file mode 100644
index 000000000000..02eded378e26
--- /dev/null
+++ b/security/netpgp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: netpgp
+# Date created: 2009-05-27
+# Whom: bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netpgp
+PORTVERSION= 20090525
+CATEGORIES= security
+MASTER_SITES= NETBSD/LOCAL_PORTS
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= PGP signing, verification, encryption and decryption program
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+CFLAGS+= -DOPENSSL_NO_IDEA
+
+MAN1+= netpgp.1
+MAN3+= libnetpgp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
+
+.include <bsd.port.post.mk>