aboutsummaryrefslogtreecommitdiff
path: root/security/netpgp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-15 21:46:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-15 21:46:41 +0000
commitca2be65696241dec10910f527334d26eb7744c29 (patch)
treed02b8e244dbad7086b685ca5eed02e8bdfc380a1 /security/netpgp
parent0a3a673ee794b18568c2999d11ac41e930a1fe2a (diff)
downloadports-ca2be65696241dec10910f527334d26eb7744c29.tar.gz
ports-ca2be65696241dec10910f527334d26eb7744c29.zip
Notes
Diffstat (limited to 'security/netpgp')
-rw-r--r--security/netpgp/Makefile30
-rw-r--r--security/netpgp/distinfo3
-rw-r--r--security/netpgp/pkg-descr18
-rw-r--r--security/netpgp/pkg-plist7
4 files changed, 58 insertions, 0 deletions
diff --git a/security/netpgp/Makefile b/security/netpgp/Makefile
new file mode 100644
index 000000000000..02eded378e26
--- /dev/null
+++ b/security/netpgp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: netpgp
+# Date created: 2009-05-27
+# Whom: bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netpgp
+PORTVERSION= 20090525
+CATEGORIES= security
+MASTER_SITES= NETBSD/LOCAL_PORTS
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= PGP signing, verification, encryption and decryption program
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+CFLAGS+= -DOPENSSL_NO_IDEA
+
+MAN1+= netpgp.1
+MAN3+= libnetpgp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/netpgp/distinfo b/security/netpgp/distinfo
new file mode 100644
index 000000000000..49451d192e4b
--- /dev/null
+++ b/security/netpgp/distinfo
@@ -0,0 +1,3 @@
+MD5 (netpgp-20090525.tar.gz) = 2b097a919112e0f4ff064e52daca0632
+SHA256 (netpgp-20090525.tar.gz) = 6a2b7206c1013054a2290ec1ecf4b9804ebb9fb4376b61a5750b84c88a79e5d8
+SIZE (netpgp-20090525.tar.gz) = 1103952
diff --git a/security/netpgp/pkg-descr b/security/netpgp/pkg-descr
new file mode 100644
index 000000000000..c8d3f6f7bfda
--- /dev/null
+++ b/security/netpgp/pkg-descr
@@ -0,0 +1,18 @@
+The netpgp command can digitally sign files and verify that the
+signatures attached to files were signed by a given user identifier.
+netpgp can also encrypt files using the public or private keys of
+users and, in the same manner, decrypt files which were encrypted.
+
+The netpgp utility can also be used to generate a new key-pair for a
+user. This key is in two parts, the public key (which can be used by
+other people) and a private key.
+
+In addition to these primary uses, the third way of using netpgp is to
+maintain keyrings. Keyrings are collections of public keys belonging
+to other users. By using other means of identification, it is
+possible to establish the bona fides of other users. Once trust has
+been established, the public key of the other user will be signed.
+The other user's public key can be added to our keyring. The other
+user will add our public key to their keyring.
+
+WWW: http://www.NetBSD.org/
diff --git a/security/netpgp/pkg-plist b/security/netpgp/pkg-plist
new file mode 100644
index 000000000000..c2679b42da38
--- /dev/null
+++ b/security/netpgp/pkg-plist
@@ -0,0 +1,7 @@
+bin/netpgp
+include/netpgp.h
+lib/libnetpgp.a
+lib/libnetpgp.la
+lib/libnetpgp.so
+lib/libnetpgp.so.1
+lib/libnetpgp.so.1.0.0