aboutsummaryrefslogtreecommitdiff
path: root/security/nettle
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2016-01-23 21:13:46 +0000
committerJohan van Selst <johans@FreeBSD.org>2016-01-23 21:13:46 +0000
commit61eb9ad3a2ef2614e59cdc813559f76f208b3b6c (patch)
tree7052886e85b9ea77b33d50074a9e52b82cbbccc7 /security/nettle
parent0613a2fca3ade995a86cbc9a80643e0c9429e4b1 (diff)
downloadports-61eb9ad3a2ef2614e59cdc813559f76f208b3b6c.tar.gz
ports-61eb9ad3a2ef2614e59cdc813559f76f208b3b6c.zip
Update to Nettle 3.1.1
Note: Nettle 3 is not fully backwards compatible
Notes
Notes: svn path=/head/; revision=407057
Diffstat (limited to 'security/nettle')
-rw-r--r--security/nettle/Makefile9
-rw-r--r--security/nettle/distinfo4
-rw-r--r--security/nettle/pkg-plist21
3 files changed, 23 insertions, 11 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 7e13c972811c..eee22d45d940 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nettle
-PORTVERSION= 2.7.1
+PORTVERSION= 3.1.1
CATEGORIES= security
MASTER_SITES= GNU \
http://www.lysator.liu.se/~nisse/archive/:liu \
@@ -11,8 +11,8 @@ MASTER_SITES= GNU \
MAINTAINER= johans@FreeBSD.org
COMMENT= Low-level cryptographic library
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+LICENSE= LGPL3 GPLv2+
+LICENSE_COMB= multi
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
@@ -39,6 +39,9 @@ OPTIONS_DEFINE= DOCS EXAMPLES
CONFIGURE_ENV+= CCPIC=-fPIC
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} \
diff --git a/security/nettle/distinfo b/security/nettle/distinfo
index e3f655b2247c..012f70b0557a 100644
--- a/security/nettle/distinfo
+++ b/security/nettle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nettle-2.7.1.tar.gz) = bc71ebd43435537d767799e414fce88e521b7278d48c860651216e1fc6555b40
-SIZE (nettle-2.7.1.tar.gz) = 1558863
+SHA256 (nettle-3.1.1.tar.gz) = 5fd4d25d64d8ddcb85d0d897572af73b05b4d163c6cc49438a5bfbb8ff293d4c
+SIZE (nettle-3.1.1.tar.gz) = 1851876
diff --git a/security/nettle/pkg-plist b/security/nettle/pkg-plist
index 458337577537..568d13f12792 100644
--- a/security/nettle/pkg-plist
+++ b/security/nettle/pkg-plist
@@ -1,5 +1,6 @@
bin/nettle-hash
bin/nettle-lfib-stream
+bin/nettle-pbkdf2
bin/pkcs1-conv
bin/sexp-conv
include/nettle/aes.h
@@ -14,13 +15,20 @@ include/nettle/buffer.h
include/nettle/camellia.h
include/nettle/cast128.h
include/nettle/cbc.h
+include/nettle/ccm.h
+include/nettle/chacha-poly1305.h
+include/nettle/chacha.h
include/nettle/ctr.h
+include/nettle/curve25519.h
include/nettle/des-compat.h
include/nettle/des.h
+include/nettle/dsa-compat.h
include/nettle/dsa.h
+include/nettle/eax.h
include/nettle/ecc-curve.h
include/nettle/ecc.h
include/nettle/ecdsa.h
+include/nettle/eddsa.h
include/nettle/gcm.h
include/nettle/gosthash94.h
include/nettle/hmac.h
@@ -37,9 +45,9 @@ include/nettle/nettle-types.h
include/nettle/pbkdf2.h
include/nettle/pgp.h
include/nettle/pkcs1.h
+include/nettle/poly1305.h
include/nettle/realloc.h
include/nettle/ripemd160.h
-include/nettle/rsa-compat.h
include/nettle/rsa.h
include/nettle/salsa20.h
include/nettle/serpent.h
@@ -50,14 +58,15 @@ include/nettle/sha2.h
include/nettle/sha3.h
include/nettle/twofish.h
include/nettle/umac.h
+include/nettle/version.h
include/nettle/yarrow.h
lib/libhogweed.a
lib/libhogweed.so
-lib/libhogweed.so.2
-lib/libhogweed.so.2.5
+lib/libhogweed.so.4
+lib/libhogweed.so.4.1
lib/libnettle.a
lib/libnettle.so
-lib/libnettle.so.4
-lib/libnettle.so.4.7
-libdata/pkgconfig/nettle.pc
+lib/libnettle.so.6
+lib/libnettle.so.6.1
libdata/pkgconfig/hogweed.pc
+libdata/pkgconfig/nettle.pc