aboutsummaryrefslogtreecommitdiff
path: root/security/nettle
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-24 11:25:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-24 11:25:04 +0000
commitdd5f0bf0844b2d46d840ee18e2f529a8466ef092 (patch)
treef3598997c6ea2f1ec9c24130240d888d63a23bb3 /security/nettle
parentec63bda918954820993c2692af3b4cb80d63d475 (diff)
downloadports-dd5f0bf0844b2d46d840ee18e2f529a8466ef092.tar.gz
ports-dd5f0bf0844b2d46d840ee18e2f529a8466ef092.zip
Notes
Diffstat (limited to 'security/nettle')
-rw-r--r--security/nettle/Makefile6
-rw-r--r--security/nettle/distinfo4
-rw-r--r--security/nettle/files/patch-Makefile.in14
-rw-r--r--security/nettle/files/patch-configure22
-rw-r--r--security/nettle/files/patch-examples_nettle-openssl.c29
-rw-r--r--security/nettle/pkg-plist20
6 files changed, 41 insertions, 54 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 715c289a8aa5..8ebbf4bd72da 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= nettle
-PORTVERSION= 1.7
-PORTREVISION= 2
+PORTVERSION= 1.13
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.lysator.liu.se/~nisse/archive/ \
ftp://ftp.lysator.liu.se/pub/security/lsh/
@@ -28,7 +28,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
INSTALLS_SHLIB= yes
DOCS= NEWS README TODO nettle.html
-EXAMPLES= examples/README examples/*.c examples/*.h
+EXAMPLES= examples/*.c examples/*.h
INFO= nettle
post-extract:
diff --git a/security/nettle/distinfo b/security/nettle/distinfo
index f477fc593dbe..027a5482c4f5 100644
--- a/security/nettle/distinfo
+++ b/security/nettle/distinfo
@@ -1,2 +1,2 @@
-MD5 (nettle-1.7.tar.gz) = 1212a2451530af024ce9253f01284ddd
-SIZE (nettle-1.7.tar.gz) = 497991
+MD5 (nettle-1.13.tar.gz) = 2e22612a0d7ac01064bf948a7d57f19a
+SIZE (nettle-1.7.tar.gz) = 775548
diff --git a/security/nettle/files/patch-Makefile.in b/security/nettle/files/patch-Makefile.in
index 5e9e5bd2c686..a46bc2fb063b 100644
--- a/security/nettle/files/patch-Makefile.in
+++ b/security/nettle/files/patch-Makefile.in
@@ -1,10 +1,10 @@
---- Makefile.in.orig Fri Oct 24 14:28:03 2003
-+++ Makefile.in Fri Oct 24 14:29:11 2003
-@@ -1067,7 +1067,6 @@ $(SHLIBFORLINK): $(SHLIBOBJECTS)
- install-shared: $(SHLIBFORLINK)
- $(INSTALL_DATA) $(SHLIBFORLINK) $(DESTDIR)$(libdir)/$(SHLIBFILE)
- (cd $(DESTDIR)$(libdir) \
+--- Makefile.in.orig Tue Nov 1 09:34:09 2005
++++ Makefile.in Tue Nov 1 09:34:24 2005
+@@ -221,7 +221,6 @@
+ $(INSTALL_PROGRAM) $(SHLIBFORLINK) $(DESTDIR)$(libdir)/$(SHLIBFILE)
+ [ -z "$(SHLIBSONAME)" ] \
+ || (cd $(DESTDIR)$(libdir) \
- && ln -sf $(SHLIBFILE) $(SHLIBSONAME) \
&& ln -sf $(SHLIBFILE) $(SHLIBFORLINK) )
- %.html : %.texinfo
+ install-info: nettle.info
diff --git a/security/nettle/files/patch-configure b/security/nettle/files/patch-configure
index 96c78f36792e..dceae170135b 100644
--- a/security/nettle/files/patch-configure
+++ b/security/nettle/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Fri Oct 24 14:27:53 2003
-+++ configure Fri Oct 24 14:28:43 2003
-@@ -3160,7 +3160,7 @@ fi
- SHLIBCFLAGS="-fpic"
- SHLIBFORLINK=libnettle.so
- SHLIBSONAME='$(SHLIBFORLINK).$(SHLIBMAJOR)'
--SHLIBFILE='$(SHLIBSONAME).$(SHLIBMINOR)'
-+SHLIBFILE='$(SHLIBSONAME)'
- SHLIBLINK='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME)'
-
- echo "enable_shared: $enable_shared"
+--- configure.orig Tue Nov 1 09:35:20 2005
++++ configure Tue Nov 1 09:36:28 2005
+@@ -2990,7 +2990,7 @@
+ *)
+ SHLIBFORLINK=libnettle.so
+ SHLIBSONAME='$(SHLIBFORLINK).$(SHLIBMAJOR)'
+- SHLIBFILE='$(SHLIBSONAME).$(SHLIBMINOR)'
++ SHLIBFILE='$(SHLIBSONAME)'
+ SHLIBLINK='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME)'
+ # FIXME: It might make some sense to link with -lgmp
+ SHLIBLIBS=''
diff --git a/security/nettle/files/patch-examples_nettle-openssl.c b/security/nettle/files/patch-examples_nettle-openssl.c
deleted file mode 100644
index dbd034518587..000000000000
--- a/security/nettle/files/patch-examples_nettle-openssl.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- examples/nettle-openssl.c.orig Fri Nov 8 16:05:20 2002
-+++ examples/nettle-openssl.c Thu May 1 12:52:10 2003
-@@ -93,7 +93,7 @@
- openssl_des_set_key(void *ctx, unsigned length, const uint8_t *key)
- {
- assert(length == 8);
-- des_key_sched((char *) key, ctx);
-+ des_key_sched((const_DES_cblock *)key, ctx);
- }
-
- #define DES_BLOCK_SIZE 8
-@@ -105,7 +105,7 @@
- assert (!(length % DES_BLOCK_SIZE));
- while (length)
- {
-- des_ecb_encrypt((char *) src, (char *) dst, ctx, DES_ENCRYPT);
-+ des_ecb_encrypt((const_DES_cblock *)src, (DES_cblock *)dst, ctx, DES_ENCRYPT);
- length -= DES_BLOCK_SIZE;
- dst += DES_BLOCK_SIZE;
- src += DES_BLOCK_SIZE;
-@@ -119,7 +119,7 @@
- assert (!(length % DES_BLOCK_SIZE));
- while (length)
- {
-- des_ecb_encrypt((char *) src, (char *) dst, ctx, DES_DECRYPT);
-+ des_ecb_encrypt((const_DES_cblock *) src, (DES_cblock *) dst, ctx, DES_DECRYPT);
- length -= DES_BLOCK_SIZE;
- dst += DES_BLOCK_SIZE;
- src += DES_BLOCK_SIZE;
diff --git a/security/nettle/pkg-plist b/security/nettle/pkg-plist
index efb4a6b17d3e..0d91f8fed635 100644
--- a/security/nettle/pkg-plist
+++ b/security/nettle/pkg-plist
@@ -1,24 +1,35 @@
bin/sexp-conv
+bin/nettle-lfib-stream
include/nettle/aes.h
include/nettle/arcfour.h
+include/nettle/arctwo.h
include/nettle/base16.h
include/nettle/base64.h
+include/nettle/bignum.h
include/nettle/blowfish.h
include/nettle/buffer.h
include/nettle/cast128.h
include/nettle/cbc.h
+include/nettle/ctr.h
include/nettle/des-compat.h
include/nettle/des.h
include/nettle/dsa.h
include/nettle/hmac.h
include/nettle/knuth-lfib.h
include/nettle/macros.h
+include/nettle/md2.h
+include/nettle/md4.h
include/nettle/md5-compat.h
include/nettle/md5.h
+include/nettle/memxor.h
include/nettle/nettle-meta.h
+include/nettle/nettle-types.h
+include/nettle/nettle-stdint.h
include/nettle/pgp.h
+include/nettle/pkcs1.h
include/nettle/realloc.h
include/nettle/rsa.h
+include/nettle/rsa-compat.h
include/nettle/serpent.h
include/nettle/sexp.h
include/nettle/sha.h
@@ -26,18 +37,23 @@ include/nettle/twofish.h
include/nettle/yarrow.h
@dirrm include/nettle
lib/libnettle.a
-lib/libnettle.so.1
+lib/libnettle.so.2
lib/libnettle.so
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/nettle.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/getopt.c
+%%EXAMPLESDIR%%/getopt1.c
+%%EXAMPLESDIR%%/getopt.h
%%EXAMPLESDIR%%/io.c
%%EXAMPLESDIR%%/nettle-benchmark.c
%%EXAMPLESDIR%%/nettle-openssl.c
+%%EXAMPLESDIR%%/rsa-decrypt.c
+%%EXAMPLESDIR%%/rsa-encrypt.c
%%EXAMPLESDIR%%/rsa-keygen.c
+%%EXAMPLESDIR%%/rsa-session.h
%%EXAMPLESDIR%%/rsa-sign.c
%%EXAMPLESDIR%%/rsa-verify.c
%%EXAMPLESDIR%%/io.h