aboutsummaryrefslogtreecommitdiff
path: root/security/newpki-server
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-14 13:58:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-14 13:58:43 +0000
commitf6febd09e04a14c68ed660d1c614d0d50fa4369e (patch)
tree7e318f230f700211ce19783d230ba78e816ce2e5 /security/newpki-server
parent64b73b6642ec5ccdfffcb138be54faf8a581be11 (diff)
Notes
Diffstat (limited to 'security/newpki-server')
-rw-r--r--security/newpki-server/Makefile62
-rw-r--r--security/newpki-server/distinfo2
-rw-r--r--security/newpki-server/files/patch-publications_ldap_configure11
-rw-r--r--security/newpki-server/files/patch-src_Makefile.in11
-rw-r--r--security/newpki-server/pkg-descr5
-rw-r--r--security/newpki-server/pkg-plist8
6 files changed, 99 insertions, 0 deletions
diff --git a/security/newpki-server/Makefile b/security/newpki-server/Makefile
new file mode 100644
index 000000000000..0162507a5ba7
--- /dev/null
+++ b/security/newpki-server/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: newpki-lib
+# Date created: 2005-07-05
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newpki-server
+DISTVERSION= 2.0.0-beta4
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= newpki
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= C++ PKI server from newpki project
+
+LIB_DEPENDS= newpki.2:${PORTSDIR}/security/newpki-lib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0.0
+
+USE_LIBTOOL_VER= 15
+USE_ICONV= yes
+USE_OPENSSL= yes
+USE_GMAKE= yes
+USE_MYSQL= yes
+USE_OPENLDAP= yes
+USE_REINPLACE= yes
+MANCOMPRESSED= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --with-newpki-include=${LOCALBASE}/include/newpki \
+ --with-newpki-lib=${LOCALBASE}/lib \
+ --with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --program-transform-name=
+
+MAN1= newpki-server.1
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-nls
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure \
+ ${WRKSRC}/publication/ldap/configure
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/conf/config.conf ${PREFIX}/etc/newpki.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/docs/newpki-server.1.gz ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/security/newpki-server/distinfo b/security/newpki-server/distinfo
new file mode 100644
index 000000000000..1896e83c6915
--- /dev/null
+++ b/security/newpki-server/distinfo
@@ -0,0 +1,2 @@
+MD5 (newpki-server-2.0.0-beta4.tar.gz) = dd4d1f3602261bc86ba72b78648ec647
+SIZE (newpki-server-2.0.0-beta4.tar.gz) = 686378
diff --git a/security/newpki-server/files/patch-publications_ldap_configure b/security/newpki-server/files/patch-publications_ldap_configure
new file mode 100644
index 000000000000..9db0d0bc68fc
--- /dev/null
+++ b/security/newpki-server/files/patch-publications_ldap_configure
@@ -0,0 +1,11 @@
+--- publication/ldap/configure.orig Wed Jul 6 23:16:06 2005
++++ publication/ldap/configure Wed Jul 6 23:17:19 2005
+@@ -7312,7 +7312,7 @@
+ # Prevent multiple expansion
+
+
+-libdir=/etc/newpki/modules
++libdir=$prefix/lib/newpki/modules
+
+ am__api_version="1.6"
+ # Find a good install program. We prefer a C program (faster),
diff --git a/security/newpki-server/files/patch-src_Makefile.in b/security/newpki-server/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..986df2ab5403
--- /dev/null
+++ b/security/newpki-server/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Jul 6 22:52:00 2005
++++ src/Makefile.in Wed Jul 6 22:55:51 2005
+@@ -212,7 +212,7 @@
+ newpki_server-RepStore_ASN1.$(OBJEXT) \
+ newpki_server-SQL.$(OBJEXT) newpki_server-SQL_Conn.$(OBJEXT)
+ newpki_server_OBJECTS = $(am_newpki_server_OBJECTS)
+-newpki_server_LDADD = $(LDADD)
++newpki_server_LDADD = $(LDADD) $(LTLIBINTL) $(LTLIBICONV)
+ newpki_server_DEPENDENCIES =
+ newpki_server_LDFLAGS =
+
diff --git a/security/newpki-server/pkg-descr b/security/newpki-server/pkg-descr
new file mode 100644
index 000000000000..661a33ae12a0
--- /dev/null
+++ b/security/newpki-server/pkg-descr
@@ -0,0 +1,5 @@
+NewPKI is a PKI based on the OpenSSL low-level API, all the datas are handled
+through a database, which provides a much more flexible PKI than with OpenSSL,
+such as seeking a certificate with a search engine.
+
+WWW: http://www.newpki.org
diff --git a/security/newpki-server/pkg-plist b/security/newpki-server/pkg-plist
new file mode 100644
index 000000000000..0909309ab196
--- /dev/null
+++ b/security/newpki-server/pkg-plist
@@ -0,0 +1,8 @@
+etc/newpki.conf.sample
+lib/newpki/modules/libpublication_ldap.la
+lib/newpki/modules/libpublication_ldap.so
+lib/newpki/modules/libpublication_ldap.so.0
+sbin/newpki-server
+%%NLS%%share/locale/fr/LC_MESSAGES/newpki-server.mo
+@dirrm lib/newpki/modules
+@dirrm lib/newpki