aboutsummaryrefslogtreecommitdiff
path: root/security/nikto
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-21 22:39:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-21 22:39:50 +0000
commit696016ba733f664b1528b4d48331d4f2fbc1b8ef (patch)
tree97d9671e465a30bc9917c9baf17bb6c71ed1aa13 /security/nikto
parent258a678bdeccb425a20f68feb0aa7b03381497a3 (diff)
downloadports-696016ba733f664b1528b4d48331d4f2fbc1b8ef.tar.gz
ports-696016ba733f664b1528b4d48331d4f2fbc1b8ef.zip
Notes
Diffstat (limited to 'security/nikto')
-rw-r--r--security/nikto/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index 32019a17266f..016c68da1e80 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nikto
PORTVERSION= 1.32
+PORTREVISION= 1
CATEGORIES= security www
MAINTAINER= ports@FreeBSD.org
@@ -21,6 +22,8 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net
NO_BUILD= yes
USE_REINPLACE= yes
+PORTDOCS= nikto_usage.txt nikto_usage.html CHANGES.txt README_plugins.txt
+
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
@${MKDIR} ${PREFIX}/etc/nikto && ${CHMOD} 755 ${PREFIX}/etc/nikto
@@ -32,5 +35,11 @@ do-install:
do \
${INSTALL_SCRIPT} ${WRKSRC}/plugins/$$i ${PREFIX}/share/nikto; \
done
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>