aboutsummaryrefslogtreecommitdiff
path: root/security/nmap/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-01-06 18:42:38 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-01-06 18:42:38 +0000
commitdfddabb5cdd6a0e2edb137b35c609011dc384b55 (patch)
treeb3544f3ae2c10f532f054641c53a200dc0321f75 /security/nmap/Makefile
parent7f69dd23ca96c869511aba05a8b9c17935b317c0 (diff)
Notes
Diffstat (limited to 'security/nmap/Makefile')
-rw-r--r--security/nmap/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 6bfd1dd7d830..15796d456524 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -1,13 +1,8 @@
-# Ports collection makefile for: nmap
-# Date created: Tue Aug 04, 1998
-# Whom: David O'Brien (obrien@NUXI.com)
-#
+# Created by: David O'Brien (obrien@NUXI.com)
# $FreeBSD$
-#
PORTNAME= nmap
-DISTVERSION= 6.01
-PORTREVISION= 1
+DISTVERSION= 6.25
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -18,7 +13,7 @@ COMMENT= Port scanning utility for large networks
# http://nmap.org/book/man-legal.html
LICENSE= GPLv2
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
USE_LUA= 5.1
LUA_COMPS= lua
@@ -34,7 +29,7 @@ CONFIGURE_ARGS= --without-localdirs \
CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
# fix for gcc from ports
-.if ${CC} != "cc"
+.if ${CC} != "cc" && ${CC} !="clang"
GCCLIBDIR_CMDS= ${CC} -print-file-name=libstdc++.so | ${SED} -e 's/libstdc++.so//'
CONFIGURE_ARGS+=LDFLAGS="-L$$(${GCCLIBDIR_CMDS})"
NDCC= true
@@ -74,6 +69,19 @@ PORTEXAMPLES= ${EXAMPLES:T}
post-extract:
@${RM} -rf ${WRKSRC}/mswin32
+# reflect new mailing addreses
+pre-patch:
+ @for f in $$(${GREP} -Rl "nmap-dev@insecure.org" ${WRKSRC}); do\
+ ${SED} -i '' -e 's|nmap-dev@insecure.org|dev@nmap.org|g' $${f} ;\
+ done
+ @for f in $$(${GREP} -Rl "http://cgi.insecure.org/mailman" ${WRKSRC}); do\
+ ${SED} -i '' -e 's|http://cgi.insecure.org/mailman/listinfo/nmap-dev|http://nmap.org/mailman/listinfo/dev|g' $${f} ;\
+ done
+
+post-patch:
+# fix from r30346
+ @${REINPLACE_CMD} -e 's|~0L;|0xffffffffL;|' ${WRKSRC}/nbase/nbase_misc.c
+
post-configure:
@${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|" ${WRKSRC}/Makefile