aboutsummaryrefslogtreecommitdiff
path: root/security/nmap/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2015-11-04 17:30:00 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2015-11-04 17:30:00 +0000
commitd521b0af5efd6d9310199fb9eb74d620aabfc1a7 (patch)
tree5526f86208d017f95cfbc09fd72fa59be70cd59c /security/nmap/Makefile
parent944c339d56fec9229be61afc592dac8f3a99da3f (diff)
downloadports-d521b0af5efd6d9310199fb9eb74d620aabfc1a7.tar.gz
ports-d521b0af5efd6d9310199fb9eb74d620aabfc1a7.zip
Notes
Diffstat (limited to 'security/nmap/Makefile')
-rw-r--r--security/nmap/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 170fff8a4da0..d734c23c05d0 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nmap
-DISTVERSION= 6.49BETA5
+DISTVERSION= 6.49BETA6
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -30,22 +30,16 @@ SSL_USE= OPENSSL=yes
SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
SSL_CONFIGURE_OFF= --without-openssl
SSL_CFLAGS= -I${OPENSSLINC}
+SSL_VARS= STRIP_FILES=ncat
+# PR: ports/159376 Workaround if OS is build with WITHOUT_INET6
+IPV6_LIB_DEPENDS_OFF= libpcap.so:${PORTSDIR}/net/libpcap
IPV6_CONFIGURE_OFF= --with-libpcap=${LOCALBASE}/IPv6
.include <bsd.port.options.mk>
-# PR: ports/159376 Workaround if OS is build with WITHOUT_INET6
-.if ! ${PORT_OPTIONS:MIPV6}
-LIB_DEPENDS+= libpcap.so:${PORTSDIR}/net/libpcap
-.endif
-
DOCS= CHANGELOG HACKING
-STRIP_FILES= nmap nping
-
-.if ${PORT_OPTIONS:MSSL}
-STRIP_FILES+= ncat
-.endif
+STRIP_FILES+= nmap nping
CONFIGURE_ARGS+=--without-localdirs \
--without-zenmap \
@@ -66,6 +60,8 @@ pre-install:
post-install:
${STRIP_CMD} ${STRIP_FILES:S|^|${STAGEDIR}${PREFIX}/bin/|}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}