aboutsummaryrefslogtreecommitdiff
path: root/security/nmap/Makefile
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-04-11 10:00:50 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-04-11 10:00:50 +0000
commite74fa876ace14ee32a6db74c4ee89f550376aaa8 (patch)
treed43134530ebfce8cd71e2d982ed43fd090859f93 /security/nmap/Makefile
parentcf914cb8b143445a0f912da01fb48eb24bb8af19 (diff)
Notes
Diffstat (limited to 'security/nmap/Makefile')
-rw-r--r--security/nmap/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 6c8d2708c4f8..55c9c23e94a5 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,23 +7,31 @@
#
PORTNAME?= nmap
-PORTVERSION= 3.00
-CATEGORIES= security
-MASTER_SITES= http://download.insecure.org/nmap/dist/ \
- http://www.mobis.com/ajax/projects/
+PORTVERSION= 3.20
+CATEGORIES= security ipv6
+MASTER_SITES= http://download.insecure.org/nmap/dist/
DISTNAME= nmap-${PORTVERSION:S/.b/BETA/}
-EXTRACT_SUFX= .tgz
MAINTAINER= d.marks@student.umist.ac.uk
COMMENT?= Port scanning utility for large networks
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+
+MAN1?= nmap.1
+
.include <bsd.port.pre.mk>
-GNU_CONFIGURE= yes
.if ${OSVERSION} < 300004
CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
.endif
-MAN1?= nmap.1
+
+CONFIGURE_TARGET= -build=${ARCH}-portbld-freebsd${OSREL}
+.if ${PORTNAME} == "nmap"
+CONFIGURE_ARGS+= --without-nmapfe
+.endif
+ALL_TARGET?= nmap
+INSTALL_TARGET?= install-nmap
.if !target(post-install) && (${PORTNAME} == "nmap")
post-install: