aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-25 19:04:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-25 19:04:40 +0000
commitd2286037657e2ee9a1f3726728f59ba85574af1f (patch)
tree008bccdc14083a53e05c1e9554051932866743c2 /security/nmap
parent7bc9469bedc65b042f0a205e63ac6745b85b08fa (diff)
downloadports-d2286037657e2ee9a1f3726728f59ba85574af1f.tar.gz
ports-d2286037657e2ee9a1f3726728f59ba85574af1f.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile3
-rw-r--r--security/nmap/distinfo6
-rw-r--r--security/nmap/files/patch-scan_engine.cc45
3 files changed, 4 insertions, 50 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 9fddefb333e6..123c2cef55c6 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,7 +7,6 @@
PORTNAME?= nmap
PORTVERSION= ${DISTVERSION:L:C/([a-z])[a-z]+/\1/g:C/[^a-z0-9+]+/./g}
-PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://download.insecure.org/nmap/dist/ \
http://www.mirrors.wiretapped.net/security/network-mapping/nmap/ \
@@ -18,7 +17,7 @@ DISTNAME= nmap-${DISTVERSION} # needed for security/nmapfe
MAINTAINER= daniel@roe.ch
COMMENT?= Port scanning utility for large networks
-DISTVERSION= 4.01
+DISTVERSION= 4.10
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index c354e40255e7..2f597f5d95b2 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,3 @@
-MD5 (nmap-4.01.tar.bz2) = 09c259837b24f6c7385c2c1c49760a7c
-SHA256 (nmap-4.01.tar.bz2) = 2b2cebaeee196dbf779cf7212b01dab8bb06b7e6807f45f3b62902bf84ffb58e
-SIZE (nmap-4.01.tar.bz2) = 1895276
+MD5 (nmap-4.10.tar.bz2) = 4c3fc7d227034892ade86892d8306b2a
+SHA256 (nmap-4.10.tar.bz2) = b90411a0030a188580de26ec3fd791fee590a946e4d0ecc5a9eff6a1aa29427b
+SIZE (nmap-4.10.tar.bz2) = 2130202
diff --git a/security/nmap/files/patch-scan_engine.cc b/security/nmap/files/patch-scan_engine.cc
deleted file mode 100644
index 5ea4ee9129cd..000000000000
--- a/security/nmap/files/patch-scan_engine.cc
+++ /dev/null
@@ -1,45 +0,0 @@
-$FreeBSD$
-
-Patch taken from <20060217013528.GG7214@syn.lnxnet.net>.
-http://seclists.org/lists/nmap-dev/2006/Jan-Mar/0205.html
-Will be included in nmap 4.02.
-
---- scan_engine.cc.ORIG Wed Mar 8 13:36:06 2006
-+++ scan_engine.cc Wed Mar 8 13:40:44 2006
-@@ -807,6 +807,7 @@
-
- /* Returns true if the GLOBAL system says that sending is OK.*/
- bool GroupScanStats::sendOK() {
-+ int recentsends;
-
- if (USI->scantype == CONNECT_SCAN && CSI->numSDs >= CSI->maxSocketsAllowed)
- return false;
-@@ -815,7 +816,9 @@
- the last listen call, at least for systems such as Windoze that
- don't give us a proper pcap time. Also for connect scans, since
- we don't get an exact response time with them either. */
-- if (USI->scantype == CONNECT_SCAN || !pcap_recv_timeval_valid()) {
-+ recentsends = USI->gstats->probes_sent - USI->gstats->probes_sent_at_last_wait;
-+ if (recentsends > 0 &&
-+ (USI->scantype == CONNECT_SCAN || !pcap_recv_timeval_valid())) {
- int to_ms = (int) MAX(to.srtt * .75 / 1000, 50);
- if (TIMEVAL_MSEC_SUBTRACT(USI->now, last_wait) > to_ms)
- return false;
-@@ -828,7 +831,7 @@
- responses when I scan localhost. And half of those are the @#$#
- sends being received. I think I'll put a limit of 50 sends per
- wait */
-- if (USI->gstats->probes_sent - USI->gstats->probes_sent_at_last_wait >= 50)
-+ if (recentsends >= 50)
- return false;
-
- /* When there is only one target left, let the host congestion
-@@ -969,7 +972,7 @@
-
- getTiming(&tmng);
- if (tmng.cwnd >= num_probes_active + .5 &&
-- (freshPortsLeft() || num_probes_waiting_retransmit)) {
-+ (freshPortsLeft() || num_probes_waiting_retransmit || !retry_stack.empty())) {
- if (when) *when = USI->now;
- return true;
- }