aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-01-13 22:43:17 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-01-13 22:43:17 +0000
commit78344c76b25982ec34ee23de2a4272bf103a40af (patch)
tree80393e75437c73afc097e97f435863ba14fdaf1e /security/nmap
parentb125d9d9c57992a33455a91fbeba2e975c7a8072 (diff)
downloadports-78344c76b25982ec34ee23de2a4272bf103a40af.tar.gz
ports-78344c76b25982ec34ee23de2a4272bf103a40af.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile3
-rw-r--r--security/nmap/files/patch-liblua__liolib.c15
2 files changed, 17 insertions, 1 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 15796d456524..0260a3d57b13 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nmap
DISTVERSION= 6.25
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -57,7 +58,7 @@ PLIST_SUB+= WITHSSL="@comment "
# be defined as param -DWITHOUT_INET6 during build time
# since the port system has no access to src.conf
.if defined(WITHOUT_INET6)
-LIB_DEPENDS+= pcap.1:${PORTSDIR}/net/libpcap
+LIB_DEPENDS+= pcap:${PORTSDIR}/net/libpcap
CONFIGURE_ARGS+= --with-libpcap=${LOCALBASE}
.endif
diff --git a/security/nmap/files/patch-liblua__liolib.c b/security/nmap/files/patch-liblua__liolib.c
new file mode 100644
index 000000000000..aae1461db922
--- /dev/null
+++ b/security/nmap/files/patch-liblua__liolib.c
@@ -0,0 +1,15 @@
+Fix build for FreeBSD-7.4
+nmap 6.25 contains liblua5.2.1
+
+http://lua-users.org/lists/lua-l/2011-12/msg00708.html
+==============================================================
+--- ./liblua/liolib.c.orig 2013-01-09 18:47:49.000000000 +0100
++++ ./liblua/liolib.c 2013-01-09 18:48:29.000000000 +0100
+@@ -19,6 +19,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+
+ #define liolib_c
+ #define LUA_LIB