aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-12-23 15:29:34 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-12-23 15:29:34 +0000
commit094ad8b9bf42f7d9bc3539fb98cf97c5abeacf9a (patch)
tree25df0ead00ed98f59cd3f4bbb590075ddec13d87 /security/nmap
parent167e729a4ad25c340c9db15b1fcd8afc4a6e4391 (diff)
downloadports-094ad8b9bf42f7d9bc3539fb98cf97c5abeacf9a.tar.gz
ports-094ad8b9bf42f7d9bc3539fb98cf97c5abeacf9a.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile8
-rw-r--r--security/nmap/files/patch-output.cc13
-rw-r--r--security/nmap/files/patch-tcpip.cc20
3 files changed, 34 insertions, 7 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 00df37251fa4..0f002335dccd 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -81,10 +81,4 @@ INSTALL_TARGET= install-nmapfe
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/nmap/files/patch-output.cc b/security/nmap/files/patch-output.cc
new file mode 100644
index 000000000000..7a1d364dfcb9
--- /dev/null
+++ b/security/nmap/files/patch-output.cc
@@ -0,0 +1,13 @@
+--- output.cc.orig Fri Dec 8 04:01:19 2006
++++ output.cc Mon Dec 18 15:50:13 2006
+@@ -742,8 +742,8 @@
+ case LOG_MACHINE:
+ case LOG_SKID:
+ case LOG_XML:
+-#ifdef WIN32
+- apcopy = ap;
++#if defined(WIN32) || (defined(FREEBSD) && (OSVERSION < 500000))
++ apcopy = ap;
+ #else
+ va_copy(apcopy, ap); /* Needed in case we need to so a second vnsprintf */
+ #endif
diff --git a/security/nmap/files/patch-tcpip.cc b/security/nmap/files/patch-tcpip.cc
new file mode 100644
index 000000000000..d4233a62e90a
--- /dev/null
+++ b/security/nmap/files/patch-tcpip.cc
@@ -0,0 +1,20 @@
+--- tcpip.cc.orig Fri Dec 8 04:01:19 2006
++++ tcpip.cc Mon Dec 18 15:48:46 2006
+@@ -1959,7 +1959,7 @@
+
+ // Returns whether the system supports pcap_get_selectable_fd() properly
+ bool pcap_selectable_fd_valid() {
+-#if defined(WIN32) || defined(MACOSX)
++#if defined(WIN32) || defined(MACOSX) || (defined(FREEBSD) && (OSVERSION < 500000))
+ return false;
+ #endif
+ return true;
+@@ -1972,7 +1972,7 @@
+ results. If you just want to test whether the function is supported,
+ use pcap_selectable_fd_valid() instead. */
+ int my_pcap_get_selectable_fd(pcap_t *p) {
+-#if defined(WIN32) || defined(MACOSX)
++#if defined(WIN32) || defined(MACOSX) || (defined(FREEBSD) && (OSVERSION < 500000))
+ return -1;
+ #else
+ assert(pcap_selectable_fd_valid());