aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2019-12-30 12:38:05 +0000
committerBen Woods <woodsb02@FreeBSD.org>2019-12-30 12:38:05 +0000
commit0e18b95bd561223108587e1a24fa5bae13cf2d4b (patch)
tree393c9427770377d458201a2ea8e6ad3753a51d71 /security/nmap
parentaba53255ae00b083da76d547628fafbcf52aa389 (diff)
downloadports-0e18b95bd561223108587e1a24fa5bae13cf2d4b.tar.gz
ports-0e18b95bd561223108587e1a24fa5bae13cf2d4b.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile2
-rw-r--r--security/nmap/distinfo6
-rw-r--r--security/nmap/files/patch-configure15
-rw-r--r--security/nmap/files/patch-libdnet-stripped_src_arp-ioctl.c14
-rw-r--r--security/nmap/files/patch-ncat_configure11
-rw-r--r--security/nmap/files/patch-nping_configure11
-rw-r--r--security/nmap/pkg-plist18
7 files changed, 54 insertions, 23 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 10e7cb7ef8af..a6dc4f91847c 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nmap
-DISTVERSION= 7.70
+DISTVERSION= 7.80
PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= https://nmap.org/dist/ \
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index f36fbb8e2136..9a11dffb2990 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521565225
-SHA256 (nmap-7.70.tar.bz2) = 847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18
-SIZE (nmap-7.70.tar.bz2) = 10467371
+TIMESTAMP = 1575679617
+SHA256 (nmap-7.80.tar.bz2) = fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa
+SIZE (nmap-7.80.tar.bz2) = 10550327
diff --git a/security/nmap/files/patch-configure b/security/nmap/files/patch-configure
index 8ef57a7f7fff..e8eb0ae905c1 100644
--- a/security/nmap/files/patch-configure
+++ b/security/nmap/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-07-31 19:09:47 UTC
+--- configure.orig 2019-05-24 18:28:49 UTC
+++ configure
-@@ -2583,7 +2583,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLA
+@@ -2542,7 +2542,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $
ac_compiler_gnu=$ac_cv_c_compiler_gnu
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
@@ -9,7 +9,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if ${ac_cv_prog_CC+:} false; then :
-@@ -3416,7 +3416,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLA
+@@ -3375,7 +3375,7 @@ ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $
ac_compiler_gnu=$ac_cv_c_compiler_gnu
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
@@ -18,3 +18,12 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if ${ac_cv_prog_CC+:} false; then :
+@@ -6365,7 +6365,7 @@ if test $have_libpcap != yes; then
+ else
+ CPPFLAGS="$CPPFLAGS -I\$(top_srcdir)/$libpcapdir"
+ fi
+- LIBPCAP_LIBS='$(LIBPCAPDIR)/libpcap.a'
++ LIBPCAP_LIBS='$(LIBPCAPDIR)/libpcap.a -libverbs'
+ PCAP_BUILD="build-pcap"
+ PCAP_CLEAN="clean-pcap"
+ PCAP_DIST_CLEAN="distclean-pcap"
diff --git a/security/nmap/files/patch-libdnet-stripped_src_arp-ioctl.c b/security/nmap/files/patch-libdnet-stripped_src_arp-ioctl.c
deleted file mode 100644
index 19ffb7f037d0..000000000000
--- a/security/nmap/files/patch-libdnet-stripped_src_arp-ioctl.c
+++ /dev/null
@@ -1,14 +0,0 @@
-# Use correct width in sscanf. Fixes #1156
-# https://github.com/nmap/nmap/commit/36a6d897a584013d25e51ac339fe45ffc45df9df
-
---- libdnet-stripped/src/arp-ioctl.c.orig 2008-09-19 06:12:25 UTC
-+++ libdnet-stripped/src/arp-ioctl.c
-@@ -218,7 +218,7 @@ arp_loop(arp_t *a, arp_handler callback,
-
- ret = 0;
- while (fgets(buf, sizeof(buf), fp) != NULL) {
-- i = sscanf(buf, "%s 0x%x 0x%x %100s %100s %100s\n",
-+ i = sscanf(buf, "%s 0x%x 0x%x %99s %99s %99s\n",
- ipbuf, &type, &flags, macbuf, maskbuf, devbuf);
-
- if (i < 4 || (flags & ATF_COM) == 0)
diff --git a/security/nmap/files/patch-ncat_configure b/security/nmap/files/patch-ncat_configure
new file mode 100644
index 000000000000..fb644bde9ef1
--- /dev/null
+++ b/security/nmap/files/patch-ncat_configure
@@ -0,0 +1,11 @@
+--- ncat/configure.orig 2019-12-08 01:42:55 UTC
++++ ncat/configure
+@@ -4934,7 +4934,7 @@ fi
+ LIBS="$LIBS_OLD"
+ fi
+
+-PCAP_LIBS="-lpcap"
++PCAP_LIBS="-lpcap -libverbs"
+ if test $have_libpcap = yes; then
+ PCAP_DEPENDS=""
+ PCAP_BUILD=""
diff --git a/security/nmap/files/patch-nping_configure b/security/nmap/files/patch-nping_configure
new file mode 100644
index 000000000000..f36960ccfe9c
--- /dev/null
+++ b/security/nmap/files/patch-nping_configure
@@ -0,0 +1,11 @@
+--- nping/configure.orig 2019-01-31 23:28:21 UTC
++++ nping/configure
+@@ -5356,7 +5356,7 @@ if test $have_libpcap != yes; then
+ LDFLAGS="-L$libpcapdir $LDFLAGS"
+ CPPFLAGS="$CPPFLAGS -I$libpcapdir"
+ fi
+- LIBPCAP_LIBS='$(LIBPCAPDIR)/libpcap.a'
++ LIBPCAP_LIBS='$(LIBPCAPDIR)/libpcap.a -libverbs'
+ PCAP_DEPENDS='$(LIBPCAPDIR)/libpcap.a'
+ PCAP_BUILD="build-pcap"
+ PCAP_CLEAN="clean-pcap"
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index 6c4f53e65fa5..b24c593dfd6d 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -39,7 +39,6 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/base32.lua
%%DATADIR%%/nselib/base64.lua
%%DATADIR%%/nselib/bin.lua
-%%DATADIR%%/nselib/bit.lua
%%DATADIR%%/nselib/bitcoin.lua
%%DATADIR%%/nselib/bits.lua
%%DATADIR%%/nselib/bittorrent.lua
@@ -127,6 +126,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/isns.lua
%%DATADIR%%/nselib/jdwp.lua
%%DATADIR%%/nselib/json.lua
+%%DATADIR%%/nselib/knx.lua
%%DATADIR%%/nselib/ldap.lua
%%DATADIR%%/nselib/lfs.luadoc
%%DATADIR%%/nselib/libssh2-utility.lua
@@ -155,6 +155,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/nrpc.lua
%%DATADIR%%/nselib/nsedebug.lua
%%DATADIR%%/nselib/omp2.lua
+%%DATADIR%%/nselib/oops.lua
%%DATADIR%%/nselib/openssl.luadoc
%%DATADIR%%/nselib/ospf.lua
%%DATADIR%%/nselib/packet.lua
@@ -164,6 +165,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/pppoe.lua
%%DATADIR%%/nselib/proxy.lua
%%DATADIR%%/nselib/punycode.lua
+%%DATADIR%%/nselib/rand.lua
%%DATADIR%%/nselib/rdp.lua
%%DATADIR%%/nselib/re.lua
%%DATADIR%%/nselib/redis.lua
@@ -190,8 +192,10 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/nselib/stdnse.lua
%%DATADIR%%/nselib/strbuf.lua
%%DATADIR%%/nselib/strict.lua
+%%DATADIR%%/nselib/stringaux.lua
%%DATADIR%%/nselib/stun.lua
%%DATADIR%%/nselib/tab.lua
+%%DATADIR%%/nselib/tableaux.lua
%%DATADIR%%/nselib/target.lua
%%DATADIR%%/nselib/tftp.lua
%%DATADIR%%/nselib/tls.lua
@@ -245,7 +249,9 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/broadcast-dns-service-discovery.nse
%%DATADIR%%/scripts/broadcast-dropbox-listener.nse
%%DATADIR%%/scripts/broadcast-eigrp-discovery.nse
+%%DATADIR%%/scripts/broadcast-hid-discoveryd.nse
%%DATADIR%%/scripts/broadcast-igmp-discovery.nse
+%%DATADIR%%/scripts/broadcast-jenkins-discover.nse
%%DATADIR%%/scripts/broadcast-listener.nse
%%DATADIR%%/scripts/broadcast-ms-sql-discover.nse
%%DATADIR%%/scripts/broadcast-netbios-master-browser.nse
@@ -359,7 +365,6 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/hnap-info.nse
%%DATADIR%%/scripts/hostmap-bfk.nse
%%DATADIR%%/scripts/hostmap-crtsh.nse
-%%DATADIR%%/scripts/hostmap-ip2hosts.nse
%%DATADIR%%/scripts/hostmap-robtex.nse
%%DATADIR%%/scripts/http-adobe-coldfusion-apsa1301.nse
%%DATADIR%%/scripts/http-affiliate-id.nse
@@ -409,6 +414,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-google-malware.nse
%%DATADIR%%/scripts/http-grep.nse
%%DATADIR%%/scripts/http-headers.nse
+%%DATADIR%%/scripts/http-hp-ilo-info.nse
%%DATADIR%%/scripts/http-huawei-hg5xx-vuln.nse
%%DATADIR%%/scripts/http-icloud-findmyiphone.nse
%%DATADIR%%/scripts/http-icloud-sendmsg.nse
@@ -440,6 +446,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-robots.txt.nse
%%DATADIR%%/scripts/http-robtex-reverse-ip.nse
%%DATADIR%%/scripts/http-robtex-shared-ns.nse
+%%DATADIR%%/scripts/http-sap-netweaver-leak.nse
%%DATADIR%%/scripts/http-security-headers.nse
%%DATADIR%%/scripts/http-server-header.nse
%%DATADIR%%/scripts/http-shellshock.nse
@@ -493,6 +500,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/http-wordpress-enum.nse
%%DATADIR%%/scripts/http-wordpress-users.nse
%%DATADIR%%/scripts/http-xssed.nse
+%%DATADIR%%/scripts/https-redirect.nse
%%DATADIR%%/scripts/iax2-brute.nse
%%DATADIR%%/scripts/iax2-version.nse
%%DATADIR%%/scripts/icap-info.nse
@@ -542,6 +550,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/lexmark-config.nse
%%DATADIR%%/scripts/llmnr-resolve.nse
%%DATADIR%%/scripts/lltd-discovery.nse
+%%DATADIR%%/scripts/lu-enum.nse
%%DATADIR%%/scripts/maxdb-info.nse
%%DATADIR%%/scripts/mcafee-epo-agent.nse
%%DATADIR%%/scripts/membase-brute.nse
@@ -638,6 +647,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/quake3-info.nse
%%DATADIR%%/scripts/quake3-master-getservers.nse
%%DATADIR%%/scripts/rdp-enum-encryption.nse
+%%DATADIR%%/scripts/rdp-ntlm-info.nse
%%DATADIR%%/scripts/rdp-vuln-ms12-020.nse
%%DATADIR%%/scripts/realvnc-auth-bypass.nse
%%DATADIR%%/scripts/redis-brute.nse
@@ -699,6 +709,8 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/smb-vuln-ms10-061.nse
%%DATADIR%%/scripts/smb-vuln-ms17-010.nse
%%DATADIR%%/scripts/smb-vuln-regsvc-dos.nse
+%%DATADIR%%/scripts/smb-vuln-webexec.nse
+%%DATADIR%%/scripts/smb-webexec-exploit.nse
%%DATADIR%%/scripts/smb2-capabilities.nse
%%DATADIR%%/scripts/smb2-security-mode.nse
%%DATADIR%%/scripts/smb2-time.nse
@@ -775,6 +787,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/traceroute-geolocation.nse
%%DATADIR%%/scripts/tso-brute.nse
%%DATADIR%%/scripts/tso-enum.nse
+%%DATADIR%%/scripts/ubiquiti-discovery.nse
%%DATADIR%%/scripts/unittest.nse
%%DATADIR%%/scripts/unusual-port.nse
%%DATADIR%%/scripts/upnp-info.nse
@@ -788,6 +801,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/vnc-title.nse
%%DATADIR%%/scripts/voldemort-info.nse
%%DATADIR%%/scripts/vtam-enum.nse
+%%DATADIR%%/scripts/vulners.nse
%%DATADIR%%/scripts/vuze-dht-info.nse
%%DATADIR%%/scripts/wdb-version.nse
%%DATADIR%%/scripts/weblogic-t3-info.nse