aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-05 22:24:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-05 22:24:16 +0000
commit35bf7feac6409175ca02916b9cf46dc8921c8342 (patch)
treeaac4e3aa23ffae020310166da39c05830db77068 /security/nmap
parent99601dc8c353516d0caeb19c39996c93fa2df943 (diff)
downloadports-35bf7feac6409175ca02916b9cf46dc8921c8342.tar.gz
ports-35bf7feac6409175ca02916b9cf46dc8921c8342.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile8
-rw-r--r--security/nmap/distinfo6
-rw-r--r--security/nmap/files/patch-Makefile.in10
-rw-r--r--security/nmap/files/patch-configure12
-rw-r--r--security/nmap/files/patch-ncat__ncat_core.c12
-rw-r--r--security/nmap/pkg-plist14
6 files changed, 28 insertions, 34 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 77fb663a6390..76ff4164c28e 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nmap
-DISTVERSION= 4.85BETA7
-PORTREVISION= 1
+DISTVERSION= 4.90RC1
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
http://www.mirrors.wiretapped.net/security/network-mapping/nmap/ \
@@ -17,8 +16,7 @@ MASTER_SITES= http://nmap.org/dist/ \
MAINTAINER= daniel@roe.ch
COMMENT= Port scanning utility for large networks
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- dnet.1:${PORTSDIR}/net/libdnet
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_LUA= 5.1
LUA_COMPS= lua
@@ -29,11 +27,11 @@ CONFIGURE_ARGS= --without-localdirs \
--without-zenmap \
--without-ndiff \
--with-libpcre=${LOCALBASE} \
- --with-libdnet=${LOCALBASE} \
--with-liblua=${LOCALBASE}
CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
MAN1= nmap.1 ncat.1
+PLIST_SUB= NCATDATADIR=share/ncat
.ifndef WITHOUT_SSL
USE_OPENSSL= yes
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index b1aaa5ef87eb..39637aece529 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,3 @@
-MD5 (nmap-4.85BETA7.tar.bz2) = 49218e9a5ec7b2628334b911a885b432
-SHA256 (nmap-4.85BETA7.tar.bz2) = dfff90a51fa44770a48dbeb31378d090ee334e4df2d013c8934f6ebf33eaabe5
-SIZE (nmap-4.85BETA7.tar.bz2) = 6454664
+MD5 (nmap-4.90RC1.tar.bz2) = 4355574dfdc3f86bfa85be0a6d9b5bf4
+SHA256 (nmap-4.90RC1.tar.bz2) = 92c02b6caf4781ff1ccaa24548ed1c7a599ea3616d57bfb496f93a2221d58723
+SIZE (nmap-4.90RC1.tar.bz2) = 9028130
diff --git a/security/nmap/files/patch-Makefile.in b/security/nmap/files/patch-Makefile.in
index 71329760543e..04b1646d2fcb 100644
--- a/security/nmap/files/patch-Makefile.in
+++ b/security/nmap/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2008-01-24 02:36:01.000000000 +0100
-+++ Makefile.in 2008-04-13 16:48:40.000000000 +0200
-@@ -11,7 +11,7 @@
+--- Makefile.in.orig 2009-06-24 23:35:54.000000000 +0200
++++ Makefile.in 2009-07-03 19:32:31.000000000 +0200
+@@ -10,7 +10,7 @@
+ mandir = @mandir@
srcdir = @srcdir@
- nmaplibexecdir = @libexecdir@/nmap
nmapdatadir = @datadir@/nmap
-deskdir = $(prefix)/share/applications
+deskdir = $(LOCALBASE)/share/applications
- NMAPDEVDIR=~/nmap-dev
+ NMAPDEVDIR=~/nmap-private-dev
export NBASEDIR=@NBASEDIR@
diff --git a/security/nmap/files/patch-configure b/security/nmap/files/patch-configure
index 2f3667f7a9c4..abafbd354df6 100644
--- a/security/nmap/files/patch-configure
+++ b/security/nmap/files/patch-configure
@@ -1,15 +1,15 @@
---- configure.orig 2008-06-15 09:05:12.000000000 +0200
-+++ configure 2008-08-03 12:41:04.000000000 +0200
-@@ -1930,7 +1930,7 @@
+--- configure.orig 2009-06-24 23:35:54.000000000 +0200
++++ configure 2009-07-03 19:35:52.000000000 +0200
+@@ -2047,7 +2047,7 @@
ac_compiler_gnu=$ac_cv_c_compiler_gnu
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
-set dummy ${ac_tool_prefix}gcc; ac_word=$2
+set dummy ${ac_tool_prefix}$CXX; ac_word=$2
- { echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+ { $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
+ $as_echo_n "checking for $ac_word... " >&6; }
if test "${ac_cv_prog_CC+set}" = set; then
-@@ -7337,8 +7337,8 @@
+@@ -7878,8 +7878,8 @@
no_lua="yes"
;;
*)
diff --git a/security/nmap/files/patch-ncat__ncat_core.c b/security/nmap/files/patch-ncat__ncat_core.c
deleted file mode 100644
index b9d7e06bb5ce..000000000000
--- a/security/nmap/files/patch-ncat__ncat_core.c
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: ncat/ncat_core.c
-diff -u -p ncat/ncat_core.c.orig ncat/ncat_core.c
---- ncat/ncat_core.c.orig 2009-04-02 11:57:42.000000000 +0900
-+++ ncat/ncat_core.c 2009-04-22 00:58:48.839927966 +0900
-@@ -89,6 +89,7 @@ int resolve(char *hostname, unsigned sho
-
- memset(&hints, 0, sizeof(hints));
- hints.ai_family = o.af;
-+ hints.ai_socktype = SOCK_DGRAM;
- if (o.nodns)
- hints.ai_flags |= AI_NUMERICHOST;
-
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index d52aa0c313ca..b3b934b73c54 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -1,9 +1,6 @@
bin/nmap
bin/ncat
%%DATADIR%%/scripts/script.db
-%%DATADIR%%/scripts/rpcinfo.nse
-%%DATADIR%%/scripts/nbstat.nse
-%%DATADIR%%/scripts/finger.nse
%%DATADIR%%/scripts/whois.nse
%%DATADIR%%/scripts/upnp-info.nse
%%DATADIR%%/scripts/telnet-brute.nse
@@ -11,6 +8,7 @@ bin/ncat
%%DATADIR%%/scripts/sshv1.nse
%%DATADIR%%/scripts/ssh-hostkey.nse
%%DATADIR%%/scripts/sql-injection.nse
+%%DATADIR%%/scripts/socks-open-proxy.nse
%%DATADIR%%/scripts/snmp-sysdescr.nse
%%DATADIR%%/scripts/snmp-brute.nse
%%DATADIR%%/scripts/sniffer-detect.nse
@@ -31,22 +29,28 @@ bin/ncat
%%DATADIR%%/scripts/smb-brute.nse
%%DATADIR%%/scripts/skypev2-version.nse
%%DATADIR%%/scripts/robots.txt.nse
+%%DATADIR%%/scripts/rpcinfo.nse
%%DATADIR%%/scripts/realvnc-auth-bypass.nse
%%DATADIR%%/scripts/pptp-version.nse
%%DATADIR%%/scripts/pop3-capabilities.nse
%%DATADIR%%/scripts/pop3-brute.nse
+%%DATADIR%%/scripts/p2p-conficker.nse
+%%DATADIR%%/scripts/nbstat.nse
%%DATADIR%%/scripts/mysql-info.nse
%%DATADIR%%/scripts/ms-sql-info.nse
%%DATADIR%%/scripts/irc-info.nse
+%%DATADIR%%/scripts/imap-capabilities.nse
%%DATADIR%%/scripts/iax2-version.nse
%%DATADIR%%/scripts/http-trace.nse
%%DATADIR%%/scripts/http-passwd.nse
%%DATADIR%%/scripts/http-open-proxy.nse
%%DATADIR%%/scripts/http-auth.nse
+%%DATADIR%%/scripts/http-iis-webdav-vuln.nse
%%DATADIR%%/scripts/html-title.nse
%%DATADIR%%/scripts/ftp-brute.nse
%%DATADIR%%/scripts/ftp-bounce.nse
%%DATADIR%%/scripts/ftp-anon.nse
+%%DATADIR%%/scripts/finger.nse
%%DATADIR%%/scripts/dns-zone-transfer.nse
%%DATADIR%%/scripts/dns-recursion.nse
%%DATADIR%%/scripts/dns-random-txid.nse
@@ -83,7 +87,9 @@ bin/ncat
%%DATADIR%%/nselib/msrpctypes.lua
%%DATADIR%%/nselib/msrpcperformance.lua
%%DATADIR%%/nselib/msrpc.lua
+%%DATADIR%%/nselib/imap.lua
@dirrm %%DATADIR%%/nselib
+%%DATADIR%%/nse_main.lua
%%DATADIR%%/nmap-mac-prefixes
%%DATADIR%%/nmap-os-db
%%DATADIR%%/nmap-protocols
@@ -93,6 +99,8 @@ bin/ncat
%%DATADIR%%/nmap.dtd
%%DATADIR%%/nmap.xsl
@dirrm %%DATADIR%%
+%%NCATDATADIR%%/ca-bundle.crt
+@dirrm %%NCATDATADIR%%
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/HACKING
%%PORTDOCS%%%%DOCSDIR%%/nmap.dtd