aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 00:53:05 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 00:53:05 +0000
commitd0bc78295475d769c54bb6627f20e9059e9f7470 (patch)
tree08f495acacc6aae6b338232de7b80762e286d718 /security/nmap
parent4344a7d1efa1bb6c850315f78ac3f956181bedfb (diff)
downloadports-d0bc78295475d769c54bb6627f20e9059e9f7470.tar.gz
ports-d0bc78295475d769c54bb6627f20e9059e9f7470.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile29
-rw-r--r--security/nmap/distinfo6
-rw-r--r--security/nmap/files/patch-Makefile.in13
-rw-r--r--security/nmap/files/patch-configure24
-rw-r--r--security/nmap/pkg-descr4
-rw-r--r--security/nmap/pkg-plist3
6 files changed, 44 insertions, 35 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index dc75a671152a..03b75237b50c 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= nmap
-PORTVERSION= 4.52
+PORTVERSION= 4.60
CATEGORIES= security ipv6
-MASTER_SITES= http://download.insecure.org/nmap/dist/ \
+MASTER_SITES= http://nmap.org/dist/ \
http://www.mirrors.wiretapped.net/security/network-mapping/nmap/ \
http://www.mirrorservice.org/sites/ftp.wiretapped.net/pub/security/network-mapping/nmap/ \
http://mirror.sg.depaul.edu/pub/security/nmap/
@@ -16,27 +16,24 @@ MASTER_SITES= http://download.insecure.org/nmap/dist/ \
MAINTAINER= daniel@roe.ch
COMMENT= Port scanning utility for large networks
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ dnet.1:${PORTSDIR}/net/libdnet
+
+USE_LUA= 5.1
+LUA_COMPS= lua
USE_BZIP2= yes
USE_GMAKE= yes
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-localdirs
-
+CONFIGURE_ARGS= --without-localdirs \
+ --without-zenmap \
+ --with-libpcre=${LOCALBASE} \
+ --with-libdnet=${LOCALBASE} \
+ --with-liblua=${LOCALBASE}
+CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= nmap.1
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- dnet.1:${PORTSDIR}/net/libdnet
-USE_LUA= 5.1
-LUA_COMPS= lua
-
-CONFIGURE_ARGS+= --without-zenmap \
- --with-libpcre=${LOCALBASE} \
- --with-libdnet=${LOCALBASE} \
- --with-liblua=${LOCALBASE}
-CONFIGURE_ENV= LUA_INCDIR="${LUA_INCDIR}" LUA_LIBDIR="${LUA_LIBDIR}"
-
.ifndef WITHOUT_SSL
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index 7cfeb1697ca5..2421b6207a0c 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,3 @@
-MD5 (nmap-4.52.tar.bz2) = 4f965a89e4e724d266dd9235c485633f
-SHA256 (nmap-4.52.tar.bz2) = ec44e89f12bb1c140e9e580f2ceee8950caa03537cf74f5718b25b19a476589a
-SIZE (nmap-4.52.tar.bz2) = 3147364
+MD5 (nmap-4.60.tar.bz2) = 6201551054050c11182fd6dd91682cb1
+SHA256 (nmap-4.60.tar.bz2) = 1c0c6a055761ac2952de49585a6d7209fdbc83aa8a88c8f7f736576a90571cca
+SIZE (nmap-4.60.tar.bz2) = 3213870
diff --git a/security/nmap/files/patch-Makefile.in b/security/nmap/files/patch-Makefile.in
index 98ebc43a82ea..21ce21185ce4 100644
--- a/security/nmap/files/patch-Makefile.in
+++ b/security/nmap/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sat Dec 1 01:21:28 2007
-+++ Makefile.in Fri Jan 4 17:05:28 2008
+--- Makefile.in.orig 2008-01-24 02:36:01.000000000 +0100
++++ Makefile.in 2008-04-13 16:48:40.000000000 +0200
@@ -11,7 +11,7 @@
srcdir = @srcdir@
nmaplibexecdir = @libexecdir@/nmap
@@ -9,3 +9,12 @@
NMAPDEVDIR=~/nmap-dev
export NBASEDIR=@NBASEDIR@
+@@ -178,7 +178,7 @@
+ # Use strip -x to avoid stripping dynamically loaded NSE functions. See
+ # http://seclists.org/nmap-dev/2007/q4/0272.html.
+ $(STRIP) -x $(DESTDIR)$(bindir)/nmap
+- $(INSTALL) -c -m 644 docs/$(TARGET).1 docs/zenmap.1 $(DESTDIR)$(mandir)/man1/
++ $(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/
+ $(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/
+ $(INSTALL) -c -m 644 docs/nmap.dtd $(DESTDIR)$(nmapdatadir)/
+ $(INSTALL) -c -m 644 nmap-services $(DESTDIR)$(nmapdatadir)/
diff --git a/security/nmap/files/patch-configure b/security/nmap/files/patch-configure
index 74215d921f00..b02fbbfd281c 100644
--- a/security/nmap/files/patch-configure
+++ b/security/nmap/files/patch-configure
@@ -1,15 +1,15 @@
---- configure.orig Thu Nov 29 10:36:33 2007
-+++ configure Sat Jan 12 16:57:04 2008
-@@ -1488,7 +1488,7 @@
- if test -z "$ac_cv_prog_CC"; then
- ac_ct_CC=$CC
- # Extract the first word of "gcc", so it can be a program name with args.
--set dummy gcc; ac_word=$2
-+set dummy $CXX; ac_word=$2
- echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
- if test "${ac_cv_prog_ac_ct_CC+set}" = set; then
-@@ -6781,9 +6781,10 @@
+--- configure.orig 2008-03-15 02:21:22.000000000 +0100
++++ configure 2008-04-13 17:16:35.000000000 +0200
+@@ -1929,7 +1929,7 @@
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+ if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}gcc", so it can be a program name with args.
+-set dummy ${ac_tool_prefix}gcc; ac_word=$2
++set dummy ${ac_tool_prefix}$CXX; ac_word=$2
+ { echo "$as_me:$LINENO: checking for $ac_word" >&5
+ echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+ if test "${ac_cv_prog_CC+set}" = set; then
+@@ -7174,9 +7174,10 @@
no_lua="yes"
;;
*)
diff --git a/security/nmap/pkg-descr b/security/nmap/pkg-descr
index da815059b3a8..a781de00127e 100644
--- a/security/nmap/pkg-descr
+++ b/security/nmap/pkg-descr
@@ -6,7 +6,7 @@ fingerprinting (remote host OS or device identification). Nmap also
offers flexible target and port specification, decoy/stealth scanning,
sunRPC scanning, and much more.
-WWW: http://www.insecure.org/nmap/
+WWW: http://nmap.org/
See the web page and the Phrack Magazine article (Volume 7, Issue 51
-September 01, 1997, article 11 of 17) http://www.insecure.org/nmap/p51-11.txt
+September 01, 1997, article 11 of 17) http://nmap.org/p51-11.html
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index 911ec017c417..ec67a0d6a931 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -44,8 +44,10 @@ libexec/nmap/nselib-bin/bit.so
%%DATADIR%%/scripts/HTTPpasswd.nse
%%DATADIR%%/scripts/HTTP_open_proxy.nse
%%DATADIR%%/scripts/HTTPAuth.nse
+%%DATADIR%%/scripts/UPnP-info.nse
%%DATADIR%%/scripts/zoneTrans.nse
@dirrm %%DATADIR%%/scripts
+%%DATADIR%%/nselib/http.lua
%%DATADIR%%/nselib/ipOps.lua
%%DATADIR%%/nselib/strbuf.lua
%%DATADIR%%/nselib/stdnse.lua
@@ -54,6 +56,7 @@ libexec/nmap/nselib-bin/bit.so
%%DATADIR%%/nselib/match.lua
%%DATADIR%%/nselib/listop.lua
%%DATADIR%%/nselib/url.lua
+%%DATADIR%%/nselib/tab.lua
@dirrm %%DATADIR%%/nselib
%%DATADIR%%/nmap-mac-prefixes
%%DATADIR%%/nmap-os-db